[Fixed] "hm" sound in Hexen

Bugs that have been investigated and resolved somehow.

Moderator: GZDoom Developers

"hm" sound in Hexen

Postby Hirogen2 » Sun Dec 28, 2003 12:44 pm

I found this oddity whilst playing Hexen:Deathkings.
You are on the last map (the map where you insert all four clock gears).
If you use the Daemon Codex (Class:puzzbook1) or Liber Obscura (Class:puzzbook2) on some lines, the "hm" player sound will play. On other line[defs] it won't.
I have experienced: when I try to arti-use any book on the normal book regals, no "hm" sound is played, when I use it on the book regals on the side (be it a door or a 1-sided linedef), the sound was played.
User avatar
Hirogen2
 
Joined: 19 Jul 2003
Location: Central Germany
Github ID: jengelh
Operating System: RedHat-like Linux (RHEL, Fedora, CentOS, etc) 64-bit
Graphics Processor: Intel (Modern GZDoom)

Postby Graf Zahl » Sun Dec 28, 2003 3:18 pm

The code responsible for this looks really messy with the sound calls at the wrong places. Instead of playing the sound when all checks have failed it's only played in a few special cases. For example, it the function searching for an object the puzzle item can be used on cannot find anything at all no sound is played. Two sided lines with open space behind are never considered blocking so that might explain why you don't hear the sound in the cases you describe.
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
 
Joined: 19 Jul 2003
Location: Germany

Postby randi » Thu Jan 08, 2004 7:20 pm

Fixed. Now it plays the sound every time "you cannot use this here" is printed. It seems strange Raven didn't have it like that to begin with.
User avatar
randi
Site Admin
 
Joined: 09 Jul 2003


Return to Closed Bugs

Who is online

Users browsing this forum: No registered users and 0 guests