[Duplicate] GZDoom for 64 bits crashes under Kubuntu

Bugs that have been investigated and resolved somehow.

Moderator: GZDoom Developers

GZDoom for 64 bits crashes under Kubuntu

Postby Ursula Snodlock » Sun Aug 02, 2020 8:42 pm

I'm using Kubuntu 20.04 on an Acer laptop, all packages are up to date. I tried out the .deb package in the website, and the game opens just fine. The problem arrives when trying to start a new playthrough, or sometimes even edit the preferences in the options menu. The window freezes, and from the terminal output, I think it has something to do with GLib/Gtk, as it throws dozens of errors related to Glib-GObject, case in point:


fluidsynth: warning: SDL2 not initialized, SDL2 audio driver won't be usable
fluidsynth: warning: SDL2 not initialized, SDL2 audio driver won't be usable

(process:16386): GLib-GObject-WARNING **: 22:38:18.287: cannot register existing type 'IpatchSplitsType'

(process:16386): GLib-GObject-CRITICAL **: 22:38:18.287: g_param_spec_enum: assertion 'G_TYPE_IS_ENUM (enum_type)' failed

** (process:16386): CRITICAL **: 22:38:18.287: ipatch_type_install_property: assertion 'G_IS_PARAM_SPEC(prop_spec)' failed

(process:16386): GLib-GObject-CRITICAL **: 22:38:18.287: g_boxed_type_register_static: assertion 'g_type_from_name (name) == 0' failed

(process:16386): GLib-GObject-WARNING **: 22:38:18.287: cannot register existing type 'IpatchSF2GenType'

(process:16386): GLib-GObject-WARNING **: 22:38:18.287: cannot retrieve class for invalid (unclassed) type '<invalid>'

** (process:16386): CRITICAL **: 22:38:18.287: file /build/libinstpatch-i701yY/libinstpatch-1.1.2/libinstpatch/IpatchSF2Gen.c: line 148 (_ipatch_sf2_gen_init): assertion `enum_class != NULL' failed.

(process:16386): GLib-GObject-WARNING **: 22:38:18.287: cannot register existing type 'IpatchSample'

(process:16386): GLib-GObject-WARNING **: 22:38:18.287: cannot register existing type 'IpatchItem'

(process:16386): GLib-GObject-CRITICAL **: 22:38:18.288: g_type_interface_add_prerequisite: assertion 'G_TYPE_IS_INTERFACE (interface_type)' failed

(process:16386): GLib-GObject-WARNING **: 22:38:18.288: cannot register existing type 'IpatchSF2GenItem'

(process:16386): GLib-GObject-WARNING **: 22:38:18.288: cannot register existing type 'IpatchItem'

(process:16386): GLib-GObject-CRITICAL **: 22:38:18.288: g_type_interface_add_prerequisite: assertion 'G_TYPE_IS_INTERFACE (interface_type)' failed

(process:16386): GLib-GObject-WARNING **: 22:38:18.288: cannot register existing type 'IpatchSF2ModItem'

(process:16386): GLib-GObject-WARNING **: 22:38:18.288: cannot register existing type 'IpatchItem'

(process:16386): GLib-GObject-CRITICAL **: 22:38:18.288: g_type_interface_add_prerequisite: assertion 'G_TYPE_IS_INTERFACE (interface_type)' failed

(process:16386): GLib-GObject-WARNING **: 22:38:18.288: cannot register existing type 'IpatchSF2VoiceCache'

(process:16386): GLib-GObject-WARNING **: 22:38:18.288: cannot retrieve class for invalid (unclassed) type '<invalid>'

(process:16386): GLib-GObject-WARNING **: 22:38:18.288: cannot register existing type 'IpatchItem'

(process:16386): GLib-GObject-CRITICAL **: 22:38:18.288: g_type_register_static: assertion 'parent_type > 0' failed

(process:16386): GLib-GObject-CRITICAL **: 22:38:18.288: g_type_register_static: assertion 'parent_type > 0' failed

(process:16386): GLib-CRITICAL **: 22:38:18.288: g_once_init_leave: assertion 'result != 0' failed

(process:16386): GLib-GObject-WARNING **: 22:38:18.288: cannot retrieve class for invalid (unclassed) type '<invalid>'

(process:16386): GLib-GObject-WARNING **: 22:38:18.288: cannot register existing type 'IpatchItem'

(process:16386): GLib-GObject-CRITICAL **: 22:38:18.288: g_type_register_static: assertion 'parent_type > 0' failed

(process:16386): GLib-GObject-WARNING **: 22:38:18.288: cannot retrieve class for invalid (unclassed) type '<invalid>'

(process:16386): GLib-GObject-WARNING **: 22:38:18.288: cannot register existing type 'IpatchConverter'

(process:16386): GLib-GObject-WARNING **: 22:38:18.288: cannot retrieve class for invalid (unclassed) type '<invalid>'
```

This doesn't seem to be a problem with the 32 bit version though
Ursula Snodlock
 

Re: GZDoom for 64 bits crashes under Kubuntu

Postby _mental_ » Sun Aug 02, 2020 11:42 pm

Duplicate of this report.
_mental_
 
 
 
Joined: 07 Aug 2011


Return to Closed Bugs

Who is online

Users browsing this forum: No registered users and 0 guests