Voxel models are too dark when Ambient Occlusion is enabled.

Moderator: GZDoom Developers

Forum rules
Please construct and post a simple demo whenever possible for all bug reports. Please provide links to everything.

If you can include a wad demonstrating the problem, please do so. Bug reports that include fully-constructed demos have a much better chance of being investigated in a timely manner than those that don't.

Please make a new topic for every bug. Don't combine multiple bugs into a single topic. Thanks!

Voxel models are too dark when Ambient Occlusion is enabled.

Postby axredneck » Wed Jun 19, 2019 4:09 pm

I believe it's because voxels don't have normals which are used by SSAO shader.
How to reproduce:
- Download and run any wad with voxels.
- Toggle Ambient Occlusion on/off while looking at voxel model(s).
Possible solution: render voxel models with invalid normals, e.g. vec3(0,0,0) or vec3(0,0,-1), and filter out pixels with such normals in SSAO shader.
User avatar
axredneck
excuse me for my bad English
 
Joined: 11 Dec 2017
Location: Russia
Github ID: axredneck
Operating System: Other Linux 64-bit
Graphics Processor: nVidia with Vulkan support

Return to OpenGL Renderer Bugs

Who is online

Users browsing this forum: No registered users and 2 guests