[Fixed] [Linux, modern 8ac864b] Black screen

Bugs that have been investigated and resolved somehow.

Moderator: Developers

[Linux, modern 8ac864b] Black screen

Postby Talon1024 » Fri Jun 29, 2018 7:08 am

Once I start a new game, load a saved game, start watching a demo or the titlemap, etc., the screen turns black, and I am unable to see anything. If I look at the automap, I see only a single white pixel in the center of the screen.

The main menu and console work just fine, however, except if the current mod has a titlemap.

Here is a startup log, if it provides any interesting details:
Code: Select allExpand view
GZDoom g3.5pre-161-g8ac864b - 2018-06-26 09:28:23 +0200 - SDL version
Compiled on Jun 26 2018

M_LoadDefaults: Load system defaults.
W_Init: Init WADfiles.
 adding /home/kevinc/Games/doom/gzdoom-modern-20180626/gzdoom.pk3, 622 lumps
 adding /home/kevinc/Games/doom/gzdoom-modern-20180626/zd_extra.pk3, 132 lumps
 adding /home/kevinc/Games/doom/IWADS/DOOM2.WAD, 2919 lumps
 adding lights.pk3, 6 lumps
 adding brightmaps.pk3, 500 lumps
 adding ../gzdoom/MusicPacks/Doom2PK3.pk3, 22 lumps
I_Init: Setting up machine state.
CPU Vendor ID: GenuineIntel
  Name: Intel(R) Core(TM) i5-4690K CPU @ 3.50GHz
  Family 6, Model 60, Stepping 3
  Features: SSE2 SSE3 SSSE3 SSE4.1 SSE4.2 HyperThreading
I_InitSound: Initializing OpenAL
  Opened device ALSA Default
  EFX enabled
V_Init: allocate screen.
S_Init: Setting up sound.
ST_Init: Init startup screen.
Checking cmd-line parameters...
S_InitData: Load sound definitions.
G_ParseMapInfo: Load map definitions.
Texman.Init: Init texture manager.
ParseTeamInfo: Load team definitions.
LoadActors: Load actor definitions.
script parsing took 97.81 ms
R_Init: Init Doom refresh subsystem.
DecalLibrary: Load decals.
M_Init: Init menus.
P_Init: Init Playloop state.
ParseSBarInfo: Loading custom status bar definition.
D_CheckNetGame: Checking network game status.
player 1 of 1 (1 nodes)
Using video driver x11
GL_VENDOR: NVIDIA Corporation
GL_RENDERER: GeForce GTX 970/PCIe/SSE2
GL_VERSION: 4.5.0 NVIDIA 390.67 (Core profile)
GL_SHADING_LANGUAGE_VERSION: 4.50 NVIDIA

Max. texture size: 16384
Max. texture units: 32
Max. varying: 124
Max. combined shader storage blocks: 96
Max. vertex shader storage blocks: 16
Resolution: 1280 x 1024
16 bots read from bots.cfg


map01 - entryway
Talon1024
 
 
 
Joined: 27 Jun 2016

Re: [Linux, modern 8ac864b] Black screen

Postby _mental_ » Fri Jun 29, 2018 8:07 am

I cannot check on Linux with OpenGL Core Profile but on macOS I managed to get black screen with Ambient Occlusion enabled, i.e. when gl_ssao CVAR is not zero.
However in my case this affects menu and automap as well. It's just solid black screen regardless of game mode until AO is turned off.

Please note that refactoring of postprocess effects is happening in the different branch.
Most likely this will be sorted out before (or right after) merging into master.
_mental_
 
 
 
Joined: 07 Aug 2011

Re: [Linux, modern 8ac864b] Black screen

Postby Talon1024 » Fri Jun 29, 2018 10:38 am

However in my case this affects menu and automap as well. It's just solid black screen regardless of game mode until AO is turned off.

That sucks. On the other hand, setting gl_ssao to 0 solved the black screen issue on my end as well.
Talon1024
 
 
 
Joined: 27 Jun 2016

Re: [Linux, modern 8ac864b] Black screen

Postby _mental_ » Sat Jun 30, 2018 2:56 am

Unfortunately hw_postprocess branch has the same problem.
In addition, palette tonemap mode causes a black screen too.

It's on macOS, I cannot check on Windows at the moment.
_mental_
 
 
 
Joined: 07 Aug 2011

Re: [Linux, modern 8ac864b] Black screen

Postby dpJudas » Sat Jun 30, 2018 4:32 am

On the hw_postprocess branch the palette tonemap is black because the second texture is somehow not bound correctly. I've spent quite some time trying to figure out why with little success.

I'll try convert the ssao pass to see if it magically repairs it, but given the problem I have with the tonemap I fear even if it fixes the original problem it might still remain broken.
dpJudas
 
 
 
Joined: 28 May 2016

Re: [Linux, modern 8ac864b] Black screen

Postby Graf Zahl » Thu Nov 01, 2018 2:23 am

Does this still happen?
User avatar
Graf Zahl
Lead GZDoom Developer
 
Joined: 19 Jul 2003
Location: Germany

Re: [Linux, modern 8ac864b] Black screen

Postby Talon1024 » Thu Nov 01, 2018 9:47 am

No. This bug is fixed.
Talon1024
 
 
 
Joined: 27 Jun 2016


Return to Closed Bugs

Who is online

Users browsing this forum: PlayerLin and 0 guests