[Not GZDoom] Turning off Shadowmaps disables lights on restart

Bugs that have been investigated and resolved somehow.

Moderator: Developers

Turning off Shadowmaps disables lights on restart

Postby Hexereticdoom » Sun Jun 10, 2018 8:42 pm

Hello there, I have found recently a strange behaviour related to most recent versions of GZDoom and QZDoom...

The issue is, having the Light Shadowmaps option activated in Dynamic Light options, if you decide to toggle it off, close the menu and exiting normally from the program, on next restart and then entering to any level (for example, IDCLEV on map 28 of Doom II) you'll be able to see the lamp/torch spotlights are completely deactivated by default.

To make them visible, you have to toggle on again the Light Shadowmaps option or you won't get spotlights at all, even having loaded correctly the provided Lights.pk3 file.

The problem can be reproduced on GZDoom 3.4.0 and QZDoom 2.1.0, no matter if you load or not any mods/addons with Doom. However, I did not have this issue at all when I was using QZDoom 2.0.0 or some older releases of GZDoom.

Hope you can fix it in a future release, thanks in advance! :)
User avatar
Hexereticdoom
Don't make me angry or I'll bite you! Heheheee...
 
Joined: 08 Aug 2013
Location: Spain

Re: Turning off Shadowmaps disables lights on restart

Postby _mental_ » Mon Jun 11, 2018 2:23 am

Dynamic lights work fine for me regardless of light shadowmaps setting.
Also, it's disabled by default and so, dynamic lights should not work without this feature.
Could you please try with default settings, i.e. without .ini file?
_mental_
 
 
 
Joined: 07 Aug 2011

Re: Turning off Shadowmaps disables lights on restart

Postby Hexereticdoom » Tue Jun 12, 2018 7:22 pm

_mental_ wrote:Dynamic lights work fine for me regardless of light shadowmaps setting.
Also, it's disabled by default and so, dynamic lights should not work without this feature.
Could you please try with default settings, i.e. without .ini file?

OK, I have tested it deleting the INI file and started with all the default settings, but seems I obtain the same result...

No visible dynamic lights at all, until I toggle the shadowmaps option. But once toggled on or off, the lights are fully visible. To be more precise, if I leave it 'on', the dynamic lights load OK on next program restart. But if I leave it 'off', the lights won't show by default on next restart.

Is it intended to work that way? On QZDoom 2.0.0 this did not happen, neither on GZDoom 3.1.0 (also tested). However, it does with QZDoom 2.1.0 and GZDoom 3.4.0.

May this issue be related to my graphic card? For your info, it's a Radeon 7470M on an ASUS X54H laptop, mounted by manufacturer. Pretty old, I know... :|
User avatar
Hexereticdoom
Don't make me angry or I'll bite you! Heheheee...
 
Joined: 08 Aug 2013
Location: Spain

Re: Turning off Shadowmaps disables lights on restart

Postby Graf Zahl » Wed Jun 13, 2018 12:32 am

This should already be fixed. Please recheck with a recent devbuild.
User avatar
Graf Zahl
Lead GZDoom Developer
 
Joined: 19 Jul 2003
Location: Germany

Re: Turning off Shadowmaps disables lights on restart

Postby Hexereticdoom » Wed Jun 13, 2018 7:30 pm

Graf Zahl wrote:This should already be fixed. Please recheck with a recent devbuild.

Tested again with GZDoom 3.5 prebuild 33, and also with 3.4.1 (released some minutes ago) and the issue still persists... :shrug:

However, I have discovered something, it could be an useful tip: the lamps/torches can be seen illuminated themselves, if you look closely. The textures around (floors and walls) are the ones that don't get illuminated by the source light in any way, until you finally toggle on shadowmaps.

Pretty strange, isn't it?
User avatar
Hexereticdoom
Don't make me angry or I'll bite you! Heheheee...
 
Joined: 08 Aug 2013
Location: Spain

Re: Turning off Shadowmaps disables lights on restart

Postby landfill baby » Fri Jun 15, 2018 5:40 pm

I have a similar problem, dynamic lights won't light the walls, ceilings, and floors in the GL renderer, except on the first frame during the intro wipe (e.g. E1M1 in 16:9), no matter what settings I use.
Tested on 3.4.1 and 3.5 pre 44, Win32, OpenGL 3.3, ATI Mobility Radeon HD 5165 (4650 but with higher clock speed)
edit: if i turn wipes off it works????
Last edited by landfill baby on Mon Jul 02, 2018 10:56 am, edited 1 time in total.
User avatar
landfill baby
 
Joined: 31 Jan 2017

Re: Turning off Shadowmaps disables lights on restart

Postby Hexereticdoom » Fri Jun 29, 2018 8:01 pm

Well, I guess until this issue gets resolved I'll have no more choice than switch back again to QZDoom 2.0.0, because the 'forced' activation of Shadowmaps from 2.1.0 to make spotlights working OK is provoking serious framerate drops in my laptop on some light complex maps, specially on Doom II's 13th level... :?
User avatar
Hexereticdoom
Don't make me angry or I'll bite you! Heheheee...
 
Joined: 08 Aug 2013
Location: Spain

Re: Turning off Shadowmaps disables lights on restart

Postby Graf Zahl » Sun Jul 15, 2018 2:17 am

Testing with a recent build from the "modern" branch and a two week old version of the "master" branch I cannot reproduce any of this, the lights are always present. It doesn't matter whether I enable or disable shadowmaps or even force -glversion 3.3 - it looks correct in all those cases, even with -glversion 2.1 on the older build.
User avatar
Graf Zahl
Lead GZDoom Developer
 
Joined: 19 Jul 2003
Location: Germany

Re: Turning off Shadowmaps disables lights on restart

Postby Hexereticdoom » Mon Jul 16, 2018 6:59 pm

Hmmm, OK then... Since I have recently switched to Linux Mint on my laptop and erased Windows 10 for good, I'll try as soon as I can the latest available GZDoom version for this system and I'll test if the problem is also present here. I've got the feeling that the main trouble could be probably caused by the AMD graphic card driver (provided by Windows update), but now that this new Linux OS uses a different and non-propietary driver, the results might not be the same...

I'll give you a response ASAP!
User avatar
Hexereticdoom
Don't make me angry or I'll bite you! Heheheee...
 
Joined: 08 Aug 2013
Location: Spain

Re: Turning off Shadowmaps disables lights on restart

Postby Hexereticdoom » Thu Jul 26, 2018 8:19 pm

Well, after some days of familiarization with my new not-windows OS and a few testings, I can confirm definitely that the reported error in this thread is NOT present in Linux Mint, the GZDoom's Shadowmaps toggle option works as expected, without making any light mess. So it was an exclusive Windows 10 graphic driver problem, after all!

On the other hand, the AMD non-propietary graphic driver seems to work quite slower than with the Windows one, judging by the internal FPS counter and specially at fullscreen mode (1366x768), but at least starting GZDoom with -glversion2 command line the game experience is smoother and pretty more enjoyable without all that frame droppings. Yeah, I guess someday I'll have to renovate my good old laptop for a more modern one... :|

So then on my side, the main issue has been resolved... Thanks everybody for your help! :thumb:
User avatar
Hexereticdoom
Don't make me angry or I'll bite you! Heheheee...
 
Joined: 08 Aug 2013
Location: Spain


Return to Closed Bugs

Who is online

Users browsing this forum: No registered users and 0 guests