Black dropshadow showing underneath certain sprites

Moderator: GZDoom Developers

Forum rules
Please construct and post a simple demo whenever possible for all bug reports. Please provide links to everything.

If you can include a wad demonstrating the problem, please do so. Bug reports that include fully-constructed demos have a much better chance of being investigated in a timely manner than those that don't.

Please make a new topic for every bug. Don't combine multiple bugs into a single topic. Thanks!

Black dropshadow showing underneath certain sprites

Postby DenisBelmondo » Fri Dec 21, 2018 5:05 am

Spoiler: "Dropshadow" shown flashing in green


I forgot to report this a while ago, but in the software renderer there seems to be dropshadows appearing underneath certain sprites, most of them being these "particle" actors (blood, bullet smoke, etc.). Unfortunately, I do not know any more details than this.

Here is an archive isolating the blood particles displaying this problematic behavior: Link
User avatar
DenisBelmondo
now is time to the i386 heart on fire
 
Joined: 06 Jun 2008
Location: Two-Key Return

Re: Black dropshadow showing underneath certain sprites

Postby DenisBelmondo » Mon Dec 24, 2018 10:47 pm

Apologies for the bump, I thought it would be appropriate since this may provide additional insight. I've found that this particular effect happens on decals as well. As you can see, the gib decals (they are only "sprayed" by gibs which are in turn, spawned by xdeathing monsters) as shown in Dead Marine are also a victim of this strange bug. The "shadows" are once again highlighted in green below:

Image

I wish i could provide more details, but after some time of testing and fiddling with my own mods, I just can't seem to figure out what triggers this.
User avatar
DenisBelmondo
now is time to the i386 heart on fire
 
Joined: 06 Jun 2008
Location: Two-Key Return

Re: Black dropshadow showing underneath certain sprites

Postby dpJudas » Tue Dec 25, 2018 12:52 am

When did this start happening? It looks a sampling error or maybe the spans being off by one.
dpJudas
 
 
 
Joined: 28 May 2016

Re: Black dropshadow showing underneath certain sprites

Postby DenisBelmondo » Tue Dec 25, 2018 1:41 am

dpJudas wrote:When did this start happening? It looks a sampling error or maybe the spans being off by one.


Unfortunately I don't quite remember that well, but roughly a year and a half ago?
User avatar
DenisBelmondo
now is time to the i386 heart on fire
 
Joined: 06 Jun 2008
Location: Two-Key Return


Return to Software Renderer Bugs

Who is online

Users browsing this forum: No registered users and 1 guest

cron