New texture refactor broke translucency on single-file texs

Moderator: GZDoom Developers

Forum rules
Please construct and post a simple demo whenever possible for all bug reports. Please provide links to everything.

If you can include a wad demonstrating the problem, please do so. Bug reports that include fully-constructed demos have a much better chance of being investigated in a timely manner than those that don't.

Please make a new topic for every bug. Don't combine multiple bugs into a single topic. Thanks!

New texture refactor broke translucency on single-file texs

Postby ZZYZX » Sun Dec 16, 2018 11:30 am

When I say single-file, I'm referring to those in textures directory or inside TX_ markers.
Example wad attached. The image should be translucent.

It only looks correct with vid_rendermode 3, in all other renderers it's differently non-translucent.
Rendermode 1: https://i.imgur.com/3ydKM9F.png
Rendermode 4,0,2: https://i.imgur.com/xdowJep.png
Rendermode 3: https://i.imgur.com/3IypTsk.png

Reported against cc52f8937
Attachments
badtexturemap.wad
(48.85 KiB) Downloaded 27 times
User avatar
ZZYZX
le chat du rabbin
 
 
 
Joined: 14 Oct 2012
Location: Ukraine

Re: New texture refactor broke translucency on single-file t

Postby Graf Zahl » Sun Dec 16, 2018 1:17 pm

Fixed for the hardware renderer. Why the true color software renderer isn't doing this right, but the softpoly renderer is, is something to be answered by someone else, preferably dpJudas.
User avatar
Graf Zahl
Lead GZDoom Developer
Lead GZDoom Developer
 
Joined: 19 Jul 2003
Location: Germany

Re: New texture refactor broke translucency on single-file t

Postby dpJudas » Sun Dec 16, 2018 7:49 pm

I have no idea why it does this for the true color software renderer. It probably picks the wrong drawer.
dpJudas
 
 
 
Joined: 28 May 2016


Return to Software Renderer Bugs

Who is online

Users browsing this forum: No registered users and 1 guest