[ZDoom 2.6.1 ] Sprites visible behind sectors with 3D floors

Moderator: GZDoom Developers

Forum rules
Please construct and post a simple demo whenever possible for all bug reports. Please provide links to everything.

If you can include a wad demonstrating the problem, please do so. Bug reports that include fully-constructed demos have a much better chance of being investigated in a timely manner than those that don't.

Please make a new topic for every bug. Don't combine multiple bugs into a single topic. Thanks!

[ZDoom 2.6.1 ] Sprites visible behind sectors with 3D floors

Postby DonaldDuck » Tue Jul 31, 2012 7:05 am

I'm working on a remake of Witchaven for ZDoom, and I found a strange bug:

When a sector has 3d floors, sprites that are behind this affected sectors are not shown as correctly as sprites who are behind sectors without 3d floors.
Here are some images:

(Please enlarge the images)

Spoiler:


The 3D floor was supposed to simulate deep water and is attached to the floor.
User avatar
DonaldDuck
Full nuts
 
Joined: 11 Jun 2011

Re: [ZDoom 2.6.1 ] Sprites visible behind sectors with 3D fl

Postby Edward-san » Tue Jul 31, 2012 8:43 am

why just screenshots should help developers solving the problem? demo wad or won't be fixed.
Edward-san
Mathematics is the language with which God has written the universe. (Galilei)
 
Joined: 17 Oct 2009

Re: [ZDoom 2.6.1 ] Sprites visible behind sectors with 3D fl

Postby DonaldDuck » Tue Jul 31, 2012 9:57 am

Edward-san wrote:why just screenshots should help developers solving the problem? demo wad or won't be fixed.


EDIT:

I've tried something and now I know what causes the problem:
Spoiler:


Take this example wad.
I made 3 different sectors:

A: Sector with swimmable 3d floor.
B: Normal sector
C: Sector with solid 3d floor.

Only the sector A causes the bug. And if i turn off the swimmable option, the bug vanishes:
You do not have the required permissions to view the files attached to this post.
User avatar
DonaldDuck
Full nuts
 
Joined: 11 Jun 2011


Return to Classic ("Carmack") Software Renderer Bugs

Who is online

Users browsing this forum: No registered users and 0 guests