[4.2.4]Scrambled Voxel Colors When Models Are On

Moderator: GZDoom Developers

Forum rules
Please construct and post a simple demo whenever possible for all bug reports. Please provide links to everything.

If you can include a wad demonstrating the problem, please do so. Bug reports that include fully-constructed demos have a much better chance of being investigated in a timely manner than those that don't.

Please make a new topic for every bug. Don't combine multiple bugs into a single topic. Thanks!

[4.2.4]Scrambled Voxel Colors When Models Are On

Postby TheMightyHeracross » Tue Dec 03, 2019 1:29 pm

This happens in the palette versions of both the Carmack and Softpoly renderers. Curiously, this only happens when models are turned on- when models are off the voxel models have correct colors even in these renderers.

Models on:
Image

Models off:
Image

Test wad used:
http://teamhellspawn.com/zdoom_vox.zip
User avatar
TheMightyHeracross
...and remember: his silence is golden.
 
Joined: 18 Aug 2013
Location: Philadelphia, PA
Discord: TheMightyHeracross#1716
Operating System: Debian-like Linux (Debian, Ubuntu, Kali, Mint, etc) 64-bit

Re: [4.2.4]Scrambled Voxel Colors When Models Are On

Postby phantombeta » Tue Dec 03, 2019 5:43 pm

If you look at the Chaingun, you can notice they seem to be drawn differently - the one with models enabled is more... Cube-ey.
Which leads to the conclusion that what's happening here is that it's trying to render the OpenGL renderer's mesh conversions instead of using the normal voxel rendering code.
Unfortunately, the renderers are not my area of expertise, so I can't tell you why it's doing that, nor can I fix it.
User avatar
phantombeta
In the meadow of sinful thoughts, every flower's a perfect one
 
Joined: 02 May 2013
Location: The United Soviet Socialist Dictatorship of Hueland
Discord: phantombeta#2461
Github ID: Doom2fan
Operating System: Windows 10/8.1/8 64-bit
OS Test Version: No (Using Stable Public Version)
Graphics Processor: nVidia with Vulkan support


Return to Classic ("Carmack") Software Renderer Bugs

Who is online

Users browsing this forum: No registered users and 1 guest