No weapon lighting in software renderer.

Moderator: GZDoom Developers

Forum rules
Please construct and post a simple demo whenever possible for all bug reports. Please provide links to everything.

If you can include a wad demonstrating the problem, please do so. Bug reports that include fully-constructed demos have a much better chance of being investigated in a timely manner than those that don't.

Please make a new topic for every bug. Don't combine multiple bugs into a single topic. Thanks!

No weapon lighting in software renderer.

Postby unkles » Sat Sep 07, 2019 2:27 am

Am I missing something ? I feel i looked in all the menus for something to have my weapon change from bright to dark in the shadows of maps. By the way , I'm new here but I was hoping to get some insight in this forum. Any help would be appreciated. Thanks.
unkles
 
Joined: 07 Sep 2019

Re: No weapon lighting in software renderer.

Postby Gez » Sat Sep 07, 2019 3:36 am

Can you be more explicit?

I'm not sure if you're talking about how bright the weapons look in low-light sectors, or about the effect where shooting weapons increase the light level temporarily.
Gez
 
 
 
Joined: 06 Jul 2007

Re: No weapon lighting in software renderer.

Postby unkles » Sat Sep 07, 2019 4:23 pm

I ment low light sectors . Sorry.
unkles
 
Joined: 07 Sep 2019

Re: No weapon lighting in software renderer.

Postby drfrag » Sun Sep 08, 2019 5:24 am

It's true, it's a software renderer bug. At least LZDoom is not affected, the vintage build was. Also GZDoom 3.6.0 wasn't, 3.7.2 was.
User avatar
drfrag
I.R developer, I.R smart
Vintage GZDoom Developer
 
Joined: 23 Apr 2004
Location: Spain

Re: No weapon lighting in software renderer.

Postby drfrag » Sun Sep 08, 2019 7:31 am

There was a refactoring that started with "- move visibility calculation to LightVisibility" from 12/17 , must be something there.
User avatar
drfrag
I.R developer, I.R smart
Vintage GZDoom Developer
 
Joined: 23 Apr 2004
Location: Spain

Re: No weapon lighting in software renderer.

Postby unkles » Sun Sep 08, 2019 5:35 pm

Thanks for the feedback. Maby I'll try that 3.6.0 build.
unkles
 
Joined: 07 Sep 2019


Return to Software Renderer Bugs

Who is online

Users browsing this forum: No registered users and 1 guest