Page 1 of 1

Exit to console on opening Options Menu

PostPosted: Wed May 01, 2019 2:17 pm
by Enjay
g4.2pre-6-g8d36f0a0c gtx1080 win10

I'm just putting this here in case anyone else can replicate it. So far, I have failed.

I was in full-screen (1920x1200) running GZDoom with doom2.wad and -noautoload I was at the player start spot on map01. I hit alt-enter to go into windowed mode, pressed escape to call up the main menu, chose options and I was dumped to the console.

There was a message but I was trying to do something else at the time so I didn't pay it much mind because I assumed that it would be repeatable. However, the words scale and zscript were mentioned (and maybe can't/cannot). Every time I tried to open the options menu, I was just dumped to the console. However, on quitting and restarting GZDoom, everything worked as expected.

I have since tried several times to make it happen again, repeating the above steps exactly, and everything has continued to work normally. So, I don't really know why it happened.

I'm aware that this isn't the most useful bug report but, like I said, if perhaps other people could try it, something might get flagged up.

Re: Exit to console on opening Options Menu

PostPosted: Sun May 05, 2019 2:22 am
by Graf Zahl
As may not be surprising, this gets dumped right into "on-hold bugs" because there's simply nothing here to work on.

Re: Exit to console on opening Options Menu

PostPosted: Sun May 05, 2019 5:17 am
by Enjay
Indeed, no surprise at all. I have tried repeatedly to get it to happen again and it hasn't. Perhaps it was just "one of those things" where, perhaps, something else going on at the time was affecting memory or something.

If it does happen again, I'll at least make a proper note of the error message.