Page 1 of 1

[2.9pre-1233] OpenAL Error on Sound Environment switch

PostPosted: Sat Sep 03, 2016 5:51 am
by Gutawer
In the newest versions of ZDoom, using the OpenAL Backend, when a sound environment boundary is crossed, switching into another boundary, the following error is printed -
Spoiler:

This can be seen here: https://vid.me/gwUD in the Adventures of Square (http://forum.zdoom.org/viewtopic.php?f=19&t=46604).

I believe this bug may have been introduced in this build http://zdoom.org/Changelog/716fbec/files, because of the addition of FMOD Studio.

Re: [2.9pre-1233] OpenAL Error on Sound Environment switch

PostPosted: Sat Sep 03, 2016 7:08 am
by Graf Zahl
It definitely has nothing to do witg FMod, that code is completely separate.
Also, which OpenAL are you using, the official one or OpenAL Soft?

Re: [2.9pre-1233] OpenAL Error on Sound Environment switch

PostPosted: Sat Sep 03, 2016 7:12 am
by Gutawer
I am using whichever version of OpenAL comes with GZDoom on the SVN page.

Re: [2.9pre-1233] OpenAL Error on Sound Environment switch

PostPosted: Sat Sep 03, 2016 7:55 am
by Graf Zahl
Ok. The problem is, the error doesn't tell me much about what precisely went wrong here.

Re: [2.9pre-1233] OpenAL Error on Sound Environment switch

PostPosted: Sat Sep 03, 2016 10:43 am
by Gutawer
Hmm. Is there anyway I can get OpenAL to give a more detailed error?

Re: [2.9pre-1233] OpenAL Error on Sound Environment switch

PostPosted: Sat Sep 03, 2016 11:00 am
by Graf Zahl
No. What you see is what OpenAL reports.