Graphical Issues Still Exist in GZDoom 4.8.2

Need help running G/Q/ZDoom/ECWolf/Zandronum/3DGE? Did your computer break? Ask here.

Moderator: GZDoom Developers

Guest

Re: Graphical Issues Still Exist in GZDoom 4.8.2

Post by Guest »

I don't know how much this helps, but I have tested GZDoom 4.8.0 and beyond with AMD drivers from AMD's website both V21.5.2 and V22.6.1 (latest) and the graphical issues still exist no matter what driver I use. My GPU at idle runs around 110F (fans not running) and my GPU only made it to 117F (fans not running) when playing SGTMark IV's Original Starter Pack (The Tower) and using a nuke to destroy all the enemies on the bridge which puts alot of strain on my GPU and CPU. So I honestly don't know. I know some people having mentioned driver issues and overheating issues, but I'm not seeing that here as a problem as again I've had the issue or two sets of drivers and my GPU doesn't even get hot enough for the fans to cut on. CPU only made it to 89F that I can tell during all that.
Guest

Re: Graphical Issues Still Exist in GZDoom 4.8.2

Post by Guest »

So here's where we're at in GZDoom gzdoom-x64-g4.9pre-93-ga847dacaa. Graphical issues with the screen wipe MELT still exist. The graphical flashing text issues with the options and start new game menu still exist. The Assault Rifle issue in Brutal Doom V21 where you do the GIVE ALL cheat and it shows 500 ammo instead of 9999 ammo like I got in the ammo.txt for Brutal Doom V21 and the gun flashes with no sound still exists. **All weapon sounds that were missing or looping remain still working/corrected**. Tested with Duke Nukem Weapons & Monsters Mod V10b and Brutal Doom V21.
User avatar
wildweasel
Moderator Team Lead
Posts: 21384
Joined: Tue Jul 15, 2003 7:33 pm
Preferred Pronouns: He/Him
Graphics Processor: nVidia with Vulkan support

Re: Graphical Issues Still Exist in GZDoom 4.8.2

Post by wildweasel »

Archie Nellerridge wrote:The Assault Rifle issue in Brutal Doom V21 where you do the GIVE ALL cheat and it shows 500 ammo instead of 9999 ammo like I got in the ammo.txt for Brutal Doom V21 and the gun flashes with no sound still exists.
As stated earlier, this is a mod bug; the "rifle" you're getting with Give All is actually the Strife AssaultGun, because the Brutal rifle coincidentally has the same sprite names, so it will give you that gun when you cheat for it.
User avatar
Blue Shadow
Posts: 4903
Joined: Sun Nov 14, 2010 12:59 am
Graphics Processor: ATI/AMD (Modern GZDoom)

Re: Graphical Issues Still Exist in GZDoom 4.8.2

Post by Blue Shadow »

The rifle issue is due to a change to the give artifacts cheat in 4.8.0. Because give all gives, well, "all", this includes artifacts. And the change meant that the rifle now qualifies as an artifact to be given by the cheat, as it now, unlike before, meets the conditions.
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
Posts: 47995
Joined: Sat Jul 19, 2003 10:19 am
Location: Germany

Re: Graphical Issues Still Exist in GZDoom 4.8.2

Post by Graf Zahl »

That's still a bug. The code in question has already been changed for keys, but apparently also needs to be changed for weapons.
Guest

Re: Graphical Issues Still Exist in GZDoom 4.8.2

Post by Guest »

So here's where we're at in GZDoom gzdoom-x64-g4.9pre-104-g595975fcc. Graphical issues with the screen wipe MELT still exist. The graphical flashing text issues with the options and start new game menu still exist. **The Assault Rifle issue in Brutal Doom V21 where you do the GIVE ALL cheat and it shows 500 ammo instead of 9999 ammo like I got in the ammo.txt for Brutal Doom V21 and the gun flashes with no sound is now corrected**. **All weapon sounds that were missing or looping remain still working/corrected**. Tested with Duke Nukem Weapons & Monsters Mod V10b and Brutal Doom V21. All that officially remains is graphical issues with the screen wipe MELT and graphical issues with flashing text with the options and start new game menus. The flashing graphical text issues that I have noticed so far occur if your in Duke Nukem Weapons & Monsters Mod V10b (maybe after or even before starting a game) and go to options then player options then go out of GZdoom entirely straight to Brutal Doom V21 and do the exact same thing there going to options then player options and then going out of the GZdoom, but when you go back into Brutal Doom V21 that's when the graphical flashing text issues occur. It seems random, but I think it involves going in and out of GZdoom a couple of time for the flashing text issues occur. I don't know if the player options menu has anything to do with it or not either. This all I know that made it occur I went to Duke Nukem Weapons & Monster V10b and tested the sound for the weapons etc then I got out of the game and went to the options menu for Duke Nukem Weapons & Monsters V10b and player options nothing occurred as far as graphical text issues. I went straight to Brutal Doom V21 and tested the sound for weapons etc and also the assault rifle issue then I got out of the game and went to the options menu for Brutal Doom V21 and player options and nothing occurred as far as the graphical text issues. Well I went out of Brutal Doom V21 and back in and boom the graphical text issues occurred on both options menu and start new game menu. So I believe going in and out of GZDoom multiple times causes it or maybe going from one mod to another who knows, but that's what got it to occur on mine this time this is also probably why Rachel couldn't get it to occur as it's possible going from one mod to another causes it or going in and out of GZDoom multiple times causes it I really don't know. The screen wipe MELT thing exists no matter what. So all that's left like I said is graphical issues with flashing text during the options and start new game menus and the screen wipe MELT everything else seem corrected with the sounds for weapons and assault rifle for Brutal Doom V21. I would like to add a weird bug that has existed in every version of GZdoom I've used so far I forgot to mention which is if you go to a new game and use the console the game will crash out with a fatal error. Now if you open the console before starting a new game and then open the console in game it works fine no problems this also seems random, but I've known it to exist in every GZDoom version I've tried don't know the cause. So say you go into Brutal Doom V21 or Duke Nukem Weapons & Monsters V10b and go directly into a game and open the console the game crashes with a fatal error, but if open the console before going directly into a game and then open the console after going into a game it doesn't crash and again this is random, but has been on every version of GZdoom I've ever used I just haven't had a chance to report it till now.
User avatar
wildweasel
Moderator Team Lead
Posts: 21384
Joined: Tue Jul 15, 2003 7:33 pm
Preferred Pronouns: He/Him
Graphics Processor: nVidia with Vulkan support

Re: Graphical Issues Still Exist in GZDoom 4.8.2

Post by wildweasel »

I'm sorry, I'm going to have to level some grievances with you:

- This is an INSANELY LONG paragraph that offers no breaks for the reader's eyes. No indications of when the subject has changed.

- A lot of it seems like stuff you've said many times before. You don't need to repeat yourself.

- There's a bunch of completely unrelated issues in here, when the topic of this thread is the graphical issues.

- Why do you feel the need to repost all of it every few days?
Guest

Re: Graphical Issues Still Exist in GZDoom 4.8.2

Post by Guest »

Wildweasel the reason I repost things is because some things have changed and some things have not. The reason I keep mentioning the sound issues is I want you to know there remaining corrected so far. The assault rifle issue has also been corrected. The graphical issues are still a thing. The reason I repost is because I'm testing dev builds and letting you know what's corrected and what remains to be corrected. Say I don't repost the sound issues or assault rifle issue just the graphical issues in future posts how would you know if there still working or broken again? I'm trying to help yawl out getting these issues resolved which yawl are getting there just the graphical issues remain and of course the console issue I forgot to mention a long time ago. As far as the long paragraph I was trying to help Rachel out by showing what I did to produce the issue for the flashing text with the options menu and new game menu because he said he couldn't get it to happen on his end. The screen MELT issue has been a thing since 4.8.0 and remains same as the flashing text with the options and new game menus. Anyway I know yawl don't understand me and I apologize, but I do have some mental hangups like ADHD, OCD, Severe Depression & Anxiety, Learning Disabilities, and Insomnia hence why I repeat myself is because of some of these issues. I don't mean to do it just happens just ask my friends and family I do it all the time. Anyway the way I see it yawl should be greatful I trying to help yawl out by letting you know what's been fixed and what remains to be fixed instead of criticizing me for trying to help yawl out. I told you I would test new versions and let yawl know what's fixed and what remains and that's what I've been doing. Be glad as some of these issues I've had effect others as well. Anyway I'll try to space my testing of dev builds and new versions out further if that helps.
User avatar
wildweasel
Moderator Team Lead
Posts: 21384
Joined: Tue Jul 15, 2003 7:33 pm
Preferred Pronouns: He/Him
Graphics Processor: nVidia with Vulkan support

Re: Graphical Issues Still Exist in GZDoom 4.8.2

Post by wildweasel »

No, seriously, hit the Enter key once in a while, especially when you're talking about a new thing.
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
Posts: 47995
Joined: Sat Jul 19, 2003 10:19 am
Location: Germany

Re: Graphical Issues Still Exist in GZDoom 4.8.2

Post by Graf Zahl »

TBH, these repeated posts won't get us any closer to a solution. What we need is someone who experiences the problem and has some knowledge to help analyzing them. Until then, I'M afraid, you are out of luck.
Guest

Re: Graphical Issues Still Exist in GZDoom 4.8.2

Post by Guest »

Graf Zahl other people have posted videos and pictures of the issues in other posts I posted. In Major Bugs In 4.8.0 graphical and sound so far post morningstars10 posted a picture of the graphical flashing texts issue. In post Graphical Issues & Sound Issues Still Exist In 4.8.1 Rachael posted a post of a post by DrPyspy showing a video of some of the graphical issues like the screen wipe MELT issue and other graphical issues which was done on a Radeon RX 460 according to the post. Here the video https://www.youtube.com/watch?v=25A9s2524jQ

So basically other people are experiencing it as well not just me and their telling you about it and showing you my question is are you not seeing the posts by other people because if you are you would know by now I'm not the only one experiencing these issues. I'm not trying to be a jerk here either I'm just saying other people have told and showed you the same thing I'm having, but it seems like your not noticing it and only noticing me posting about it when others have posted about it as well. Or there are some communication issues somewhere along the line between yawl developers and your not all seeing the posts at the same time which would indeed lead to misunderstandings, communication issues, and other developers not knowing about everything that's going etc. Basically what I'm saying here is each developer need to be aware of each post posted on here so each one is up to speed and nothing is missed by one or multiple developers. Just saying again not being a jerk just stating facts.
User avatar
wildweasel
Moderator Team Lead
Posts: 21384
Joined: Tue Jul 15, 2003 7:33 pm
Preferred Pronouns: He/Him
Graphics Processor: nVidia with Vulkan support

Re: Graphical Issues Still Exist in GZDoom 4.8.2

Post by wildweasel »

The problem isn't that other people aren't experiencing the problem. It's that the people who might have the ability to fix the problem, are not experiencing the problem or cannot figure out what part needs to be adjusted to fix it. (Or just haven't had the time.)
User avatar
Rachael
Admin
Posts: 12911
Joined: Tue Jan 13, 2004 1:31 pm
Discord: Rachael#3767
Twitch ID: madamerachelle
Github ID: madame-rachelle
Preferred Pronouns: She/Her

Re: Graphical Issues Still Exist in GZDoom 4.8.2

Post by Rachael »

This has nothing to do with us not wanting to fix this bug - trust me we really do.

It has everything to do with the fact that we physically can't, not until we know what exactly is going on - and until someone with a Vulkan SDK experiencing this problem runs GZDoom with vk_debug 1 - and posts the output - we'll never get any closer to finding a solution for this.

I would suggest upgrading your drivers. It is the first thing that usually goes wrong in situations like this.

Secondly, check to make sure your GPU is properly cooled. GPU's get extremely finicky when their cooling is not up to par - and the problems that arise look actually very much like this.

If neither of those fixes the problem then yeah, we're going to need the debug outputs.
Guest

Re: Graphical Issues Still Exist in GZDoom 4.8.2

Post by Guest »

latest version not running on windows 10, i click the exe but nothing happens, is there any new requirements like drivers or something? :)
Guest

Re: Graphical Issues Still Exist in GZDoom 4.8.2

Post by Guest »

Rachael I am unable to update my drivers because AMD told me they moved Windows 7 to Legacy Support their latest drivers was V22.6.1 for Windows 7 which had a flaw which was the HDMI Audio Driver wasn't getting installed with that driver set and they said it may or may never be fixed since Windows 7 has been moved to Legacy Support. They told me to basically move back to V21.5.2 drivers since the HDMI Audio Driver works with it and stay there, but I tested GZDoom with both drivers V22.6.1 and V21.5.2 and got the same graphical issues regardless of the drivers. As far as my GPU overheating it's got two fans on it which never ever turned on during any Doom or Duke Nukem I play with GZDoom and it doesn't even look like according to AIDA 64 the GPU gets over 120F when playing Doom or Duke Nukem with GZDoom so it's not a overheating issue either. It's gotta be something yawl changed during development of V4.8.0 and beyond with Vulkan whatever you changed there is where to look because again none and I repeat none of these issues I had existed in V4.7.1 and below none whatsoever. I mean the sound issues started, the graphical issues started, and assault rifle issue started at V4.8.0 and above, but yawl have conquered the sound issues and assault rifle issue in some of your recent dev builds which I recently mentioned all that remains is the graphical issues. All I can say is go back to V4.7.1 and V4.8.0 and see what yawl changed with Vulkan and undo it or fix it I mean I don't know what else to say here. I cannot help with Vulkan SDK as I don't have it.

Return to “Technical Issues”