Page 1 of 1

x11 Prevents GZDoom From Launching

Posted: Thu Jun 16, 2022 3:47 pm
by kaispishock
Hello!
I Am Running KDE Neon 5.25, With
Kernel Version: 5.13.0-51-generic (64-bit)
Graphics Platform: X11
Processors: 4 × Intel® Core™ i5-3210M CPU @ 2.50GHz
Memory: 7.5 GiB of RAM
Graphics Processor: Mesa DRI Intel® HD Graphics 4000
Manufacturer: LENOVO
Product Name: 2325J67
System Version: ThinkPad X230

i tried everything i could, i updated, tried selecting a different IWAD, and no matter what it didn't work :(

I Ran it in a terminal and this is the output:

Code: Select all

GZDoom g4.8.0 - 2022-06-06 17:14:47 +0200 - SDL version
Compiled on Jun  7 2022

OS: KDE neon User - 5.25, Linux 5.13.0-51-generic on x86_64
M_LoadDefaults: Load system defaults.
W_Init: Init WADfiles.
 adding /opt/gzdoom/gzdoom.pk3, 668 lumps
 adding /opt/gzdoom/game_support.pk3, 2514 lumps
 adding ./DOOM.WAD, 2306 lumps
 adding /opt/gzdoom/game_widescreen_gfx.pk3, 214 lumps
S_Init: Setting up sound.
I_InitSound: Initializing OpenAL
  Opened device Built-in Audio Analog Stereo
  EFX enabled
I_Init: Setting up machine state.
CPU Vendor ID: GenuineIntel
  Name: Intel(R) Core(TM) i5-3210M CPU @ 2.50GHz
  Family 6, Model 58, Stepping 9
  Features: SSE2 SSE3 SSSE3 SSE4.1 SSE4.2 AVX F16C HyperThreading
V_Init: allocate screen.
ST_Init: Init startup screen.
Checking cmd-line parameters...
S_InitData: Load sound definitions.
G_ParseMapInfo: Load map definitions.
Texman.Init: Init texture manager.
ParseTeamInfo: Load team definitions.
LoadActors: Load actor definitions.
script parsing took 201.39 ms
R_Init: Init Doom refresh subsystem.
DecalLibrary: Load decals.
M_Init: Init menus.
P_Init: Init Playloop state.
ParseSBarInfo: Loading custom status bar definition.
D_CheckNetGame: Checking network game status.
player 1 of 1 (1 nodes)
Using video driver x11
X connection to :0 broken (explicit kill or server shutdown).==============================================================================.........]
AL lib: (EE) alc_cleanup: 1 device not closed

Re: x11 Prevents GZDoom From Launching

Posted: Thu Jun 16, 2022 11:42 pm
by Blzut3
It's dying right at the point where it would initialize OpenGL or Vulkan. Try changing vid_preferbackend (try all values 0 through 3). For example:

Code: Select all

gzdoom +vid_preferbackend 0

If none of them work perhaps see if SDL's software render driver works with softpoly (backend 2).

Code: Select all

SDL_RENDER_DRIVER=software gzdoom +vid_preferbackend 2