Wheel controller taking over mouselook

Need help running G/Q/ZDoom/ECWolf/Zandronum/3DGE? Did your computer break? Ask here.

Moderator: GZDoom Developers

Wheel controller taking over mouselook

Postby Curunir » Sun May 15, 2022 5:16 am

So here's the thing. I now have a Thrustmaster wheel connected to my PC and it turns out whenever I boot up GZDoom, the camera starts doing wild circles while the wheel is available. The only way I can stop this from happening that I know of is disabling the wheel device in device manager.

Is there any option, toggle or cvar that will prevent the game from picking up the wheel or any USB controller for that matter, because I only play using mouse and keyboard anyway?

Thanks in advance!
User avatar
Curunir
In heaven everything is fine
 
Joined: 02 Nov 2003
Operating System: Windows 10/8.1/8/201x 64-bit
Graphics Processor: ATI/AMD with Vulkan Support

Re: Wheel controller taking over mouselook

Postby Enjay » Sun May 15, 2022 5:40 am

This is in the options under controller options:

Image

Have you tried that (switching it to off I mean)?
User avatar
Enjay
Everyone is a moon, and has a dark side which he never shows to anybody. Twain
 
 
 
Joined: 15 Jul 2003
Location: Scotland

Re: Wheel controller taking over mouselook

Postby Curunir » Sun May 15, 2022 6:31 am

I had somehow managed not to enter that menu and see the option.

Thanks a lot, Enjay, that fixed it!
User avatar
Curunir
In heaven everything is fine
 
Joined: 02 Nov 2003
Operating System: Windows 10/8.1/8/201x 64-bit
Graphics Processor: ATI/AMD with Vulkan Support


Return to Technical Issues

Who is online

Users browsing this forum: No registered users and 2 guests