GZDoom on M1 Mac: Keys get stuck sometimes

Need help running G/Q/ZDoom/ECWolf/Zandronum/3DGE? Did your computer break? Ask here.

Moderator: GZDoom Developers

GZDoom on M1 Mac: Keys get stuck sometimes

Postby Madoc » Tue May 03, 2022 2:22 pm

I'm running the latest GZDoom on an M1 Mac.
Keys sometimes get stuck, i.e. GZDoom sometimes doesn't process a key up / key down event.
Also, sometimes GZDoom seems to not receive any keyboard events for several seconds.

Here is what I tried, all with the same result:
* Installed GZDoom both via Homebrew and manually (i.e., download + unpack Zip, move app to `/Applications`).
* Switched from OpenGL to truecolor software renderer.
* Starting GZDoom both from iTerm and by double clicking the app.

Any hints on where I could look for a fix? Any options I could change?

Also, does anyone run GZDoom on and iMac and can confirm that they DON'T have the same issue?

Thanks everyone!
Madoc
 
Joined: 03 May 2022
Operating System: Mac OS X 10.8 or later
Graphics Processor: Apple M1

Re: GZDoom on M1 Mac: Keys get stuck sometimes

Postby Rachael » Tue May 03, 2022 4:22 pm

https://devbuilds.drdteam.org/gzdoom-mac/

Please try a git build.

I have never had problems as you describe. If you are using a magic keyboard, make sure it is charged.
User avatar
Rachael
^ walking stack of unfinished projects ^
Admin
 
Joined: 13 Jan 2004
Discord: Rachael#3767
Twitch ID: madamerachelle
Github ID: madame-rachelle


Return to Technical Issues

Who is online

Users browsing this forum: No registered users and 1 guest