GZDoom Zscript A_CustomRailgun Does not Recongize Black

Need help running G/Q/ZDoom/ECWolf/Zandronum/3DGE? Did your computer break? Ask here.

Moderator: GZDoom Developers

User avatar
Doomguy 2000
Posts: 169
Joined: Tue Oct 12, 2010 3:30 pm
Location: Undisclosed Location, United States

GZDoom Zscript A_CustomRailgun Does not Recongize Black

Post by Doomguy 2000 »

When I was converting my code to ZScript. I ran into this problem where the custom railgun feature does not recognize black for some reason. When I change the ring color to black, it defaults to blue instead and the rail color becomes a dark shade white with tiny particles of gray.

Code: Select all

 Missile:
    HEAD B 5 A_FaceTarget;
    HEAD B 0 A_StartSound("weapons/railgf");
    HEAD B 5 A_CustomRailgun (30, 5, "black", "white", 1);
    HEAD B 0 A_StartSound("weapons/railgf");
    HEAD B 5 A_CustomRailgun (30, 0, "black", "white", 1);
    HEAD B 0 A_StartSound("weapons/railgf");
    HEAD B 5 A_CustomRailgun (30, -5, "black", "white", 1);
    HEAD B 0 A_FaceTarget;
    goto See;
User avatar
Blue Shadow
Posts: 4903
Joined: Sun Nov 14, 2010 12:59 am
Operating System: Windows 10/8.1/8/201x 64-bit
OS Test Version: No (Using Stable Public Version)
Graphics Processor: ATI/AMD (Modern GZDoom)

Re: GZDoom Zscript A_CustomRailgun Does not Recongize Black

Post by Blue Shadow »

ZDoom Wiki wrote:color1: The color of the particles that form the spiral "ring" of the beam. This can be in the form of a RRGGBB string or a string holding a color defined in the X11R6RGB lump. If the string is invalid, the particles will be black. None (without quotes) in DECORATE or "" in ZScript will make the ring invisible. A value of 0, which is treated specially, draws the the particles in one of four shades of blue, picked randomly.
By the looks of it, "black" (or "000000"), falls under that special case, too. The closest you can have to black is "010101".

Return to “Technical Issues”