No sound on GZdoom v4.7.1 (openal error??)

Need help running G/Q/ZDoom/ECWolf/Zandronum/3DGE? Did your computer break? Ask here.

Moderator: GZDoom Developers

No sound on GZdoom v4.7.1 (openal error??)

Postby pointblank » Fri Dec 24, 2021 7:44 pm

Running Linux Mint, latest version. Have had gzdoom installed for a long time as flatpak, but sound recently stopped working, i think when i had to reinstall zandronum for an unrelated issue. now i am trying the apt package of gzdoom (which is actually a newer version than the flatpak version), but neither has working sound or music. i have tried cleaning out ~/.config/gzdoom, purging all residual files, reinstalling, and removing wads & mods.

here are the errors i get:
Code: Select allExpand view
S_Init: Setting up sound.
I_InitSound: Initializing OpenAL
AL lib: (EE) ALCpulsePlayback_contextStateCallback: Received context failure!
AL lib: (EE) ALCpulsePlayback_connectStream: Stream did not get ready: Connection terminated
 Could not open audio device
Sound init failed. Using nosound.


I have tried selecting different midi devices in the in-game sound menu, but to no avail. right now, i have fluidsynth selected.

the openal related packages i have installed via apt:
Code: Select allExpand view
libopenal-data
libopenal-dev
libopenal1
libopenal1:i386
openal-info (i think this one is useless)


please help!! :!: :(
pointblank
 
Joined: 24 Dec 2021
Discord: Ao1|Pointblank#2256
Operating System: Debian-like Linux (Debian, Ubuntu, Mint, etc) 64-bit
OS Test Version: No (Using Stable Public Version)

Re: No sound on GZdoom v4.7.1 (openal error??)

Postby pointblank » Fri Dec 24, 2021 11:07 pm

i've spent a few hours now, trying to figure out why sound works on my other Linux Mint computer, but not my main one. Comparing apt packages, looking at /etc/openal/alsoft.conf, trying different downloads of gzdoom... this is looking hopeless. not how i want to spend my christmas eve lol. i'll check back in a few days.
pointblank
 
Joined: 24 Dec 2021
Discord: Ao1|Pointblank#2256
Operating System: Debian-like Linux (Debian, Ubuntu, Mint, etc) 64-bit
OS Test Version: No (Using Stable Public Version)

Re: No sound on GZdoom v4.7.1 (openal error??)

Postby pointblank » Fri Dec 24, 2021 11:19 pm

quick update:
reinstalling the flatpak version, and launching via terminal w/ flatpak run org.zdoom.GZDoom results in the following errors (slightly different from the deb package errors)
Code: Select allExpand view
S_Init: Setting up sound.
I_InitSound: Initializing OpenAL
[ALSOFT] (EE) Failed to set real-time priority for thread: Operation not permitted (1)
[ALSOFT] (EE) Failed to set real-time priority for thread: Operation not permitted (1)
 Could not open audio device
Sound init failed. Using nosound.
ALSA lib seq_hw.c:466:(snd_seq_hw_open) open /dev/snd/seq failed: No such file or directory
pointblank
 
Joined: 24 Dec 2021
Discord: Ao1|Pointblank#2256
Operating System: Debian-like Linux (Debian, Ubuntu, Mint, etc) 64-bit
OS Test Version: No (Using Stable Public Version)

Re: No sound on GZdoom v4.7.1 (openal error??)

Postby KynikossDragonn » Sat Dec 25, 2021 2:33 am

Sounds like flatpak permission problems, what if you just compiled GZDoom yourself and ran it locally instead?

I always read about flatpak ran stuff having all sorts of permission issues with accessing sound devices and even the PulseAudio/PipeWire server that I don't see happen if you had just built the software yourself and run it outside of flatpak's weird sandboxing.

Code: Select allExpand view
AL lib: (EE) ALCpulsePlayback_contextStateCallback: Received context failure!
AL lib: (EE) ALCpulsePlayback_connectStream: Stream did not get ready: Connection terminated


These two lines right here definitely sound like running this from flatpak it's unable to access the cookie needed to access the PulseAudio server.
User avatar
KynikossDragonn
『霧雨魔理沙のペットドラゴン』
 
Joined: 12 Dec 2020
Location: Independence, KS, USA
Twitch ID: kynikossdragonn
Github ID: KynikossDragonn
Operating System: Other Linux 64-bit
OS Test Version: No (Using Stable Public Version)
Graphics Processor: Intel (Modern GZDoom)

Re: No sound on GZdoom v4.7.1 (openal error??)

Postby pointblank » Sat Dec 25, 2021 6:07 am

yes, a flatpak permission issue was one of my guesses too, except it occurred with the deb package too...

BUT

pipewire got an update and both versions work flawlessly now. i guess patience was the solution here.
thank you for your time. 😅
pointblank
 
Joined: 24 Dec 2021
Discord: Ao1|Pointblank#2256
Operating System: Debian-like Linux (Debian, Ubuntu, Mint, etc) 64-bit
OS Test Version: No (Using Stable Public Version)


Return to Technical Issues

Who is online

Users browsing this forum: No registered users and 2 guests