Weird issues with GZDoom binary

Need help running G/Q/ZDoom/ECWolf/Zandronum/3DGE? Did your computer break? Ask here.

Moderator: GZDoom Developers

Weird issues with GZDoom binary

Postby sacarias » Mon Dec 06, 2021 5:02 pm

Built GZDoom on Debian 11 on build directory $HOME/gzdoom_build by following steps in wiki page.
It seems to work normally by running it from command line.

However, I found some weird stuff after doing few small tests.

Running normally from command line works; but trying to run it from file manager in GUI opens a window "Choose application to run with. File type: shared library". The same result as if trying to open this way any other .so library file.
Hell, binary even has the same icon as .so libraries, instead of the characteristic icon of common "executable binaries"...

Also, I tried symlinking gzdoom binary from gzdoom_build to $HOME/bin, which is included in PATH.
Tried running by invoking it with just "gzdoom"; got a window "Fatal error: Cannot find gzdoom.pk3". The same result as if renaming gzdoom.pk3 inside gzdoom_build to something else, then trying to run normally from command line.
The only case it works is when invoking from $HOME/bin directory itself. Hell, in that case just use "./gzdoom" while there...

Finally, "file" command shows gzdoom binary as "ELF 64-bit LSB pie executable"; while other common binaries are "ELF 64-bit LSB executable", without "pie". An internet search showed that LSB pie executables are actually just "shared libraries", but executable.

Could someone help with the described issues, by chance, please?
Could they be related to the fact that binary is a "pie executable"?

Thanks for your attention.
sacarias
 
Joined: 02 Oct 2019

Re: Weird issues with GZDoom binary

Postby sacarias » Thu Dec 30, 2021 7:00 pm

Kind of solved by doing slower, longer internet searches.

Seems like a "thing" (not even necessarily a "bug") in Debian-based distros.

Also, in general, trying to run direct binaries from file manager is seemingly considered not a very "common" practice. Perhaps not even "orthodox"?
sacarias
 
Joined: 02 Oct 2019


Return to Technical Issues

Who is online

Users browsing this forum: No registered users and 1 guest