Page 1 of 1

Screen tearing (from window mode?)

PostPosted: Thu Nov 18, 2021 10:54 pm
by BG213
Hello all. I am having screen tearing issues in GZDoom. Was playing around with window mode when trying to set up OBS and quit GZDoom in window mode, re-opened it and disaster! I cannot access the in-game options menu or console due to the screen tearing, so any solution will have to come some other way (system console?). I tried re-installing GZDoom and re-starting my system and no difference. Problem persists across Doom I, Doom II, TNT, Plutonia and Free Doom wads. Relevant system info and a link to a screenshot is listed below.

Mac OS X 10.13.6
Intel HD Graphics 6000

https://drive.google.com/file/d/13ulbj9 ... knJ-6wUOc/

Re: Screen tearing (from window mode?)

PostPosted: Fri Nov 19, 2021 1:31 pm
by Jarvis Cinkinleg
As I said previously re-installing GZDoom from the dmg file doesn't solve the problem. When I remove all the contents of the directory:

~/Library/Application Support/gzdoom/

(all the game wad files) I get the following error message:

iMac16,1 running macOS High Sierra 10.13.6 (XXXXXXXX) 64-bit Intel
M_LoadDefaults: Load system defaults.

Execution could not continue.
Cannot find a game IWAD (doom.wad, doom2.wad, heretic.wad, etc.).
Did you install GZDoom properly? You can do either of the following:

1. Place one or more of these wads in ~/Library/Application Support/gzdoom/
2. Edit your ~/Library/Preferences/gzdoom.ini and add the directories
of your iwads to the list beneath [IWADSearch.Directories]

# 1 makes sense. # 2 led me to look for gzdoom.ini in

~/Library/Preferences/

but no such .ini file seems to exist. I suspect this is the preference file which is the cause of the problem. Deleting it and causing GZDoom to make a new one should be the solution, no? But this can't be tried without first locating the .ini!


PS: For future reference if anyone else has this problem:

~Users/XXXXX/Library/ is a hidden folder. To reveal hidden files and folders press cmd-shft-period ("."). Find gzdoom.ini and trash it. Relaunching GZDoom should fix it, albeit you'll have to set up all your preferences again from default.