m1 mac can't open iwads?

Need help running G/Q/ZDoom/ECWolf/Zandronum/3DGE? Did your computer break? Ask here.

Moderator: GZDoom Developers

m1 mac can't open iwads?

Postby Thomas Bosslebot » Wed Oct 27, 2021 11:01 am

I just installed GZDoom on my m1 mac. I've been using it on PC forever. I followed the instructions I was given, unzipped it to my applications folder from the websites download. GZdoom said to put my wads in /library/applicationsupport/gzdoom so I put my plain old doom wad in. It stills says no wad is found, even if I click the wad and tell GZdoom to open it, or try to run the wad through the command line. How do I fix this?
Thomas Bosslebot
 

Re: m1 mac can't open iwads?

Postby _mental_ » Thu Oct 28, 2021 2:11 am

First of all, the path from 'Cannot find IWAD' error message is ~/Library/Application Support/gzdoom.
However, /Library/Application Support/gzdoom works as well. It just asks you for a admin user's password to be able to create folder and copy files.

There should be space between Application and Support words in the path. If it is present, maybe you created a folder in wrong place.
Also, I assume that you didn't install macOS on case-sensitive file system.

Loading from command line is possible too using -iwad switch followed by a path to IWAD.
Clicking on .wad file loads it as PWAD, not IWAD.

Better location for IWADs is in Documents folder. Create gzdoom folder in it, and copy all IWADs there.
_mental_
 
 
 
Joined: 07 Aug 2011


Return to Technical Issues

Who is online

Users browsing this forum: No registered users and 0 guests