GZDoom 4.7.0 startup crash on GL_ES mode.

Need help running G/Q/ZDoom/ECWolf/Zandronum/3DGE? Did your computer break? Ask here.

Moderator: GZDoom Developers

GZDoom 4.7.0 startup crash on GL_ES mode.

Postby Gentan » Fri Oct 01, 2021 10:07 am

To whoever's reading this post: Hello there! Hope you're having a good day so far.

I have been active on these forums for a while now and just now I decided to create my account, I believe it's worth a shot to mention my crashing issue here; although I don't really expect to get a fix or a possible solution, and here's why:

Seriously potato-ish PC (somewhat decent for vanilla DOOM standards), and my country's economical situation is utterly upside-down. If you wish to know, yes, I am from Venezuela. I do have a hint that the solution to this issue is either upgrading my CPU or getting a GPU, which would be impossible since basically prices are not regulated in this country (meaning everyone does what they want with prices), and the minimum price for at least a GT 730 is $200 bucks. Tough luck I guess... Anyways! Here goes nothing:

The recent update for GZDoom (4.7.0) incorporated an OpenGL_ES mode, which should make the port friendlier for older hardware, I believe it also is compatible with OpenGL versions lower than 3.3 (I have 3.1). This got me really interested in playing DOOM again! I stopped since I updated to Win10 because one of the programs that I use for my job specifically requires Windows 10, otherwise believe me I would have stayed in 7.

I patched the GZDoom.exe with wtfi.exe to get rid of the "OpenGL not accelerated!" mumbo jumbo, and then tried to launch the game, with the most hyped-up face you can possibly imagine.

My face just dropped again. Now it's giving me another crash error as soon as everything finishes loading! I get a black-screen just as if the game was going to start, then it closes after about half a second or so. The crash states the following:

Code: C0000005 (Access Violation - tried to write address 0000000004BC0010)
Address: 00007FF640D6DA83
Flags: 00000000
(I've attached the full crash report.zip below for the full technical stuff)

I have no idea on what could possibly cause this. I have set "vid_rendermode 3" along with "preferred_backend 3" to set the backend to OpenGL_ES, I've tried running the program as administrator, Win8 compatibility mode and so far nothing's worked. If anyone has a clue on what's happening or can help me with this, I would gladly appreciate it very much! Thanks in advance, and sorry if I mention too much unnecesary information. My PC specs are below:

Intel Celeron G530 2.4GHz, 2 cores (ouch)
6gb RAM DDR3 1600MHz
Integrated "Intel HD Graphics Family Driver" that comes with the processor (around 2nd gen or so) (OpenGL 3.1 capable)
You do not have the required permissions to view the files attached to this post.
Gentan
 
Joined: 01 Oct 2021
Operating System: Windows 10/8.1/8/201x 64-bit
Graphics Processor: Intel (Legacy GZDoom)

Re: GZDoom 4.7.0 startup crash on GL_ES mode.

Postby drfrag » Fri Oct 01, 2021 10:26 am

I think LZDoom will run better on your hardware (you can use Windows 8 compatibility mode as an alternative to wtfi).
That said crashing on old Intel hardware is a known problem and it's under investigation. I sent emile_b a backtrace (i'm debugging it on my old laptop) but i'm not even sure if it's the same crash, those kind of problems usually are not fixable if you don't own the hardware.
User avatar
drfrag
Os voy a romper a pedazos!
Vintage GZDoom Developer
 
Joined: 23 Apr 2004
Location: Spain
Discord: drfrag#3555
Github ID: drfrag666

Re: GZDoom 4.7.0 startup crash on GL_ES mode.

Postby Gentan » Fri Oct 01, 2021 11:33 am

Yup, I believe I'll stick to LZDoom for the time being, it works fine, but I wanted to try GZDoom_ES mode because I read it performed somewhat better than LZDoom, I believe that only applies for newer systems... Please keep me updated on these crashing issues! And thank you for replying. :)
Gentan
 
Joined: 01 Oct 2021
Operating System: Windows 10/8.1/8/201x 64-bit
Graphics Processor: Intel (Legacy GZDoom)

Re: GZDoom 4.7.0 startup crash on GL_ES mode.

Postby Graf Zahl » Fri Oct 01, 2021 11:58 am

The HD3000 would be good enough had Intel not abandoned it with a worthless driver version that only features a very poor OpenGL implementation.
Its Linux driver does support GL 3.3, only on Windows it won't.
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
 
Joined: 19 Jul 2003
Location: Germany


Return to Technical Issues

Who is online

Users browsing this forum: No registered users and 0 guests