Poor performance (~10-15mins into game)

Need help running G/Q/ZDoom/ECWolf/Zandronum/3DGE? Did your computer break? Ask here.

Moderator: GZDoom Developers

Poor performance (~10-15mins into game)

Postby Wilhelmina Greenhall » Fri Sep 03, 2021 11:50 am

Hi,

My laptop is the following spec:

T490 - Intel Core i7 ~4.6 Ghz, 40GB RAM, 512GB SSD, NVIDIA GeForce MX250 2GB

I can start levels (e.g. Doom1, TNT) fine but after 5-15mins the frame rate crashes & my game slows to a crawl. I have to save & then restart GZDoom & then the sequence starts again. I've reinstalled GZDoom and updated (4.6.1) with no improvement. I can play Steam Unity Doom without any such problems so it's very unlikely it's a memory issue on my laptop.

Any suggestions what the issue is?

Thanks!
Wilhelmina Greenhall
 

Re: Poor performance (~10-15mins into game)

Postby Graf Zahl » Fri Sep 03, 2021 12:52 pm

This sounds like your system powers down the GPU after some time. The most frequent cause is dust clogging up the system's fans.
If you have air circulation problems, the first thing you should try is to enable VSync to cap the frame rate and see if that helps.
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
 
Joined: 19 Jul 2003
Location: Germany

Re: Poor performance (~10-15mins into game)

Postby Redneckerz » Fri Sep 03, 2021 1:56 pm

40 GB RAM does not sound right for a laptop, let alone 32 GB RAM.

Are there energy-saving options active? Nvidia Optimus and other technologies will switch between the IGP and dedicated GPU, which might be messy.
User avatar
Redneckerz
To it's ports i may have seen
Spotlight Team
 
Joined: 25 Nov 2019
Discord: Redneckerz#8399
Operating System: Windows 10/8.1/8/201x 64-bit
Graphics Processor: Intel (Modern GZDoom)

Re: Poor performance (~10-15mins into game)

Postby Wilhelmina Greenhall » Sat Sep 04, 2021 5:56 am

It definitely has 40Gb. The T490 can take up to 48Gb: https://www.lenovo.com/gb/en/laptops/th ... 2TP2TT4900.

Thanks for the tips, I'll investigate & report back!
Wilhelmina Greenhall
 

Re: Poor performance (~10-15mins into game)

Postby Wilhelmina Greenhall » Mon Sep 06, 2021 1:21 am

turning on VSync worked like a charm!

Is the potential air circulation/dust problem worth investigating or is this a common issue with laptops?

Thanks again
Wilhelmina Greenhall
 

Re: Poor performance (~10-15mins into game)

Postby Rachael » Mon Sep 06, 2021 10:40 am

Wilhelmina Greenhall wrote:Is the potential air circulation/dust problem worth investigating or is this a common issue with laptops?

Yes and yes. It is worth investigating, and it is a common issue with laptops. It's actually a common issue no matter what computer you have.
User avatar
Rachael
Admin
 
Joined: 13 Jan 2004
Discord: Rachael#3767
Twitch ID: madamerachelle
Github ID: madame-rachelle
Operating System: Debian-like Linux (Debian, Ubuntu, Mint, etc) 64-bit
OS Test Version: No (Using Stable Public Version)
Graphics Processor: nVidia with Vulkan support


Return to Technical Issues

Who is online

Users browsing this forum: No registered users and 0 guests