Poor performance (~10-15mins into game)

Need help running G/Q/ZDoom/ECWolf/Zandronum/3DGE/EDuke32/Raze? Did your computer break? Ask here.

Moderator: GZDoom Developers

Forum rules
Contrary to popular belief, we are not all-knowing-all-seeing magical beings!

If you want help you're going to have to provide lots of info. Like what is your hardware, what is your operating system, what version of GZDoom/LZDoom/whatever you're using, what mods you're loading, how you're loading it, what you've already tried for fixing the problem, and anything else that is even remotely relevant to the problem.

We can't magically figure out what it is if you're going to be vague, and if we feel like you're just wasting our time with guessing games we will act like that's what you're really doing and won't help you.
Guest

Poor performance (~10-15mins into game)

Post by Guest »

Hi,

My laptop is the following spec:

T490 - Intel Core i7 ~4.6 Ghz, 40GB RAM, 512GB SSD, NVIDIA GeForce MX250 2GB

I can start levels (e.g. Doom1, TNT) fine but after 5-15mins the frame rate crashes & my game slows to a crawl. I have to save & then restart GZDoom & then the sequence starts again. I've reinstalled GZDoom and updated (4.6.1) with no improvement. I can play Steam Unity Doom without any such problems so it's very unlikely it's a memory issue on my laptop.

Any suggestions what the issue is?

Thanks!
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
Posts: 48370
Joined: Sat Jul 19, 2003 10:19 am
Location: Germany

Re: Poor performance (~10-15mins into game)

Post by Graf Zahl »

This sounds like your system powers down the GPU after some time. The most frequent cause is dust clogging up the system's fans.
If you have air circulation problems, the first thing you should try is to enable VSync to cap the frame rate and see if that helps.
User avatar
Redneckerz
Spotlight Team
Posts: 987
Joined: Mon Nov 25, 2019 8:54 am
Graphics Processor: Intel (Modern GZDoom)

Re: Poor performance (~10-15mins into game)

Post by Redneckerz »

40 GB RAM does not sound right for a laptop, let alone 32 GB RAM.

Are there energy-saving options active? Nvidia Optimus and other technologies will switch between the IGP and dedicated GPU, which might be messy.
Guest

Re: Poor performance (~10-15mins into game)

Post by Guest »

It definitely has 40Gb. The T490 can take up to 48Gb: https://www.lenovo.com/gb/en/laptops/th ... 2TP2TT4900.

Thanks for the tips, I'll investigate & report back!
Guest

Re: Poor performance (~10-15mins into game)

Post by Guest »

turning on VSync worked like a charm!

Is the potential air circulation/dust problem worth investigating or is this a common issue with laptops?

Thanks again
User avatar
Rachael
Admin
Posts: 13107
Joined: Tue Jan 13, 2004 1:31 pm
Preferred Pronouns: She/Her

Re: Poor performance (~10-15mins into game)

Post by Rachael »

Wilhelmina Greenhall wrote: Is the potential air circulation/dust problem worth investigating or is this a common issue with laptops?
Yes and yes. It is worth investigating, and it is a common issue with laptops. It's actually a common issue no matter what computer you have.

Return to “Technical Issues”