GZDoom "R_OPENGL: OpenGL driver not accelerated!" nvidia/w7

Need help running G/Q/ZDoom/ECWolf/Zandronum/3DGE? Did your computer break? Ask here.

Moderator: GZDoom Developers

User avatar
bimshwel
Posts: 636
Joined: Tue Jul 15, 2003 5:15 pm
Discord: bimshwel #7516
Location: misplaced

GZDoom "R_OPENGL: OpenGL driver not accelerated!" nvidia/w7

Post by bimshwel »

I assume it is valid to respond in here since it is pinned anyhow.
I experience this famous error now but in windows 7, with nvidia quadro k1100m. In fact this is the exact same windows 7 and solid state drive I had in the computer I used up until about eight days ago. I don't know if it is exactly the same display doohickamabob but this machine is certainly newer. I tried getting a fresh nvidia driver (R418 U7 (426.32) evidently) and using that wtfi.exe on the "dev build" but neither made a difference. Although ever helpful avast wanted to scan the new exe each and every time! believe it or nuts I made sure to get a computer with a display thing in it that seemed to be the same specifically because I was paranoid about gzdoom not running since I also got this error in the older computer I was using for the past week.
Last edited by bimshwel on Fri Sep 03, 2021 2:41 am, edited 1 time in total.

User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
Posts: 47961
Joined: Sat Jul 19, 2003 10:19 am
Location: Germany

Re: GZDoom "R_OPENGL: OpenGL driver not accelerated!" Intel/

Post by Graf Zahl »

Your problem is most certainly not related. Are you sure you didn't accidentally a crippled Microsoft provided driver installed?
Also, what graphics card?

User avatar
bimshwel
Posts: 636
Joined: Tue Jul 15, 2003 5:15 pm
Discord: bimshwel #7516
Location: misplaced

Re: GZDoom "R_OPENGL: OpenGL driver not accelerated!" Intel/

Post by bimshwel »

It is related in the respect that the error message is the same!
i appear to have TWO display adapters, the nvidia quadro k1000m with nvidia drivers from the nvidia website and "standard vga graphics adapter." Notably the nvidia control panel won't open (apparently a common enough problem that there are more pages with the same heap of bogus "fixes" for it on the internet than the hiccups) and didn't go away even when i temporarily had the driver uninstalled.
I have determined that photoglop doesn't think I have opengl anymore either so I suppose this isn't a gzdoom problem so much as a I just bought a computer that can't do important things that I need it to do problem.
Last edited by bimshwel on Fri Sep 03, 2021 2:40 am, edited 1 time in total.

User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
Posts: 47961
Joined: Sat Jul 19, 2003 10:19 am
Location: Germany

Re: GZDoom "R_OPENGL: OpenGL driver not accelerated!" Intel/

Post by Graf Zahl »

Thr topic says "Intel", so it's something different. I've split this off into its own thread.

Rachael
Admin
Posts: 12855
Joined: Tue Jan 13, 2004 1:31 pm
Discord: Rachael#3767
Twitch ID: madamerachelle
Github ID: madame-rachelle

Re: GZDoom "R_OPENGL: OpenGL driver not accelerated!" nvidia

Post by Rachael »

The reason why Graf says the problem isn't related has nothing to do with the error itself, which in this case is very misleading.

The problem isn't that OpenGL isn't engaging here - it's that the drivers for some reason aren't recognizing your card at all.

This card is quite old - but not so old it doesn't have important features like OpenGL 4.6 and Vulkan, it does have those, at least. So - I would look at the drivers and see if you can find an older driver that would have worked with the card. The other possibilities are that the card was not installed right, or hardware failure.

User avatar
drfrag
Vintage GZDoom Developer
Posts: 3110
Joined: Fri Apr 23, 2004 3:51 am
Discord: drfrag#3555
Github ID: drfrag666
Location: Spain

Re: GZDoom "R_OPENGL: OpenGL driver not accelerated!" nvidia

Post by drfrag »

Looks like the drivers are not properly installed. Check if they are the right drivers for your card and OS.

User avatar
bimshwel
Posts: 636
Joined: Tue Jul 15, 2003 5:15 pm
Discord: bimshwel #7516
Location: misplaced

Re: GZDoom "R_OPENGL: OpenGL driver not accelerated!" nvidia

Post by bimshwel »

Oh I see the thread I found first that linked to the other one didn't say Intel and I failed to observe that the second one did but assumed it was deemed the primary spot to mention encounters with the error in any event.
I have installed at least four different versions of the driver from different points in time since encountering the error, the first before I bothered to gripe about it. And a fifth one that I found from 2016 insists it isn't correct so presumably a wrong one can't just go right in. I don't know how old the card is but it shouldn't be older than the one I was using just fine two weeks ago. I notice this computer, which is refurbished, has a windows 8 sticker on its underside. A fear is that for whyever reason despite purporting to work with 7 these drivers actually don't, or at least not properly, or perhaps do but my 7 installation has gone wrong over the fourish years I have had it. I shall have to do more drive swapping and check on those once a whole heap of files have been copied.

User avatar
Redneckerz
Spotlight Team
Posts: 970
Joined: Mon Nov 25, 2019 8:54 am
Discord: Redneckerz#8399
Operating System: Windows 10/8.1/8/201x 64-bit
Graphics Processor: Intel (Modern GZDoom)

Re: GZDoom "R_OPENGL: OpenGL driver not accelerated!" nvidia

Post by Redneckerz »

bimshwel wrote:Oh I see the thread I found first that linked to the other one didn't say Intel and I failed to observe that the second one did but assumed it was deemed the primary spot to mention encounters with the error in any event.
I have installed at least four different versions of the driver from different points in time since encountering the error, the first before I bothered to gripe about it. And a fifth one that I found from 2016 insists it isn't correct so presumably a wrong one can't just go right in. I don't know how old the card is but it shouldn't be older than the one I was using just fine two weeks ago. I notice this computer, which is refurbished, has a windows 8 sticker on its underside. A fear is that for whyever reason despite purporting to work with 7 these drivers actually don't, or at least not properly, or perhaps do but my 7 installation has gone wrong over the fourish years I have had it. I shall have to do more drive swapping and check on those once a whole heap of files have been copied.

Download CPU-Z and GPU-Z and let it run. Post the results as a screenshot here so we have a better picture of the machine.

User avatar
bimshwel
Posts: 636
Joined: Tue Jul 15, 2003 5:15 pm
Discord: bimshwel #7516
Location: misplaced

Re: GZDoom "R_OPENGL: OpenGL driver not accelerated!" nvidia

Post by bimshwel »

I was not expecting help with my non-gzdoom problem but if you can draw any conclusion from this I certainly welcome you to do so!
cpuz.png
gpuz.png

I do not like the look of all those zero mhzs and unknowns on the nvidia readout.
You do not have the required permissions to view the files attached to this post.

Rachael
Admin
Posts: 12855
Joined: Tue Jan 13, 2004 1:31 pm
Discord: Rachael#3767
Twitch ID: madamerachelle
Github ID: madame-rachelle

Re: GZDoom "R_OPENGL: OpenGL driver not accelerated!" nvidia

Post by Rachael »

What happens when you run "devmgmt.msc"?

User avatar
bimshwel
Posts: 636
Joined: Tue Jul 15, 2003 5:15 pm
Discord: bimshwel #7516
Location: misplaced

Re: GZDoom "R_OPENGL: OpenGL driver not accelerated!" nvidia

Post by bimshwel »

device.png
that launches the device manager. It of course thinks everything is working just fine apart from some mysterious usb device it is unable to identify or keep out when I "uninstall" it.
You do not have the required permissions to view the files attached to this post.

User avatar
Redneckerz
Spotlight Team
Posts: 970
Joined: Mon Nov 25, 2019 8:54 am
Discord: Redneckerz#8399
Operating System: Windows 10/8.1/8/201x 64-bit
Graphics Processor: Intel (Modern GZDoom)

Re: GZDoom "R_OPENGL: OpenGL driver not accelerated!" nvidia

Post by Redneckerz »

It should be noted that seeing two adapters isn't unusual. Windows by default has a Standard VGA Adapter - A basic adapter to just display the screen.

The 0 mhz is where my gut feeling says lies the problem in. You are using a Quadro card, which is a workstation card. Performance in games will vary, but is generally stable. Now, the card mentioned is old enough for driver support to be discontinued.

What Nvidia driver were you using?

User avatar
bimshwel
Posts: 636
Joined: Tue Jul 15, 2003 5:15 pm
Discord: bimshwel #7516
Location: misplaced

Re: GZDoom "R_OPENGL: OpenGL driver not accelerated!" nvidia

Post by bimshwel »

this isn't a matter of performance level, just activating at all. The w530 thinkpad I could use until recently that ran gzdoom without incident was older than the w541 i have now and presumably its graphic parts were the same or even older.
quadroo.png

I tried all four of these drivers so far in addition to whichever installed itself at first. The one I mentioned earlier that wouldn't install I deduced was actually for 32 bit windows so maybe a wrong one really would go in as long as it liked the bits.
You do not have the required permissions to view the files attached to this post.
Last edited by bimshwel on Fri Sep 03, 2021 4:10 pm, edited 1 time in total.

Rachael
Admin
Posts: 12855
Joined: Tue Jan 13, 2004 1:31 pm
Discord: Rachael#3767
Twitch ID: madamerachelle
Github ID: madame-rachelle

Re: GZDoom "R_OPENGL: OpenGL driver not accelerated!" nvidia

Post by Rachael »

Redneckerz wrote:It should be noted that seeing two adapters isn't unusual. Windows by default has a Standard VGA Adapter - A basic adapter to just display the screen.

Actually, it is not normal to see that at all when everything is working properly, unless you actually do have a second adapter - in which case - it would try and detect it and install drivers for it.

Another guess that I have is, maybe you're plugging your monitor into the wrong HDMI slot. Which might be why the Microsoft Basic Display Adapter is activated. To be specific, a plug that is not specifically controlled by the NVidia driver. In my experience, that would cause this to happen.

User avatar
bimshwel
Posts: 636
Joined: Tue Jul 15, 2003 5:15 pm
Discord: bimshwel #7516
Location: misplaced

Re: GZDoom "R_OPENGL: OpenGL driver not accelerated!" nvidia

Post by bimshwel »

The monitor is attached to the unit since it is a portable computer. There are still a few more driver versions to try though nvidia's website isn't offering any from before 2018.
///////////
ehhhhdit: that is six tried now with no difference! the one in at present purports to be version "24.21.14.1163."
///////////
one hour later ehhhhhhhhdit: i can now confirm that the opengl works just fine and still appears with the second display adapter under windows 10. which i hate immediately and this development is incredibly inconvenient but not impossible to handle. I would say this is more compromised-with than resolved. thank to anyone who read through any of this garbage!

Return to “Technical Issues”