Voxel models have a flattened appearance

Need help running G/Q/ZDoom/ECWolf/Zandronum/3DGE? Did your computer break? Ask here.

Moderator: GZDoom Developers

User avatar
Dikiy Zver
Posts: 7
Joined: Sun Nov 08, 2020 6:10 am
Operating System: Windows 10/8.1/8/201x 64-bit

Voxel models have a flattened appearance

Post by Dikiy Zver »

I have a problem with displaying voxel models when working in Hardware (OpenGL) mode (I use LZDoom). Similar artifacts appear in all voxel models in all mods where they are involved. I tried switching to GZDoom, but the error was similar. I do not know what could be the reason.

Screenshots from Led's Generic Weapon Mod.
You do not have the required permissions to view the files attached to this post.
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
Posts: 47977
Joined: Sat Jul 19, 2003 10:19 am
Location: Germany

Re: Voxel models have a flattened appearance

Post by Graf Zahl »

Doesn't happen for me in neither GZDoom nor LZDoom.
What's your hardware specs?
User avatar
Dikiy Zver
Posts: 7
Joined: Sun Nov 08, 2020 6:10 am
Operating System: Windows 10/8.1/8/201x 64-bit

Re: Voxel models have a flattened appearance

Post by Dikiy Zver »

Graf Zahl wrote:Doesn't happen for me in neither GZDoom nor LZDoom.
What's your hardware specs?

Hardware specs:
Acer Aspire 3 Device
OS: Windows 10 64-bit
Video Adapters: APU1 - AMD Radeon(TM) Vega 3 Graphics - Main/Integrated/Hybrid; GPU2 - Radeon 530 Series - Discrete/Hybrid
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
Posts: 47977
Joined: Sat Jul 19, 2003 10:19 am
Location: Germany

Re: Voxel models have a flattened appearance

Post by Graf Zahl »

Does it only happen in LZDoom or also in GZDoom?
Also, is this mod specific?
Last but not least: Are your graphics drivers up to date?
User avatar
Dikiy Zver
Posts: 7
Joined: Sun Nov 08, 2020 6:10 am
Operating System: Windows 10/8.1/8/201x 64-bit

Re: Voxel models have a flattened appearance

Post by Dikiy Zver »

Graf Zahl wrote:Does it only happen in LZDoom or also in GZDoom?
Also, is this mod specific?
Last but not least: Are your graphics drivers up to date?
Does it only happen in LZDoom or also in GZDoom?
Answer: This happens in both LZDoom and GZDoom.

Also, is this mod specific?
Answer: This mod is no exception. In ANY mod where there are voxel models, these very models begin to behave inappropriately. The interesting thing is that when I run the mod with the voxel models enabled in Software mode, they acquire a normal appearance.

Last but not least: Are your graphics drivers up to date?
Answer: All drivers are updated to the latest version.
User avatar
Dark-Assassin
Posts: 727
Joined: Thu Mar 19, 2009 3:40 am
Location: South Australia

Re: Voxel models have a flattened appearance

Post by Dark-Assassin »

I too am getting this problem with GZDoom, LZDoom, and Raze using OpenGL. Vulkan and Software are fine. It even happens with regular 3D models.

I think AMD's latest drivers screwed something up with OpenGL again. However it doesn't happen in other OpenGL games I've tried.

I'm using an AMD RX 580 in my system.
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
Posts: 47977
Joined: Sat Jul 19, 2003 10:19 am
Location: Germany

Re: Voxel models have a flattened appearance

Post by Graf Zahl »

That indeed sounds like a driver bug. Nothing unusual for AMD on OpenGL. I'd recommend using Vulkan anyway on AMD if the hardware supports it as its performance is significantly better.
How does it fare with non-voxel models? They use the same method for rendering.
User avatar
Dark-Assassin
Posts: 727
Joined: Thu Mar 19, 2009 3:40 am
Location: South Australia

Re: Voxel models have a flattened appearance

Post by Dark-Assassin »

In GZDoom they also seem to render mostly flat unless during interpolation. They don't in Raze but rendering models on that only works on the old render and is broken in a different way anyway.
User avatar
Dikiy Zver
Posts: 7
Joined: Sun Nov 08, 2020 6:10 am
Operating System: Windows 10/8.1/8/201x 64-bit

Re: Voxel models have a flattened appearance

Post by Dikiy Zver »

Dark-Assassin wrote:In GZDoom they also seem to render mostly flat unless during interpolation. They don't in Raze but rendering models on that only works on the old render and is broken in a different way anyway.
And how can I enable Vulkan on the device?
User avatar
Kappes Buur
 
 
Posts: 4007
Joined: Thu Jul 17, 2003 12:19 am
Location: British Columbia, Canada

Re: Voxel models have a flattened appearance

Post by Kappes Buur »

Dikiy Zver wrote:And how can I enable Vulkan on the device?
According to AMD.com the driver supports The Vulkan® API.
According to this website it is Vulkan 1.2.

When you start GZDoom with the startup menu
Spoiler:
select the game IWAD and Vulkan for the Video Setting.
Or, if you do not see the startup menu, go into the ini file and set

queryiwad=true
queryiwad_key=shift

then restart GZDoom.

And if you set GZDoom to generate a logfile then you would see something like this in a text editor
Spoiler:
In your case, of course, the AMD RX580 for the Vulkan Device.
User avatar
Dikiy Zver
Posts: 7
Joined: Sun Nov 08, 2020 6:10 am
Operating System: Windows 10/8.1/8/201x 64-bit

Re: Voxel models have a flattened appearance

Post by Dikiy Zver »

Kappes Buur wrote:
Dikiy Zver wrote:And how can I enable Vulkan on the device?
According to AMD.com the driver supports The Vulkan® API.
According to this website it is Vulkan 1.2.

When you start GZDoom with the startup menu
Spoiler:
select the game IWAD and Vulkan for the Video Setting.
Or, if you do not see the startup menu, go into the ini file and set

queryiwad=true
queryiwad_key=shift

then restart GZDoom.

And if you set GZDoom to generate a logfile then you would see something like this in a text editor
Spoiler:
In your case, of course, the AMD RX580 for the Vulkan Device.
Thank you, now I know what I need... a full-fledged PC with a powerful video card))
User avatar
Rachael
Admin
Posts: 12888
Joined: Tue Jan 13, 2004 1:31 pm
Discord: Rachael#3767
Twitch ID: madamerachelle
Github ID: madame-rachelle

Re: Voxel models have a flattened appearance

Post by Rachael »

You already *HAVE* a Vulkan-capable device. You just have to enable Vulkan in GZDoom.

While in-game hit Esc, go to Options ->


then go to Set Video Mode ->


then go to Preferred Rendering API (at the very top) ->


Press the right arrow key until that says "Vulkan" - then exit out and restart GZDoom (has to be restarted completely).

You now have Vulkan enabled and the voxels should render correctly.
User avatar
Dikiy Zver
Posts: 7
Joined: Sun Nov 08, 2020 6:10 am
Operating System: Windows 10/8.1/8/201x 64-bit

Re: Voxel models have a flattened appearance

Post by Dikiy Zver »

I have run GZDoom before and it gives me this error:

Code: C0000005 (Access Violation - tried to read address 00000000000001C0)
Address: 00007FFA022AD3C6

Error Report:
You do not have the required permissions to view the files attached to this post.
User avatar
Rachael
Admin
Posts: 12888
Joined: Tue Jan 13, 2004 1:31 pm
Discord: Rachael#3767
Twitch ID: madamerachelle
Github ID: madame-rachelle

Re: Voxel models have a flattened appearance

Post by Rachael »

Strange. My Vulkan on my AMD works just fine. Your's is crashing in the AMD Vulkan driver interface, itself.

Please uninstall your drivers, and do a clean reinstall.

If that doesn't fix it, please check AMD's archives and download the driver last released from May of this year. That is the last known good working OpenGL driver.

Actually - here's a link: https://www.amd.com/en/support/kb/relea ... win-21-5-2
Look for where it says on the page "The Radeon Software Adrenalin 2020 Edition 21.5.2 installation package can be downloaded from the following links:"
User avatar
Nash
 
 
Posts: 17282
Joined: Mon Oct 27, 2003 12:07 am
Twitch ID: nashmuhandes
Github ID: nashmuhandes
Location: Kuala Lumpur, Malaysia

Re: Voxel models have a flattened appearance

Post by Nash »

Had to deal with a lot of this for ElderJam.

If using Vulkan on your AMD graphics isn't possible for whatever reason, another alternative is to downgrade your drivers to 21.5.2. This has been confirmed to solve all 3D issues.

Return to “Technical Issues”