GZDoom 4.6.1 takes too long to launch

Need help running G/Q/ZDoom/ECWolf/Zandronum/3DGE? Did your computer break? Ask here.

Moderator: GZDoom Developers

User avatar
IvanDobrovski
Posts: 83
Joined: Mon Aug 08, 2016 4:05 am

GZDoom 4.6.1 takes too long to launch

Post by IvanDobrovski »

I've been previously using 4.5.0 of GZDoom and it launches immediately, however the new 4.6.1 version takes a long time to launch.

Video describing exactly what is happening:
Spoiler:
Video showing how fast it should be, on 4.5.0:
Spoiler:
Earliest dev build I've found to have this slowdown: gzdoom-x64-g4.7.0pre-62-g2d63974d3.7z
User avatar
Rachael
Admin
Posts: 12895
Joined: Tue Jan 13, 2004 1:31 pm
Discord: Rachael#3767
Twitch ID: madamerachelle
Github ID: madame-rachelle
Preferred Pronouns: She/Her

Re: GZDoom 4.6.1 takes too long to launch

Post by Rachael »

That is the oldest build that is publicly visible as of this post.

Does 4.6.0 have the slowdown issue?
User avatar
IvanDobrovski
Posts: 83
Joined: Mon Aug 08, 2016 4:05 am

Re: GZDoom 4.6.1 takes too long to launch

Post by IvanDobrovski »

Rachael wrote:That is the oldest build that is publicly visible as of this post.

Does 4.6.0 have the slowdown issue?
I just tried, yep it has the exact same issue.
User avatar
Enjay
 
 
Posts: 26403
Joined: Tue Jul 15, 2003 4:58 pm
Location: Scotland

Re: GZDoom 4.6.1 takes too long to launch

Post by Enjay »

Just an outside chance - do you have any anti-virus software that maybe doesn't recognise the newer versions (not that 4.6.0 is that new)?

I have seen similar delays with other software when the anti-virus doesn't recognise a program from its white list and needs to "call home" a virus check on it.
User avatar
IvanDobrovski
Posts: 83
Joined: Mon Aug 08, 2016 4:05 am

Re: GZDoom 4.6.1 takes too long to launch

Post by IvanDobrovski »

Enjay wrote:Just an outside chance - do you have any anti-virus software that maybe doesn't recognise the newer versions (not that 4.6.0 is that new)?

I have seen similar delays with other software when the anti-virus doesn't recognise a program from its white list and needs to "call home" a virus check on it.
I think you were on to something, because I noticed just now after running it as admin it launched as fast as it should be. It seems the problem is "magically" gone now as well, after having launched it as admin. I assume that made it "trustable" to the system. I'll keep this in mind for the future. Thanks!
7SyntaxError
Posts: 4
Joined: Sat Jun 26, 2021 7:46 am
Operating System: Other Linux 64-bit
OS Test Version: No (Using Stable Public Version)
Graphics Processor: ATI/AMD with Vulkan Support

Re: GZDoom 4.6.1 takes too long to launch

Post by 7SyntaxError »

IvanDobrovski wrote:
Enjay wrote:Just an outside chance - do you have any anti-virus software that maybe doesn't recognise the newer versions (not that 4.6.0 is that new)?

I have seen similar delays with other software when the anti-virus doesn't recognise a program from its white list and needs to "call home" a virus check on it.
I think you were on to something, because I noticed just now after running it as admin it launched as fast as it should be. It seems the problem is "magically" gone now as well, after having launched it as admin. I assume that made it "trustable" to the system. I'll keep this in mind for the future. Thanks!
Never run executables with admin privileges unless you absolutely have to. It's dangerous to do so.

Return to “Technical Issues”