Page 2 of 2

Re: Figuring out how to use GZDoom on Linux Mint [news topic

PostPosted: Fri Jul 30, 2021 3:12 pm
by pfred1x
Did you ever get it to work?
I define $DOOMWADDIR in my environment which Doom honors and then keep all of my game files there and the engine finds them fine.

At the command prompt (no dollar sign attached to the variable):
$ export DOOMWADDIR="/path/to/some/directory"

You can put that into your ~/.profile file and it'll just load into your environment automatically. Without the $ prompt. Just:
export DOOMWADDIR="/path/to/some/directory"

Another command:
Now the $ gets a little confusing the first one (which you don't type) is the prompt and the second one (which you do type) tells the shell you are looking for a variable:
$ echo $DOOMWADDIR

This is what mine looks like:
$ echo $DOOMWADDIR
/home/pfred1/bin/share/games/doom

That displays the variable. You'd see it issuing the "env" command which shows your entire environment.

My game can also use pk3 files too. I build the engine from source and just include everything. Right now I'm running:

GZDoom g4.4pre-34-gb453c87b7 - 2020-02-08 03:07:06 -0300 - SDL version
Compiled on Feb 8 2020

My binary is linked to libz.so.1, libbz2.so.1.0, liblz4.so.1, liblzma.so.5 and they all do decompression. You use the ldd command to see what shared objects your binary is linked to. Something like:

$ ldd /home/pfred1/Build/gzdoom/gzdoom/build/gzdoom

ldd likes a full path to the file. Which in my case spits out a list 63 lines long. So it is linked to a lot of libraries.

$ ldd /home/pfred1/Build/gzdoom/gzdoom/build/gzdoom | wc -l
63

That's interesting. My old binary is linked to two libraries my newer engine isn't linked to. But that's unrelated.

Re: Figuring out how to use GZDoom on Linux Mint [news topic

PostPosted: Wed Sep 29, 2021 6:20 pm
by omxgamer127
Hi man ,it is possible to define or change the default iwad location directory (DOOMWADDIR/DOOMWADPATH) by a command line parameter
for gzdoom/lzdoom
i need it it to create an autoplay menu builder for my repack
the problem is my iwad/pwad data and my sourceport is in different folder

Re: Figuring out how to use GZDoom on Linux Mint [news topic

PostPosted: Thu Sep 30, 2021 5:17 pm
by Blzut3
There's no command line option to add a search path beyond manipulating the DOOMWADDIR environment variable. You can however pass full paths to the files you want to load in "-iwad" or "-file". Also GZDoom searches the current working directory for iwads by default, so unless you need a specific working directory you can always cd to the iwad location.