.deh is old and unsupported

Need help running G/Q/ZDoom/ECWolf/Zandronum/3DGE? Did your computer break? Ask here.

Moderator: GZDoom Developers

.deh is old and unsupported

Postby spoone » Tue May 11, 2021 12:05 pm

I hope this was the right place to post this. I'm trying to run the original Aliens tc with the dehacked patch it came with, but it keeps saying .deh is old and unsupported. Is there a way to fix this?
spoone
 
Joined: 24 Apr 2006

Re: .deh is old and unsupported

Postby drfrag » Tue May 11, 2021 12:11 pm

Which version of GZDoom? What's the exact message? I can't find that string in the source. Probably is a very old dehacked patch.
User avatar
drfrag
Os voy a romper a pedazos!
Vintage GZDoom Developer
 
Joined: 23 Apr 2004
Location: Spain
Discord: drfrag#3555
Github ID: drfrag666

Re: .deh is old and unsupported

Postby spoone » Tue May 11, 2021 12:21 pm

Most recent version. It says Atc2.deh is an old and unsupported patch.
spoone
 
Joined: 24 Apr 2006

Re: .deh is old and unsupported

Postby openroadracer » Tue May 11, 2021 1:10 pm

spoone wrote:Most recent version.
"Most recent" doesn't help us. Can you relate the version of GZDoom you have to a specific GitHub GZDoom release or commit?
User avatar
openroadracer
 
Joined: 23 Sep 2019
Operating System: Windows Vista/7/2008 64-bit
OS Test Version: No (Using Stable Public Version)
Graphics Processor: ATI/AMD with Vulkan Support

Re: .deh is old and unsupported

Postby Rachael » Tue May 11, 2021 1:14 pm

I think he's referring to the .deh patch itself, which makes it quite a moot point what version of GZDoom he is using.

Older Dehacked versions used to save the patches in binary format which GZDoom can't read.

GZDoom can only read the text versions from the most recent version of Dehacked.

That same recent Dehacked executable can read said patches, temporarily apply them, and then resave them in text format which GZDoom will be able to read.

You will need DOSBox in order to do this.
User avatar
Rachael
Admin
 
Joined: 13 Jan 2004
Discord: Rachael#3767
Twitch ID: madamerachelle
Github ID: madame-rachelle
Operating System: Debian-like Linux (Debian, Ubuntu, Mint, etc) 64-bit
OS Test Version: No (Using Stable Public Version)
Graphics Processor: nVidia with Vulkan support

Re: .deh is old and unsupported

Postby Devalaous » Sat May 15, 2021 9:06 pm

Its better to use the repackaged version by Quasar, it solves this issue.
Devalaous
 
Joined: 23 Apr 2021
Location: New Zealand
Operating System: Windows 10/8.1/8/201x 64-bit
Graphics Processor: nVidia with Vulkan support

Re: .deh is old and unsupported

Postby Matt » Mon May 17, 2021 6:05 pm

Could the error message be improved to explain that it's the binary that's the problem?
User avatar
Matt
Putting the XD into *xdeath since 2007
 
Joined: 04 Jan 2004
Location: Gotham City SAR, Wyld-Lands of the Lotus People, Dominionist PetroConfederacy of Saudi Canadia

Re: .deh is old and unsupported

Postby Blzut3 » Tue May 18, 2021 6:02 am

I'm not sure how that would be any better? The problem is exactly what the error message says: the dehacked file is in an old format which is unsupported by GZDoom. I suppose it would be a little more clear if it said something along the lines of "was made by an unsupported version of DeHackEd < 2.3" instead of just saying the mod is old.
Blzut3
Pronounced: B-l-zut
 
 
 
Joined: 24 Nov 2004
Github ID: Blzut3
Operating System: Debian-like Linux (Debian, Ubuntu, Mint, etc) 64-bit
Graphics Processor: ATI/AMD with Vulkan Support

Re: .deh is old and unsupported

Postby Gez » Tue May 18, 2021 6:36 am

Yeah, if the message said that it's the version of the DEH patch that is old and unsupported, it would be a lot more clear.
Gez
 
 
 
Joined: 06 Jul 2007

Re: .deh is old and unsupported

Postby spoone » Tue May 18, 2021 7:58 am

So is there just no fix at all for this error?
spoone
 
Joined: 24 Apr 2006

Re: .deh is old and unsupported

Postby Rachael » Tue May 18, 2021 8:00 am

spoone wrote:So is there just no fix at all for this error?


Rachael wrote:That same recent Dehacked executable can read said patches, temporarily apply them, and then resave them in text format which GZDoom will be able to read.

You will need DOSBox in order to do this.


You will have to do this. Load the patch with the latest version of DeHackEd and then save it again so it saves as text format.
User avatar
Rachael
Admin
 
Joined: 13 Jan 2004
Discord: Rachael#3767
Twitch ID: madamerachelle
Github ID: madame-rachelle
Operating System: Debian-like Linux (Debian, Ubuntu, Mint, etc) 64-bit
OS Test Version: No (Using Stable Public Version)
Graphics Processor: nVidia with Vulkan support

Re: .deh is old and unsupported

Postby spoone » Tue May 18, 2021 10:17 am

I keep trying to open dehacked in dosbox but it keeps saying can't find Doombak.exe. I even tried editing the .ini.
spoone
 
Joined: 24 Apr 2006

Re: .deh is old and unsupported

Postby wildweasel » Tue May 18, 2021 10:51 am

Perhaps this one's more worth looking into:
Devalaous wrote:Its better to use the repackaged version by Quasar, it solves this issue.
User avatar
wildweasel
from a different perspective.
Moderator Team Lead
 
Joined: 15 Jul 2003


Return to Technical Issues

Who is online

Users browsing this forum: No registered users and 0 guests