GZdoom 4.5.0 sound effect and music issues

Need help running G/Q/ZDoom/ECWolf/Zandronum/3DGE? Did your computer break? Ask here.

Moderator: GZDoom Developers

GZdoom 4.5.0 sound effect and music issues

Postby amdcrash » Fri Mar 26, 2021 2:10 am

when trying to play any wad, GZDoom plays the music through my primary monitor and the sound effects through the laptop's speakers. how do i get it to play sound effects through the speakers of the monitor?
amdcrash
 
Joined: 21 Feb 2019

Re: GZdoom 4.5.0 sound effect and music issues

Postby Chris » Fri Mar 26, 2021 4:15 pm

amdcrash wrote:when trying to play any wad, GZDoom plays the music through my primary monitor and the sound effects through the laptop's speakers. how do i get it to play sound effects through the speakers of the monitor?

I'm guessing you're on Windows. If so, setting the monitor as the default sound device should make GZDoom use it by default. You can also check the game's sound options (Full options menu -> Sound Options -> Advanced options -> OpenAL options) to make sure you have the default sound device selected.
User avatar
Chris
 
Joined: 17 Jul 2003

Re: GZdoom 4.5.0 sound effect and music issues

Postby amdcrash » Sun Mar 28, 2021 8:38 am

Chris wrote:
amdcrash wrote:when trying to play any wad, GZDoom plays the music through my primary monitor and the sound effects through the laptop's speakers. how do i get it to play sound effects through the speakers of the monitor?

I'm guessing you're on Windows. If so, setting the monitor as the default sound device should make GZDoom use it by default. You can also check the game's sound options (Full options menu -> Sound Options -> Advanced options -> OpenAL options) to make sure you have the default sound device selected.


thank you for your reply, i had a look at my sound settings and found it was set to my speakers on the monitor but then i saw the openAL options portion and had a look which turned out to have the wrong speaker set, changing it and restarting GZDoom fixed it.
amdcrash
 
Joined: 21 Feb 2019


Return to Technical Issues

Who is online

Users browsing this forum: No registered users and 0 guests