OpenGL 3.3 requirement

Need help running G/Q/ZDoom/ECWolf/Zandronum/3DGE? Did your computer break? Ask here.

Moderator: GZDoom Developers

OpenGL 3.3 requirement

Postby David Shakegold » Mon Mar 08, 2021 12:33 am

is this OpenGL 3.3 a separate download driver or what am i missing?

does it not come with the latest GZDoom download??
David Shakegold
 

Re: OpenGL 3.3 requirement

Postby Graf Zahl » Mon Mar 08, 2021 12:59 am

OpenGL is implemented by the graphics driver. If yours reports that it doesn't support it the most likely cause is that your graphics hardware is too old.
What's your system specs?
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
 
Joined: 19 Jul 2003
Location: Germany

Re: OpenGL 3.3 requirement

Postby axredneck » Mon Mar 08, 2021 8:40 am

Usually this means that:
1. Your hardware is old - in this case you should upgrade a GPU or use another source port
or
2. You don't have proper driver installed - in this case you should download a driver from your GPU manufacturer site.
User avatar
axredneck
excuse me for my bad English
 
Joined: 11 Dec 2017
Location: Russia
Github ID: axredneck
Operating System: Other Linux 64-bit
OS Test Version: No (Using Stable Public Version)
Graphics Processor: nVidia with Vulkan support


Return to Technical Issues

Who is online

Users browsing this forum: No registered users and 3 guests