LZDoom 3.87c running at horrible frames on menu and in game

Need help running G/Q/ZDoom/ECWolf/Zandronum/3DGE? Did your computer break? Ask here.

Moderator: GZDoom Developers

LZDoom 3.87c running at horrible frames on menu and in game

Postby QuadMachine2 » Thu Feb 11, 2021 10:10 pm

Ok so when I open up LZDoom patched with wtfi.exe so I can run it under OpenGL it just runs at the worst framerates like 0-1 frames, any help, here's my specs
Intel i3 1.4 GHZ Dual Core
Intel Integrated HD 3000 512 MB VRAM, OpenGL 1.1, DirectX 11, Vulkan not supported
4 GB RAM DDR3
1336x768 60 HZ screen
Up to date drivers
Not up to date with windows updates
QuadMachine2
 
Joined: 11 Feb 2021
Discord: xants#6964
Operating System: Windows 10/8.1/8/201x 64-bit
OS Test Version: No (Using Stable Public Version)
Graphics Processor: Intel (Legacy GZDoom)

Re: LZDoom 3.87c running at horrible frames on menu and in g

Postby drfrag » Fri Feb 12, 2021 6:40 am

That's becouse you're using a software driver, you need to install the driver from intel not to update the microsoft driver (it doesn't support OpenGL).
User avatar
drfrag
Os voy a romper a pedazos!
Vintage GZDoom Developer
 
Joined: 23 Apr 2004
Location: Spain
Discord: drfrag#3555
Github ID: drfrag666

Re: LZDoom 3.87c running at horrible frames on menu and in g

Postby QuadMachine2 » Fri Feb 12, 2021 9:45 pm

drfrag wrote:That's becouse you're using a software driver, you need to install the driver from intel not to update the microsoft driver (it doesn't support OpenGL).

Not sure what you mean by "software driver", could you please elaborate
QuadMachine2
 
Joined: 11 Feb 2021
Discord: xants#6964
Operating System: Windows 10/8.1/8/201x 64-bit
OS Test Version: No (Using Stable Public Version)
Graphics Processor: Intel (Legacy GZDoom)

Re: LZDoom 3.87c running at horrible frames on menu and in g

Postby _mental_ » Sat Feb 13, 2021 2:07 am

Install graphics driver made by Intel.
_mental_
 
 
 
Joined: 07 Aug 2011

Re: LZDoom 3.87c running at horrible frames on menu and in g

Postby QuadMachine2 » Tue Feb 16, 2021 8:14 pm

_mental_ wrote:Install graphics driver made by Intel.

Nope, didn't solve it, it could be because of the wtfi patcher though, whatever, it's Intels fault
QuadMachine2
 
Joined: 11 Feb 2021
Discord: xants#6964
Operating System: Windows 10/8.1/8/201x 64-bit
OS Test Version: No (Using Stable Public Version)
Graphics Processor: Intel (Legacy GZDoom)

Re: LZDoom 3.87c running at horrible frames on menu and in g

Postby drfrag » Wed Feb 17, 2021 5:59 am

Also be aware that HD3000 graphics are not supported on Windows 10

It's a bit complicated. There's a link here to "fix" the driver but is it worth?
https://gist.github.com/rb-dahlb/26f316 ... 44ee69f0d1
Instead of Python add the path to LZDoom (and then you don't need wtfi).
User avatar
drfrag
Os voy a romper a pedazos!
Vintage GZDoom Developer
 
Joined: 23 Apr 2004
Location: Spain
Discord: drfrag#3555
Github ID: drfrag666

Re: LZDoom 3.87c running at horrible frames on menu and in g

Postby QuadMachine2 » Wed Feb 17, 2021 7:11 pm

drfrag wrote:
Also be aware that HD3000 graphics are not supported on Windows 10

It's a bit complicated. There's a link here to "fix" the driver but is it worth?
https://gist.github.com/rb-dahlb/26f316 ... 44ee69f0d1
Instead of Python add the path to LZDoom (and then you don't need wtfi).

Didn't work either, so I have no idea what to do
QuadMachine2
 
Joined: 11 Feb 2021
Discord: xants#6964
Operating System: Windows 10/8.1/8/201x 64-bit
OS Test Version: No (Using Stable Public Version)
Graphics Processor: Intel (Legacy GZDoom)

Re: LZDoom 3.87c running at horrible frames on menu and in g

Postby drfrag » Thu Feb 18, 2021 5:47 am

Try again with an unpatched lzdoom.exe or use the software renderer.
User avatar
drfrag
Os voy a romper a pedazos!
Vintage GZDoom Developer
 
Joined: 23 Apr 2004
Location: Spain
Discord: drfrag#3555
Github ID: drfrag666

Re: LZDoom 3.87c running at horrible frames on menu and in g

Postby QuadMachine2 » Thu Feb 18, 2021 5:36 pm

drfrag wrote:Try again with an unpatched lzdoom.exe or use the software renderer.

Also didn't work, and I don't really like software renderer it's just kind of slow
QuadMachine2
 
Joined: 11 Feb 2021
Discord: xants#6964
Operating System: Windows 10/8.1/8/201x 64-bit
OS Test Version: No (Using Stable Public Version)
Graphics Processor: Intel (Legacy GZDoom)

Re: LZDoom 3.87c running at horrible frames on menu and in g

Postby Redneckerz » Fri Feb 19, 2021 2:54 pm

QuadMachine2 wrote:
drfrag wrote:Try again with an unpatched lzdoom.exe or use the software renderer.

Also didn't work, and I don't really like software renderer it's just kind of slow

Okay, let's zoom in then;
What are the exact steps that you are doing that lead to the issues you are having?
Which drivers are installed?
Do you run anything else alongside LZDoom (a mod, etc)?
User avatar
Redneckerz
To it's ports i may have seen
Spotlight Team
 
Joined: 25 Nov 2019
Discord: Redneckerz#8399
Operating System: Windows 10/8.1/8/201x 64-bit
Graphics Processor: Intel (Modern GZDoom)

Re: LZDoom 3.87c running at horrible frames on menu and in g

Postby QuadMachine2 » Sun Feb 21, 2021 1:09 pm

Redneckerz wrote:
QuadMachine2 wrote:
drfrag wrote:Try again with an unpatched lzdoom.exe or use the software renderer.

Also didn't work, and I don't really like software renderer it's just kind of slow

Okay, let's zoom in then;
What are the exact steps that you are doing that lead to the issues you are having?
Which drivers are installed?
Do you run anything else alongside LZDoom (a mod, etc)?

Ok so I've been using the 64 bit version of LZDoom since my laptop is 64 bit and it's the only version I can patch with wtfi, when I dont patch it, I get the OpenGL driver not accerlated when running it under the OpenGL option, I patch it with wtfi.exe, it works, but I get 0-1 FPS, the other option that DrFrag sent gave the same results as patching it with wtfi. The drivers are up to date, and no, no mod or anything is being run alongside with it
QuadMachine2
 
Joined: 11 Feb 2021
Discord: xants#6964
Operating System: Windows 10/8.1/8/201x 64-bit
OS Test Version: No (Using Stable Public Version)
Graphics Processor: Intel (Legacy GZDoom)

Re: LZDoom 3.87c running at horrible frames on menu and in g

Postby drfrag » Sun Feb 21, 2021 2:42 pm

Those instructions i linked were to make your driver work on windows 10, but of course you can't make the driver work if you haven't installed any driver.
According to intel the driver does not work on win10 but i don't know, may be you don't even need to follow those steps.
Just install the driver on win8.1 compatibility mode, may be it works after all. Same thing for lzdoom itself. And if it doesn't run then install win8.1 instead.
https://downloadcenter.intel.com/downlo ... ows-15-28-
User avatar
drfrag
Os voy a romper a pedazos!
Vintage GZDoom Developer
 
Joined: 23 Apr 2004
Location: Spain
Discord: drfrag#3555
Github ID: drfrag666


Return to Technical Issues

Who is online

Users browsing this forum: No registered users and 0 guests