Page 1 of 1

[GZDoom 4.1.2] Crash from zcsript GiveInventory? [SOLVED]

PostPosted: Thu Jun 06, 2019 8:46 am
by Spaceman333
I started encountering a strange error after installing GZDoom 4.1.2 which didn't happen in 3.6.0 I used prior.

Heres a screenshot of the error:

https://ibb.co/dLQzgWg

I don't know what the exact cause is, but it has to do something with spawning or using inventory items. The mod I get this error with is Boom Power Reborn that uses zscript to make any monster explode on death and occasionally drop items. Another mod that I had the error occur with was UAC Survival Pack with adds standalone grenades, flares and pipebombs.

Has anyone else gotten this error?

I'm not sure if this error is due to the mods I'm using or gzdoom itself.

Re: [GZDoom 4.1.2] Crash from zcsript GiveInventory?

PostPosted: Thu Jun 06, 2019 8:54 am
by _mental_
Most likely it's the same bug as this one. You can use the latest devbuild, the issue is already fixed there.

Re: [GZDoom 4.1.2] Crash from zcsript GiveInventory?

PostPosted: Fri Jun 07, 2019 11:59 am
by Spaceman333
_mental_ wrote:Most likely it's the same bug as this one. You can use the latest devbuild, the issue is already fixed there.


Thank you! That definitely looks like the same one. :thumb: