GZDoom 3.7.1 save games incompatible

Need help running G/Q/ZDoom/ECWolf/Zandronum/3DGE? Did your computer break? Ask here.

Moderator: GZDoom Developers

GZDoom 3.7.1 save games incompatible

Postby Gato303 » Sat Jan 19, 2019 8:51 pm

Good evening. Different topic, but related to the update to the latest version and I don't want to start a new thread:

I updated GZDoom on my Linux Mint 19 using the DRDTeam repository, now it's on version 3.7.1 and I found the nasty surprise that the savegames from previous version are not compatible with the new version :shock: :shock: It doesn't even tell me in which level I was in the previous version savegame, it just says "DIFFERENT VERSION" :( :( And I have like 6 different savegames each one for a different mod + megawad maps.

Any help about if is possible to "migrate" the old savegames into the new version? Thanks
User avatar
Gato303
 
Joined: 30 Mar 2016
Location: Colombia

Re: GZDoom 3.7.1 save games incompatible

Postby Rachael » Sat Jan 19, 2019 9:16 pm

It's not nice to bump someone else's topic to start a new and completely unrelated discussion. >_< I've gone ahead and split your post.
User avatar
Rachael
Webmaster
 
Joined: 13 Jan 2004
Discord: Rachael#3767
Twitch ID: madamerachelle
Github ID: madame-rachelle
Operating System: Windows 10/8.1/8/201x 64-bit
OS Test Version: No (Using Stable Public Version)
Graphics Processor: nVidia with Vulkan support

Re: GZDoom 3.7.1 save games incompatible

Postby Graf Zahl » Sun Jan 20, 2019 12:53 am

You'll have to play those saves with the old version. Between 3.6.0 and 3.7.0 some changes were made that render savegames incompatible.
Sometimes this can happen when data gets restructured.
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
 
Joined: 19 Jul 2003
Location: Germany

Re: GZDoom 3.7.1 save games incompatible

Postby Gato303 » Sun Jan 20, 2019 12:08 pm

Rachael wrote:It's not nice to bump someone else's topic to start a new and completely unrelated discussion. >_< I've gone ahead and split your post.

I'm sorry, but I didn't know what to do and didn't want to get into trouble by creating a new thread, since many things looks like creating a problem when posting in the forums, so I wasn't unsure what to do :o
Last edited by Gato303 on Sun Jan 20, 2019 12:16 pm, edited 1 time in total.
User avatar
Gato303
 
Joined: 30 Mar 2016
Location: Colombia

Re: GZDoom 3.7.1 save games incompatible

Postby Gato303 » Sun Jan 20, 2019 12:16 pm

Graf Zahl wrote:You'll have to play those saves with the old version. Between 3.6.0 and 3.7.0 some changes were made that render savegames incompatible.
Sometimes this can happen when data gets restructured.


Thanks for answering, though, I am sorry, but how can I do that? I already checked the DRDTeam "Debian repository" and they retired the 3.6 version, so I can't do a "Force Version" to 3.6 instead of the 3.7 and as far as I know that repository is the only way to get GZDoom builds for Linux Mint (Ubuntu actually), any other builds on the DRDTeam website are done for Windows.
User avatar
Gato303
 
Joined: 30 Mar 2016
Location: Colombia

Re: GZDoom 3.7.1 save games incompatible

Postby Gato303 » Sun Jan 20, 2019 12:25 pm

Ok.... I found this page on the DRDTeam:

http://debian.drdteam.org/pool/multiverse/g/gzdoom/

It contains many GZDoom builds installers in *.DEB format, for versions since 1.7.1

Seems those old packages can't be reached through the repository but have to be downloaded directly.
I may try to uninstall the 3.7 version and then install the 3.6 version using the *.DEB file from DRDTeam page, hoping that won't create a dependency problem, also hoping that might help other people in a similar situation.

Thanks for the help.
User avatar
Gato303
 
Joined: 30 Mar 2016
Location: Colombia

Re: GZDoom 3.7.1 save games incompatible

Postby Pa9an » Mon Nov 02, 2020 5:15 pm

Sorry to dig out this old thread...but I have similar question:
I have lost many savegames due to incompatibilites between some old versions, might also have been 3.6 -> 3.7.

Now I'm playing on the 4.3.3 version of GZDoom on Linux Mint with many dozen savegames against different games - and don't want to lose all progress again when updating to 4.4.2 or 4.5.0...

So, is there any way to find out whether savegames are compatible to the previous version?
So 4.3.3 going to 4.4.2, or 4.4.2 going to 4.5.0 ?
The changelogs are not telling anything - so would it be safe to update or is this no info that would be in the changelog anyway?
(IMHO for a *game* engine, savegame compatibility (ot the lack thereof) should be considered a major information that should easily to be found out...)
Pa9an
 
Joined: 02 May 2018

Re: GZDoom 3.7.1 save games incompatible

Postby Rachael » Tue Nov 03, 2020 5:53 am

Pa9an wrote:(IMHO for a *game* engine, savegame compatibility (ot the lack thereof) should be considered a major information that should easily to be found out...)

There isn't an easy setup in place to allow for that, the problem is it is stored in version.h and the changes to that file aren't always reflected in the changelog. But I do agree something like that would be helpful.

Pa9an wrote:Now I'm playing on the 4.3.3 version of GZDoom on Linux Mint with many dozen savegames against different games - and don't want to lose all progress again when updating to 4.4.2 or 4.5.0...

What you can do is backup your old GZDoom installation, install the new one over it, test it, if it doesn't work then put back your previous version.

Also - there is a past version archive you can access here: https://zdoom.org/files/gzdoom/bin/
User avatar
Rachael
Webmaster
 
Joined: 13 Jan 2004
Discord: Rachael#3767
Twitch ID: madamerachelle
Github ID: madame-rachelle
Operating System: Windows 10/8.1/8/201x 64-bit
OS Test Version: No (Using Stable Public Version)
Graphics Processor: nVidia with Vulkan support

Re: GZDoom 3.7.1 save games incompatible

Postby Pa9an » Wed Nov 04, 2020 4:07 pm

Rachael wrote:What you can do is backup your old GZDoom installation, install the new one over it, test it, if it doesn't work then put back your previous version.
Also - there is a past version archive you can access here: https://zdoom.org/files/gzdoom/bin/

Thanks for the recommendations.
I got hold of the 4.3.3 version first and made sure it would re-install in case the new version wouldn't work and updated to 4.5.0 now.
All savegames still work...phew :) ...but good to have had the backup handy just in case...
Pa9an
 
Joined: 02 May 2018


Return to Technical Issues

Who is online

Users browsing this forum: No registered users and 2 guests