ZDoom 3.7.1 .ini file a mess

Need help running G/Q/ZDoom/ECWolf/Zandronum/3DGE? Did your computer break? Ask here.

Moderator: GZDoom Developers

ZDoom 3.7.1 .ini file a mess

Postby arxanaxra » Sat Jan 12, 2019 4:59 pm

Hi all,
Up until this recent update the .ini file arrangement was pretty consistent and standard. Like this:

# This file was generated by GZDoom g1.8.2 on Sat Jan 05 10:05:03 2019

# These are the directories to automatically search for IWADs.
# Each directory should be on a separate line, preceded by Path=
[IWADSearch.Directories]
Path=C:\Games\doom2\plutonia\doom2.wad
Path=$HOME
Path=$PROGDIR

# These are the directories to search for wads added with the -file
# command line parameter, if they cannot be found with the path
# as-is. Layout is the same as for IWADSearch.Directories
[FileSearch.Directories]
Path=$PROGDIR
Path=$DOOMWADDIR
Path=

Now, though, the file for this latest version looks like this:

# This file was generated by GZDoom g3.7.1 on Sat Jan 12 13:01:01 2019# These are the directories to automatically search for IWADs.# Each directory should be on a separate line, preceded by Path=[IWADSearch.Directories]Path=.Path=$DOOMWADDIRPath=$HOMEPath=$PROGDIR# These are the directories to search for wads added with the -file# command line parameter, if they cannot be found with the path# as-is. Layout is the same as for IWADSearch.Directories[FileSearch.Directories]Path=$PROGDIRPath=$DOOMWADDIR# These are the directories to search for soundfonts that let listed in the menu.# Layout is the same as for

Straightening it out so it makes sense and isn't all jumbled is easy enough, if I paste the file in here it pastes logically,...hope this is making sense. But after playing and exiting it is all run together again. I can't figure it out and can only hope someone else has been having this issue and maybe figured out what is happening. Just using notepad as a text editor like I always have. I've tried playing the older version I have with edits to the file and it remains orderly, no runon, only this later version is doing it so it can't be something windows related. Anybody know anything about this?
Thanks.
arxanaxra
 
Joined: 12 Jan 2019

Re: ZDoom 3.7.1 .ini file a mess

Postby Rachael » Sat Jan 12, 2019 5:08 pm

GZDoom recently changed the line-endings for the .ini file. They are still there, and they are still standard, it's just not a standard that Windows notepad recognizes. You must use an alternative tool - like WordPad, or Notepad2, in order to edit the file.
User avatar
Rachael
Webmaster
 
Joined: 13 Jan 2004
Discord: Rachael#3767
Twitch ID: madamerachelle
Github ID: madame-rachelle

Re: ZDoom 3.7.1 .ini file a mess

Postby Graf Zahl » Sat Jan 12, 2019 5:44 pm

To further explain, this happened because it now uses a file writing mechanism that doesn't go through the line ending filter in Microsoft's runtime library. And since Notepad is the only text editor having problems with it I see no point reverting to the inferior file handling.
User avatar
Graf Zahl
Lead GZDoom Developer
Lead GZDoom Developer
 
Joined: 19 Jul 2003
Location: Germany

Re: ZDoom 3.7.1 .ini file a mess

Postby Enjay » Sun Jan 13, 2019 5:49 am

Yup, it's come up a couple of times:

viewtopic.php?f=7&t=61901
viewtopic.php?f=7&t=62689
User avatar
Enjay
Everyone is a moon, and has a dark side which he never shows to anybody. Twain
 
 
 
Joined: 15 Jul 2003
Location: Scotland

Re: ZDoom 3.7.1 .ini file a mess

Postby arxanaxra » Sun Jan 13, 2019 8:12 pm

Thanks, it's a simple matter to use another text editor. All's good and appreciate the return.
arxanaxra
 
Joined: 12 Jan 2019


Return to Technical Issues

Who is online

Users browsing this forum: No registered users and 2 guests