FPS brought to zero on decent PC

Need help running G/Q/ZDoom/ECWolf/Zandronum/3DGE? Did your computer break? Ask here.

Moderator: GZDoom Developers

FPS brought to zero on decent PC

Postby Grey-Wolf » Fri Jan 11, 2019 6:04 am

So here's my issue: I can play most mods and the vanilla games with solid 200 fps with vsync off. Sometimes, playing map packs, I start a level with this fps, then this is gradually lowered until it reaches zero (even if i stand completely still at the starting location), making the game completely unplayable in a minute or so. I tried playing the same level on Zandronum without a problem, but honestly, I don't want to play on Zandronum XD.

I think this COULD be something related to particles: I was playng "Temple of the Lizard Men 2", a map pack for doom 2. I enter the first level, fps starts at 200 and begins to drop gradually. I rush through the level to see if something changes if I move to another area, and I get to an open area with a bonfire of sorts in the distance.
[imgur]https://i.imgur.com/uE1grHo.jpg[/imgur]

FPS is around 40 at this point. I take some steps forwards, and the fire completely glitches out, bringing my FPS istantly to 0
[imgur]https://i.imgur.com/NUOfDny.jpg[/imgur]

Things I tried:
- disabling various lighting options
- limiting the particles number

My specs (sorta):
Nvidia Geforce GTX 970
16 GB RAM
i5 processor (can't remember the model)
Windows 7

Can someone help me?
User avatar
Grey-Wolf
 
Joined: 15 Jul 2018

Re: FPS brought to zero on decent PC

Postby drfrag » Fri Jan 11, 2019 6:43 am

It's a known problem with that mod, it keeps generating actors without control. It worked on old versions tough and i don't remember why.
There's a more recent version that might be fixed at the Temple IV thread, the idgames versions were obsolete.
Edit: found it. viewtopic.php?f=7&t=61658&p=1068427
It's fixed in the newer version. viewtopic.php?f=19&t=49164
User avatar
drfrag
I.R developer, I.R smart
Vintage GZDoom Developer
 
Joined: 23 Apr 2004
Location: Spain

Re: FPS brought to zero on decent PC

Postby Grey-Wolf » Fri Jan 11, 2019 6:57 am

Well, this actually worked, thank you!
But this happened to me in other mods (league of heroes for example). Can you confirm that this is always a problem on gzdoom's end? An if so, why doesn't Zandronum have the same issue?
User avatar
Grey-Wolf
 
Joined: 15 Jul 2018

Re: FPS brought to zero on decent PC

Postby Graf Zahl » Fri Jan 11, 2019 7:36 am

I cannot say anything about other mods, but the Temple of the Lizardmen mods are all very sloppily constructed. You cannot expect a mod that spills an endless amount of warnings that were never dealt with to continue to run. By ignoring the warnings its maker took some undefined behavior for granted and once that undefined behavior got defined the mod started showing some issues.

The problem with the duplicate classes is that the engine never knows which one it should take, and in this case it greatly mattered which one was picked. When ZScript was added, the mechanism to deal with this was changed by necessity, and after that certain actors who were supposed to self-terminate did not anymore.
User avatar
Graf Zahl
Lead GZDoom Developer
 
Joined: 19 Jul 2003
Location: Germany


Return to Technical Issues

Who is online

Users browsing this forum: Edward-san and 1 guest