(Solved)Sound causes stutters in GZDoom

Need help running G/Q/ZDoom/ECWolf/Zandronum/3DGE? Did your computer break? Ask here.

Moderator: GZDoom Developers

(Solved)Sound causes stutters in GZDoom

Postby Bigcmj » Thu Jan 10, 2019 1:05 am

Edit: See the last post for solution.

Looking for some advice,

When im playing GZDoom with any gameplay changing mod(Project Brutality, Brutal Doom, Russian Overkill), I get half a second stutters when picking up a new weapon or firing it for the first time. I've tried messing with the display settings but no luck, but I found when playing with "-nosound" command, the stutter disappears. I tried updating my audio drivers but it didn't work.
Any suggestions would be appreciated.

My specs are an I7-6700HQ
GTX 1060
8GB RAM
Last edited by Bigcmj on Thu Jan 10, 2019 11:56 pm, edited 1 time in total.
Bigcmj
 
Joined: 09 Jan 2019

Re: Sound causes stutters in GZDoom

Postby Rachael » Thu Jan 10, 2019 1:22 am

What version of GZDoom are you using? It sounds like you have a bad copy of OpenAL.
User avatar
Rachael
Webmaster
 
Joined: 13 Jan 2004
Discord: Rachael#3767
Twitch ID: madamerachelle
Github ID: madame-rachelle

Re: Sound causes stutters in GZDoom

Postby Bigcmj » Thu Jan 10, 2019 2:04 am

Sorry, I never included that did I, im using the the most up to date version 3.7.1.
Bigcmj
 
Joined: 09 Jan 2019

Re: Sound causes stutters in GZDoom

Postby Chris » Thu Jan 10, 2019 8:37 pm

Are you using a mechanical/spinning HD, or an SSD? Do you have any anti-virus running in the background? The symptom of stuttering when first playing a sound (but be fine with subsequent plays) would tend to indicate it's slow to read the file from the drive.
User avatar
Chris
 
Joined: 17 Jul 2003

Re: Sound causes stutters in GZDoom

Postby Bigcmj » Thu Jan 10, 2019 11:55 pm

Hey, just wanted to give an update.
I tried reinstalling OpenAL, but that didn't make any difference, however after moving GZDoom and the mods I was using over to my SSD, The stuttering is gone! I kind of feel silly, having not thought of that.

Thank you both for your help!
Bigcmj
 
Joined: 09 Jan 2019


Return to Technical Issues

Who is online

Users browsing this forum: No registered users and 2 guests