Page 1 of 1

How to Disable Auto-Aim (Permanently)

PostPosted: Tue Sep 25, 2018 6:18 pm
by 7.62x39
Hi, i'm on Windows 10 17134.319. Playing Doom 2 (BFG Edition) on GZDoom 3.5.1 (GZDoom running in C:\Program Files(x86) folder...)

There're several Auto-Aim settings...

First one, smart autoaim which is off all the time but when i restart the game other two options is change to "yes" all the time. (Allow Autoaim & Allow BFG Aiming) :evil:

Is there any fix?

Note: I checked that again. When i lunch the game these settings are "yes" but when i load my save file it's change to "no" If i start a new game autoaim is enabled... :shock: Not sure this is a problem atm but i wish my settings is permanent... :idea:



BTW, i have automap issues too. When i toogle automap i stuck there.. I have to load a save or start a new game to fix that..

Re: How to Disable Auto-Aim (Permanently)

PostPosted: Tue Sep 25, 2018 10:25 pm
by Xaser
7.62x39 wrote:GZDoom running in C:\Program Files(x86) folder...

Try moving your GZDoom installation out of Program Files and see if it starts behaving. Windows is super-picky about allowing files to be modified in that folder, and it sounds like GZDoom is having trouble saving your settings.

There have been similar issues reported by folks in the past, so it's a start.

Re: How to Disable Auto-Aim (Permanently)

PostPosted: Tue Sep 25, 2018 10:43 pm
by phantombeta
Allow Autoaim and Allow BFG Aiming aren't user options, they're dmflags.
"Allow Autoaim" is meant for force-disabling autoaim for all players in MP games, while "Allow BFG Aiming" forces the BFG to ignore your pitch if it's on. Its only use is for people who think being able to shoot the BFG up and down in deathmatch is OP or cheap.
"Smart autoaim" just changes what the autoaim looks for when both are enabled.

If you want to simply disable autoaim for yourself, simply set the "Autoaim" slider to the lowest value in the "Player Options" menu.
And definitely do what Xaser said. Never put things in program files manually! Program Files is a special folder that needs specific permissions set for a program to be able to use it.

Re: How to Disable Auto-Aim (Permanently)

PostPosted: Tue Sep 25, 2018 11:38 pm
by Xaser
Welp, that's probably it -- missed the fact that OP is setting the deathmatch options.

It certainly doesn't help things that the dmflags are in a menu called "gameplay options" and the real autoaim setting is hidden in what's effectively a multiplayer options menu. Every day is Opposite Day. :P

Seems like another case for that menu revamp to hit the shelves.

Re: How to Disable Auto-Aim (Permanently)

PostPosted: Wed Sep 26, 2018 2:41 am
by 7.62x39
Thanks guys... I put the GZDoom folder to "D" and set the "Autoaim" slider to the lowest value in the "Player Options" menu but still have the same problem. Actually, no big deal. In my save file autoaim is off anyway. :D

Re: How to Disable Auto-Aim (Permanently)

PostPosted: Wed Sep 26, 2018 7:48 am
by Korell
7.62x39 wrote:Thanks guys... I put the GZDoom folder to "D" and set the "Autoaim" slider to the lowest value in the "Player Options" menu but still have the same problem. Actually, no big deal. In my save file autoaim is off anyway. :D


If the Player Options autoaim is at the lowest value (for no autoaim) then even if the Gameplay Options (DMFlags) do state that Allow Autoaim is Yes or Smart Autoaim is on, it will still be off because of the Player Options autoaim value. The Gameplay Options are just to allow autoaim to be used, and if it is allowed then it uses the value from the Player Options (which you've set to 0). So basically don't concern yourself with the Gameplay Options and just ensure your Player Options are set as you'd want.

Re: How to Disable Auto-Aim (Permanently)

PostPosted: Sun Jul 21, 2019 12:41 pm
by Ian Tillingworth
Hi, it's maybe a little off.
I play heretic on gzdoom/qzdoom, having the same problem: after turning all options regarding autoaim off/0, it still works, and it's annoying. Is this special with heretic? All other mods/megawads/wharever works just fine.