[GZDoom 3.2.1] libgomp.so.1: version `GOMP_4.0' not found

Need help running G/Q/ZDoom/ECWolf/Zandronum/3DGE? Did your computer break? Ask here.

[GZDoom 3.2.1] libgomp.so.1: version `GOMP_4.0' not found

Postby Betsy Clayforth » Thu Nov 09, 2017 1:33 pm

I'm getting this error at GZDoom 3.2.1 startup on Linux Mint 17.3:

/opt/gzdoom/gzdoom: /usr/lib/x86_64-linux-gnu/libgomp.so.1: version `GOMP_4.0' not found (required by /opt/gzdoom/gzdoom)

I guess there are some dependencies missing in the deb package and thus causing this problem on Ubuntu 14.04 based distros.
The libgomp version is 4.8.4-2ubuntu1~14.04.3
Betsy Clayforth
 

Re: [GZDoom 3.2.1] libgomp.so.1: version `GOMP_4.0' not foun

Postby Rachael » Thu Nov 09, 2017 1:50 pm

You might want to register an account and send a PM to Blzut3 for this, since he is the one who manages the debian packages.
User avatar
Rachael
QZDoom Project Lead + Webmaster
 
Joined: 13 Jan 2004

Re: [GZDoom 3.2.1] libgomp.so.1: version `GOMP_4.0' not foun

Postby _mental_ » Fri Nov 10, 2017 1:22 am

We have OpenMP as optional dependency. Apparently Blzut3 wasn’t aware of this.
Installing libgomp1 via package manager should fix the problem.
_mental_
 
 
 
Joined: 07 Aug 2011

Re: [GZDoom 3.2.1] libgomp.so.1: version `GOMP_4.0' not foun

Postby SMT_YHVH » Sun Nov 19, 2017 2:02 pm

I've been having the same issue as well. I already have libgomp1 installed, yet it won't start up.
SMT_YHVH
 
Joined: 19 Nov 2017

Re: [GZDoom 3.2.1] libgomp.so.1: version `GOMP_4.0' not foun

Postby _mental_ » Mon Nov 20, 2017 5:15 am

My bad, after reading error message once again I understood that the OpenML library is installed but it's version is too old.
Unfortunately I have no VM image with Linux version affected by this issue. So I cannot provide a verified workaround at the moment.
_mental_
 
 
 
Joined: 07 Aug 2011

Re: [GZDoom 3.2.1] libgomp.so.1: version `GOMP_4.0' not foun

Postby Rachael » Mon Nov 20, 2017 5:53 am

All I can suggest is contacting Blzut3 about this. He's the official package maintainer and also the one who actually signs those packages, making them official (at least inasfar as Ubuntu allows them to be official when using a custom repo).
User avatar
Rachael
QZDoom Project Lead + Webmaster
 
Joined: 13 Jan 2004

Re: [GZDoom 3.2.1] libgomp.so.1: version `GOMP_4.0' not foun

Postby e1337sheep » Fri Nov 24, 2017 11:43 am

NOTE: I thought I had originally posted this as a logged in user, but realised I'd forgotten to log in. Sorry for the duplicate post, I'd delete it if I could...

After reading too many StackOverflow answers, I came across the possible issue, and a solution that worked for me. GOMP 4.0 was included with GCC 4.9; it seems our version of Ubuntu/Mint uses GCC 4.8, which uses a previous version of GOMP, which is causing the error. So, we need to install GCC 4.9, and make sure the OS uses it.

This link has the steps I used to do that.
https://askubuntu.com/questions/466651/ ... -on-ubuntu

Super short version, open a terminal, and:
Code: Select allExpand view
sudo add-apt-repository ppa:ubuntu-toolchain-r/test
sudo apt-get update
sudo apt-get install gcc-4.9 g++-4.9
sudo update-alternatives --install /usr/bin/gcc gcc /usr/bin/gcc-4.9 60 --slave /usr/bin/g++ g++ /usr/bin/g++-4.9


Just in case you need 4.8 for anything:
Code: Select allExpand view
sudo apt-get install gcc-4.8 g++-4.8
sudo update-alternatives --install /usr/bin/gcc gcc /usr/bin/gcc-4.8 60 --slave /usr/bin/g++ g++ /usr/bin/g++-4.8


And use:
Code: Select allExpand view
sudo update-alternatives --config gcc

to check version and switch between them.

Of course, this is an "at your own risk" situation, but I hope it helps :)
e1337sheep
 
Joined: 24 Nov 2017

Re: [GZDoom 3.2.1] libgomp.so.1: version `GOMP_4.0' not foun

Postby Hedda Sopperstin » Sat Jan 13, 2018 2:52 am

Hello, I solved the problem by removing GZDoom and from https://zdoom.org/files/gzdoom/bin/ I downloaded the 3.1.0 release and installed it. To prevent GZDoom to be updated, I removed the http://debian.drdteam.org/ package repository.
Hedda Sopperstin
 

Re: [GZDoom 3.2.1] libgomp.so.1: version `GOMP_4.0' not foun

Postby Rachael » Sat Jan 13, 2018 10:26 am

What you are doing is unsupported and discouraged.

I am not going to say you can't do it - because you are free to do so - but we are not going to accept bug reports for an old release, we are not going to help you get an old release working if it breaks, and the old release has two major security flaws that have recently been patched.

You are completely on your own.
User avatar
Rachael
QZDoom Project Lead + Webmaster
 
Joined: 13 Jan 2004


Return to Technical Issues

Who is online

Users browsing this forum: No registered users and 1 guest