[Not GZDoom] ZDoom Very Fatal Error - Version 3.1 - HELP!!!

Need help running G/Q/ZDoom/ECWolf/Zandronum/3DGE? Did your computer break? Ask here.

Moderator: Developers

ZDoom Very Fatal Error - Version 3.1 - HELP!!!

Postby MetallistevE » Sun Sep 17, 2017 7:26 am

Please help. I cannot play Brutal Doom on either Ultimate Doom or Doom II (both purchased through Steam) using the most up-to-date version of GZDoom 3.1 and brutalv20b_R. Keep coming up with this error.

Attempt to get invalid state See from actor ImpTorso.
Attempt to get invalid state See from actor DeadImp.
Bad hex number: no
Attempt to get invalid state Crouch from actor Nazi.
Script warning, "brutalv20b_R.pk3:impshield.txt" line 111:
Unknown class name 'DeadImp1' of type 'Actor'

game crashes immediately on Ultimate Doom as soon as I start a game. Crashes on Doom II when I fire a weapon (or attack in general).
Attachments
CrashReport - Doom II.zip
Doom II crash report
(20.67 KiB) Downloaded 11 times
CrashReport2.zip
Ultimate Doom crash Report
(21.26 KiB) Downloaded 9 times
MetallistevE
 
Joined: 17 Sep 2017

Re: ZDoom Very Fatal Error - Version 3.1 - HELP!!!

Postby Korell » Sun Sep 17, 2017 11:39 am

Looks like this is due to the mod itself rather than GZDoom. The ModDB page (I think this is the same version as the Brutal Doom mod you are using) - http://www.moddb.com/mods/brutal-doom/d ... om-300-ver - has a comment from a user named Reactorcore dated May 27th 2017 with the same errors you are getting.

I think you'll either need to find a different fixed Brutal Doom mod, or to use an earlier version of GZDoom that didn't pick up on some of the errors in the Brutal Doom code.

For example, here's an addon to the official Brutal Doom 20b mod that applies a number of fixes: http://www.moddb.com/mods/brutal-doom/a ... cial-patch
User avatar
Korell
 
Joined: 28 May 2017

Re: ZDoom Very Fatal Error - Version 3.1 - HELP!!!

Postby _mental_ » Mon Sep 18, 2017 3:04 am

It crashes within Intel graphics driver. If you have up-to-date drivers, everything you can do is to start GZDoom with -glversion 2 command line options. This will disable some rendering features but at least it should prevent those crashes.
_mental_
 
 
 
Joined: 07 Aug 2011

Re: ZDoom Very Fatal Error - Version 3.1 - HELP!!!

Postby MetallistevE » Mon Sep 18, 2017 9:29 am

Thanks a lot for all your help. I tried to get up-to-date drivers but was unable to connect for some odd reason. I'll try the add-ons and let you know how I get on.
MetallistevE
 
Joined: 17 Sep 2017

Re: ZDoom Very Fatal Error - Version 3.1 - HELP!!!

Postby MetallistevE » Mon Sep 18, 2017 12:26 pm

Oh no. That patch was even worse. Game wouldn't load at all.
MetallistevE
 
Joined: 17 Sep 2017

Re: ZDoom Very Fatal Error - Version 3.1 - HELP!!!

Postby Xavier Bazzleforth » Mon Sep 18, 2017 12:52 pm

Am I correct in assuming that this patch, the way to install it is to replace the text in the .ini file to read Path=brutalv20c_UP.pk3???? If that is the case, it really doesn't work for both ultimate doom and doom II.
Xavier Bazzleforth
 

Re: ZDoom Very Fatal Error - Version 3.1 - HELP!!!

Postby drfrag » Mon Sep 18, 2017 1:26 pm

Well, it's a patch. You need to load brutalv20c_UP.pk3 after brutalv20b.pk3, use ZDoom Launcher (ZDL).
User avatar
drfrag
ZDoom32 and ZDoom LE developer.
 
Joined: 23 Apr 2004
Location: Spain


Return to Technical Issues

Who is online

Users browsing this forum: No registered users and 1 guest