Weird OpenGL Issue

Need help running G/Q/ZDoom/ECWolf/Zandronum/3DGE? Did your computer break? Ask here.

Moderator: GZDoom Developers

Weird OpenGL Issue

Postby YukiHerz » Fri Mar 10, 2017 1:14 pm

For some reason today I can't use anything that makes use of OpenGL for rendering, Quake 4, Doom 3, GZDoom and PPSSPP all give me an error about Failing to Create an OpenGL Rendering Context, until yesterday all these things ran fine.

It's not really an issue as most things I do have a dx9 alternative, but it is very annoying and strange considering how spontaneous it is.
User avatar
YukiHerz
Expensive pasta dude
 
Joined: 02 Dec 2013
Location: Where corruption is redefined daily.
Operating System: Windows 10/8.1/8 64-bit
Graphics Processor: Intel (Legacy GZDoom)

Re: Weird OpenGL Issue

Postby Rachael » Fri Mar 10, 2017 1:15 pm

First off, wouldn't this be more appropriate in the tech issues forum? (I can move it there if you like)

Secondly, what are your hardware specs?

Thirdly, between the last time it worked and now, were there any updates or additional programs installed?
User avatar
Rachael
Webmaster
 
Joined: 13 Jan 2004
Discord: Rachael#3767
Twitch ID: madamerachelle
Github ID: madame-rachelle

Re: Weird OpenGL Issue

Postby YukiHerz » Fri Mar 10, 2017 1:37 pm

EDIT: It works again, somehow.
The screen went black while I wasn't using the computer, then it came back and I decided to check with PPSSPP again, it ran normally.
--Original Post--
1.-My bad, Please and Thanks.

2.-It's a really old laptop, the CPU is an Intel Celeron B815 1.6Ghz with an integrated graphics card (shown simply as Intel HD Graphics in DxDiag).
Image
Image

3.-There wasn't any change between last night and today.

Please do note, that due it being legacy hardware, I can't update the drivers any further because Intel says so.
User avatar
YukiHerz
Expensive pasta dude
 
Joined: 02 Dec 2013
Location: Where corruption is redefined daily.
Operating System: Windows 10/8.1/8 64-bit
Graphics Processor: Intel (Legacy GZDoom)

Re: Weird OpenGL Issue

Postby Rachael » Fri Mar 10, 2017 4:19 pm

That's weird. Maybe the driver just crashed and it's back to normal again.
User avatar
Rachael
Webmaster
 
Joined: 13 Jan 2004
Discord: Rachael#3767
Twitch ID: madamerachelle
Github ID: madame-rachelle

Re: Weird OpenGL Issue

Postby YukiHerz » Fri Mar 10, 2017 4:29 pm

Most likely, thanks for your time, regardless.
User avatar
YukiHerz
Expensive pasta dude
 
Joined: 02 Dec 2013
Location: Where corruption is redefined daily.
Operating System: Windows 10/8.1/8 64-bit
Graphics Processor: Intel (Legacy GZDoom)


Return to Technical Issues

Who is online

Users browsing this forum: No registered users and 1 guest