"R_OPENGL: OpenGL driver not accelerated!"

Need help running G/Q/ZDoom/ECWolf/Zandronum/3DGE? Did your computer break? Ask here.

Moderator: Developers

"R_OPENGL: OpenGL driver not accelerated!"

Postby Tartlman » Thu Oct 11, 2018 6:29 am

I'm getting this error whenever I try to launch GZDoom. GZDoom has been working perfectly fine until today, where it just straight up decided to stop working. I am running windows 10, and no, i did not get an update for it or anything. The old "use wtfi" fix is no longer working, since you get a whole other error if you do that. I am not the admin on this computer, so do you guys know any way to fix GZDoom without inputting admin passwords anywhere?
User avatar
Tartlman
 
Joined: 11 Oct 2018
Discord: Tartlman#2947

Re: "R_OPENGL: OpenGL driver not accelerated!"

Postby Darkcrafter » Fri Oct 12, 2018 2:54 pm

Somehow there is an issue with your graphics card drivers. What's your card and driver version (year and month of release)?
Darkcrafter
 
Joined: 23 Sep 2017
Location: Russia

Re: "R_OPENGL: OpenGL driver not accelerated!"

Postby Tartlman » Sat Oct 13, 2018 3:40 pm

My driver looks like it is pretty old: https://www.intel.com/content/www/us/en ... -2000.html
That's probably the main problem. My graphics card is an nvidia geforce gt 525m, but that's probably not the problem as my computer isn't showing any problems that match gpu failures. Guess i'll have to wait for a wtfi-like fix for newer versions of GZDoom.

oh yeah, just saying: using wtfi-fixed versions of gzdoom works fine.
User avatar
Tartlman
 
Joined: 11 Oct 2018
Discord: Tartlman#2947

Re: "R_OPENGL: OpenGL driver not accelerated!"

Postby Rachael » Sat Oct 13, 2018 7:10 pm

I'm thinking about changing that error to provide some more helpful diagnostic information about why GZDoom doesn't start, including some vital OpenGL strings if possible.
User avatar
Rachael
QZDoom + Webmaster
 
Joined: 13 Jan 2004

Re: "R_OPENGL: OpenGL driver not accelerated!"

Postby Graf Zahl » Sun Oct 14, 2018 12:47 am

Tartlman wrote:My driver looks like it is pretty old: https://www.intel.com/content/www/us/en ... -2000.html
That's probably the main problem. My graphics card is an nvidia geforce gt 525m, but that's probably not the problem as my computer isn't showing any problems that match gpu failures. Guess i'll have to wait for a wtfi-like fix for newer versions of GZDoom.

oh yeah, just saying: using wtfi-fixed versions of gzdoom works fine.



Why are you using an Intel driver for your integrated chipset and not one for the Geforce? That means that this card remains completely unused.
User avatar
Graf Zahl
Lead GZDoom Developer
 
Joined: 19 Jul 2003
Location: Germany

Re: "R_OPENGL: OpenGL driver not accelerated!"

Postby James Semblewell » Sun Oct 14, 2018 10:38 am

Graf Zahl wrote:
> [quote="Tartlman"]My driver looks like it is pretty old: https://www.intel.com/content/www/us/en ... -2000.html
> That's probably the main problem. My graphics card is an nvidia geforce gt 525m,
> but that's probably not the problem as my computer isn't showing any problems that
> match gpu failures. Guess i'll have to wait for a wtfi-like fix for newer versions
> of GZDoom.
>
> oh yeah, just saying: using wtfi-fixed versions of gzdoom works fine.[/quote]
>
>
> Why are you using an Intel driver for your integrated chipset and not one for the
> Geforce? That means that this card remains completely unused.

It's a handed down prebuilt pc, i can't control anything about the hardware.
James Semblewell
 

Re: "R_OPENGL: OpenGL driver not accelerated!"

Postby Rachael » Sun Oct 14, 2018 1:24 pm

It's not the hardware he's talking about, he's talking about the fact that you're under-utilizing it by not having drivers for your nvidia.
User avatar
Rachael
QZDoom + Webmaster
 
Joined: 13 Jan 2004


Return to Technical Issues

Who is online

Users browsing this forum: No registered users and 2 guests