"Waiting for: X" when loading saved games

Talk about multiplayer ZDoom games here.
Forum rules
Image

"Waiting for: X" when loading saved games

Postby Nash » Mon Aug 21, 2017 3:27 am

Sometimes when I try to load a saved coop game, it shows "Waiting for: X" where is X is either 1 or 2, for a 2-player session. It seems to be inconsistent to reproduce... sometimes it happens, sometimes it doesn't. Usually if I see this message, just having both players quit the session and try connecting again will produce a chance for the message to appear or not. What does the message really mean?

Also, this is based on testing netgame on the same machine (2 instances of GZDoom launched, one with -host 2 and the other with -join localhost).

I'd like to know what the message really means and if it's an error in my mod that can be fixed by me.

[EDIT] I notice it has a higher chance of happening if I launch the 2 instances of the game too fast. If I launch the host first, wait about 2 seconds in real life, then launch the joiner, the message has a much reduced chance of happening (but can still happen).
User avatar
Nash
 
 
 
Joined: 27 Oct 2003
Location: Kuala Lumpur, Malaysia
Github ID: nashmuhandes
Operating System: Windows 10/8.1/8 64-bit
Graphics Processor: nVidia GTX or Quadro with Vulkan support

Re: "Waiting for: X" when loading saved games

Postby Marisa Kirisame » Wed Feb 14, 2018 9:14 am

Sounds like some sort of race condition happening there.
User avatar
Marisa Kirisame
ZScript Magician
 
 
 
Joined: 08 Feb 2008
Location: Vigo, Galicia
Discord: Marisa Kirisame#4689
Twitch ID: magusmarisa
Github ID: OrdinaryMagician
Operating System: Other Linux 64-bit
Graphics Processor: nVidia GTX or Quadro with Vulkan support


Return to Networking

Who is online

Users browsing this forum: No registered users and 1 guest