Help with setting defaults for new mouse code

Here, developers communicate stuff that does not go onto the main News section or the front page of the site.
[Dev Blog] [Development Builds] [Git Change Log] [GZDoom Github Repo]

Moderator: GZDoom Developers

Re: Help with setting defaults for new mouse code

Postby Nash » Mon Oct 12, 2020 4:59 am

Ok, so I tried this with a fresh INI and now I feel like the fresh INI defaults feels very off: horizontal sensitivity is too low.

From here on, replicating the settings that the migration code did for me, makes it feel right again.

So in conclusion, the default (fresh INI) of 1.0 for both X and Y sensitivity doesn't feel right to me, but the ones that the migration code calculated feels right (X = 4.0, Y = 1.0 in my case).

As I said in my previous post, ever since playing every version of ZDoom and GZDoom since 2002, I have never had to alter the mouse sensitivity settings. It's stayed at 1.0 the whole time and felt completely natural and playable to me. And I've changed mice many times. My point is, I think whatever the migration code calculated for me (X being 4) is as close as it gets to "pre-mouse-cleanup refactor".
User avatar
Nash
 
 
 
Joined: 27 Oct 2003
Location: Kuala Lumpur, Malaysia
Github ID: nashmuhandes

Re: Help with setting defaults for new mouse code

Postby Graf Zahl » Mon Oct 12, 2020 5:07 am

I had something very weird happen a few days ago. All of a sudden the horizontal sensitivity of my mouse changed to half of what it was. I had to bump it up in Windows and in all games I occasionally play to feel right again.
This sure is not something where consistency exists...
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
 
Joined: 19 Jul 2003
Location: Germany

Previous

Return to Developer Blog

Who is online

Users browsing this forum: No registered users and 0 guests