"Execution could not continue" - Your ZDoom may be too old!

We sure do have a lot of rules and guidelines threads - find them all here, and please make sure you've read them! Also, community-wide announcements (that aren't major ZDoom News) go here as well.

Re: "Execution could not continue" - Your ZDoom may be too o

Postby Graf Zahl » Mon Mar 12, 2018 2:14 pm

These days the only valid reasons to use devbuilds are:

1. You want to test your mod with upcoming code changes.
2. Your mod depends on some bugfix / new feature that hasn't been released yet (but then you shouldn't release your mod before the required features become official.)
3. You want to act as a beta tester to give feedback to the developers

Under no circumstances should devbuilds be used for a mod release! There is absolutely no guarantee that any devbuild feature may survive unaltered until the next release. Unless some code ends up in an official release it may be removed or altered without notice. It's really too bad that ZDoom's extremely spotty release schedule basically forced people to ignore any common sense regarding beta-quality code.

Regarding current GZDoom, the last official release is roughly 2 months old by now, and the next one is very close to being published. 2017 has seen 10 new releases of GZDoom so there should really be no need to resort to devbuilds anymore.
User avatar
Graf Zahl
Lead GZDoom Developer
 
Joined: 19 Jul 2003
Location: Germany

Re: "Execution could not continue" - Your ZDoom may be too o

Postby wildweasel » Mon Mar 12, 2018 2:16 pm

The intent of the OP is still true, however: if you're getting "Execution could not continue" messages, you should make sure you're not running an old version of (G)ZDoom.
User avatar
wildweasel
May or may not have a pumpernickel addiction
Moderator Team Lead
 
Joined: 15 Jul 2003
Location: avatar by kurashiki

Re: "Execution could not continue" - Your ZDoom may be too o

Postby NeuralStunner » Mon Mar 12, 2018 9:56 pm

... Yeah, the last time I updated it was after the switch from SVN to git, and the ensuing rename of the DRD builds page. I'd pretty much forgotten about it since then. (Largely because it didn't appear to help much even when that information was still valid.)

I'll see if I can whip up something more up-to-date (and concise). I'd say this thread should be retired, but I think folks could use the reminder.
User avatar
NeuralStunner
Worldcrafter
 
 
 
Joined: 21 Jul 2009
Location: A Dynamic Link Library

Re: "Execution could not continue" - Your ZDoom may be too o

Postby NeuralStunner » Sun Jun 17, 2018 12:09 pm

Okay, having this hard-linked from the top of the forum has finally kicked my terrible memory into updating it. :P

Now more concise and up-to-date. Now with in-line links! [citation needed]
User avatar
NeuralStunner
Worldcrafter
 
 
 
Joined: 21 Jul 2009
Location: A Dynamic Link Library

Previous

Return to Rules and Forum Announcements

Who is online

Users browsing this forum: No registered users and 0 guests