[Engine] GLOOME / [WIP] Project 67 & Nocturne in Yellow

Projects that have specifically been abandoned or considered "dead" get moved here, so people will quit bumping them. If your project has wound up here and it should not be, contact a moderator to have it moved back to the land of the living.

Re: [Engine] GLOOME / [WIP] Project 67 & Nocturne in Yellow

Postby Gez » Sun Jan 24, 2016 5:26 pm

If you can't run Gloome, you're out of luck, either you can't use OpenGL at all or you'd have to go back to something like ZDoomGL...
Gez
 
 
 
Joined: 06 Jul 2007

Re: [Engine] GLOOME / [WIP] Project 67 & Nocturne in Yellow

Postby Legend » Thu Jan 28, 2016 12:56 am

I figured as much. I was just curious. I got the "not a valid win32 application" error when trying to play. I know the newest gzdoom is on opengl 3.something and I'm still on 1.5 I believe.

I'm still stuck on gzdoom 1.8.6 and winxp. Oh well. One day.

*edit:
I redownloaded this to give it a try and it Turns out that the game is actually semi playable by loading the pk3 files into gzdoom 1.8.6. Though it will not run engine.pk3 without errors. It runs without it but missing some graphics. Haven't tried playing enought yet to see what else is wonky.
User avatar
Legend
I Am Hellbound
 
Joined: 11 Jun 2010
Location: Antioch, CA

Re: [Engine] GLOOME / [WIP] Project 67 & Nocturne in Yellow

Postby XCVG » Thu Jan 28, 2016 11:00 am

XP might be the problem. The executable may have been built without support for XP, or it may be a 64-bit binary. Which one are you using, exactly?
User avatar
XCVG
 
Joined: 09 Aug 2013

Re: [Engine] GLOOME / [WIP] Project 67 & Nocturne in Yellow

Postby Marrub » Thu Jan 28, 2016 7:26 pm

The build system I use does not support Windows XP, yes. I did build with x86 in mind, but I am unsure if it actually runs on x86 windows installations.
User avatar
Marrub
Xevv Va Rkvyr
 
 
 
Joined: 26 Feb 2013
Discord: Marrub#5455
Twitch ID: marrubdaskuleion
Github ID: marrub--
Operating System: Other Linux 64-bit
Graphics Processor: ATI/AMD with Vulkan Support

Re: [Engine] GLOOME / [WIP] Project 67 & Nocturne in Yellow

Postby Legend » Thu Jan 28, 2016 7:52 pm

Yeah. I'm on a winxp 32 bit system. So won't run natively for me. Even if it did, I have a feeling it still wouldn't run since I don't have opengl 3 which I'm pretty sure gzdoom 1.8.10 uses which I believe gloome is based on.
User avatar
Legend
I Am Hellbound
 
Joined: 11 Jun 2010
Location: Antioch, CA

Re: [Engine] GLOOME / [WIP] Project 67 & Nocturne in Yellow

Postby Marrub » Thu Jan 28, 2016 8:45 pm

GZDoom 1.8.10 (which GLOOME is indeed based on) uses OpenGL 2.x. GZDoom 2.1 uses OpenGL 3.x.
User avatar
Marrub
Xevv Va Rkvyr
 
 
 
Joined: 26 Feb 2013
Discord: Marrub#5455
Twitch ID: marrubdaskuleion
Github ID: marrub--
Operating System: Other Linux 64-bit
Graphics Processor: ATI/AMD with Vulkan Support

Re: [Engine] GLOOME / [WIP] Project 67 & Nocturne in Yellow

Postby Legend » Fri Jan 29, 2016 1:57 am

yeah. on an old laptop with mobile intel 945gm express chipset. I believe it only supports as high as opengl 1.4. Oh well. Was just curious if I could get it working somehow.
User avatar
Legend
I Am Hellbound
 
Joined: 11 Jun 2010
Location: Antioch, CA

Re: [Engine] GLOOME / [WIP] Project 67 & Nocturne in Yellow

Postby UsernameAK » Fri Jan 29, 2016 4:54 am

add normal maps: textures named texname_N will be normal maps, textures named texname_D will be textures
User avatar
UsernameAK
Cat
 
Joined: 15 Jul 2015
Location: Ukraine
Discord: /bin/cat#8891

Re: [Engine] GLOOME / [WIP] Project 67 & Nocturne in Yellow

Postby NeuralStunner » Fri Jan 29, 2016 5:54 pm

UsernameAK wrote:add normal maps: textures named texname_N will be normal maps, textures named texname_D will be textures
Is this a suggestion? It sounds like a demand. :?

Also: Implicit filename-based features are a terrible idea. You'd be better off with a definition format to link your diffuse/normal/whatever-in-the-future maps.
User avatar
NeuralStunner
not actually a catgirl
 
 
 
Joined: 21 Jul 2009
Location: =o_O=
Discord: NeuralStunner#4201
Operating System: Windows Vista/7/2008 64-bit
Graphics Processor: nVidia (Modern GZDoom)

Re: [Engine] GLOOME / [WIP] Project 67 & Nocturne in Yellow

Postby XCVG » Fri Jan 29, 2016 6:09 pm

NeuralStunner wrote:
UsernameAK wrote:add normal maps: textures named texname_N will be normal maps, textures named texname_D will be textures
Is this a suggestion? It sounds like a demand. :?

Also: Implicit filename-based features are a terrible idea. You'd be better off with a definition format to link your diffuse/normal/whatever-in-the-future maps.


An extension to TEXTURES or GLDEFS, perhaps?
User avatar
XCVG
 
Joined: 09 Aug 2013

Re: [Engine] GLOOME / [WIP] Project 67 & Nocturne in Yellow

Postby bchan009 » Tue Feb 02, 2016 4:15 am

I just wanted to thank you for making this. I'm an animator/artist and a very light coder who has been trying to make a 2.5d game for a long time.

GameMaker works great but is too weak to do proper 3d without a lot of hacky workarounds, and Unity is too powerful and robust to do something so simple. Not to mention ZDoom already has a lot of the things I want to do built-in so I don't have to go about recreating the wheel.

Took an afternoon yesterday to learn Doombuilder and I'm already well on my way to making what I wanted to.

Thanks again!
User avatar
bchan009
 
Joined: 02 Feb 2016

Re: [Engine] GLOOME / [WIP] Project 67 & Nocturne in Yellow

Postby Alekv » Sat Feb 06, 2016 2:14 am

Tell me please about when a new version beta build GLOOME?
The latest version of August 29 , it was a long time or GLOOME since then has not improved at all?
User avatar
Alekv
 
Joined: 08 Jun 2015
Location: My world :)

Re: [Engine] GLOOME / [WIP] Project 67 & Nocturne in Yellow

Postby Ultimate Freedoomer » Tue Feb 23, 2016 6:31 pm

Would it be possible to do the following:
  • Replace Zdoom's default Heretic/Hexen compatibility code with Activision/Raven's official GPL Heretic/Hexen Code releases: https://sourceforge.net/projects/heretic/files/
  • Add vanilla IWAD demo compatibility
  • See if you can send the "replacement" portions of the code to the Zandronum development team once they are done.
I'm not asking you to do these things right this second, they are just suggestions for IF you ever update GLOOME to use GZDoom 2.1 as the base.
Ultimate Freedoomer
 
Joined: 30 Jan 2015
Location: Pittman Center
Discord: Open Source Forever#0483
Twitch ID: https://www.twitch.tv/lyokianh

Re: [Engine] GLOOME / [WIP] Project 67 & Nocturne in Yellow

Postby Gez » Tue Feb 23, 2016 6:44 pm

  • A lot of painstaking work, because you'd have to update that code anyway to make it work within ZDoom, but it should be possible. However, it also seems very pointless, what would you gain from doing that?
  • That seems nearly impossible. It'd need a lot of special casing and alternate branching in all core gameplay functions, often falling back to crippled/bugged functions while in demo mode.
  • It's free software, if the Zand developers want to take stuff from GLOOME, they can do it without being spoonfed.
Gez
 
 
 
Joined: 06 Jul 2007

Re: [Engine] GLOOME / [WIP] Project 67 & Nocturne in Yellow

Postby XCVG » Tue Feb 23, 2016 6:58 pm

Ultimate Freedoomer wrote:Would it be possible to do the following:
  • Replace Zdoom's default Heretic/Hexen compatibility code with Activision/Raven's official GPL Heretic/Hexen Code releases: https://sourceforge.net/projects/heretic/files/
  • Add vanilla IWAD demo compatibility
  • See if you can send the "replacement" portions of the code to the Zandronum development team once they are done.
I'm not asking you to do these things right this second, they are just suggestions for IF you ever update GLOOME to use GZDoom 2.1 as the base.


None of these really seem in line with the intent of GLOOME. GZDoom-gpl might be a better target.
User avatar
XCVG
 
Joined: 09 Aug 2013

PreviousNext

Return to Abandoned/Dead Projects

Who is online

Users browsing this forum: No registered users and 1 guest