Pirate Doom! - House of Mojo 06/05/14

Projects that have specifically been abandoned or considered "dead" get moved here, so people will quit bumping them. If your project has wound up here and it should not be, contact a moderator to have it moved back to the land of the living.

Re: Pirate Doom! - House of Mojo 06/05/14

Postby wildweasel » Thu Jun 04, 2015 10:26 am

Are you guys all running the most up-to-date drivers for your respective video hardware? For that matter, what hardware is everybody running?
User avatar
wildweasel
I love the smell of sourdough in the morning
 
Joined: 15 Jul 2003
Location: avatar by kurashiki

Re: Pirate Doom! - House of Mojo 06/05/14

Postby MetroidJunkie » Thu Jun 04, 2015 11:30 am

Works fine for me, GPU is AMD 5670 512MB. Lags like crazy on the Android GZDoom but that's probably to be expected since it's GZDoom running on a mobile system.
User avatar
MetroidJunkie
 
Joined: 19 Aug 2011

Re: Pirate Doom! - House of Mojo 06/05/14

Postby Batandy » Fri Jun 05, 2015 3:51 am

wildweasel wrote:Are you guys all running the most up-to-date drivers for your respective video hardware? For that matter, what hardware is everybody running?

I do have the latest drivers
Spoiler:

this is the golden souls issue that could be related to pirate doom's
I'll have to check later if i did something weird with 3d floors, but i'm pretty sure that when i first released the map it didn't have this bug at all until a certain gzdoom version
User avatar
Batandy
Have you tried blowing into the cartridge?
 
Joined: 19 Jul 2011

Re: Pirate Doom! - House of Mojo 06/05/14

Postby -doomdude- » Thu Jan 07, 2016 12:09 pm

Pirate knight concept art.
Attachments
pirate doom boss.jpg
-doomdude-
 
Joined: 22 Apr 2015

Re: Pirate Doom! - House of Mojo 06/05/14

Postby Arch » Thu Feb 18, 2016 11:11 am

Awesome, I like them all, my favorite is the third one. Only the resolution is a bit high. If you make all rotations and animations for one of these, I might make pirate doom 2 just for that hah
User avatar
Arch
Arrr!
 
Joined: 10 Nov 2011

Re: Pirate Doom! - House of Mojo 06/05/14

Postby Gideon020 » Tue Aug 02, 2016 11:15 pm

Apologies for the necro, but I've been having trouble with my copy that I downloaded off /idgames. It keeps coming up with [Script error, "Pirates!.wad:DECORATE" line 4672:
class 'dashsound' is not compatible with 'Inventory']

I'm using the latest GZDoom dev build. Anyone know where I can go to fix this error?
Gideon020
Fanboy
 
Joined: 28 Sep 2015

Re: Pirate Doom! - House of Mojo 06/05/14

Postby JimpArgon » Tue Aug 02, 2016 11:18 pm

Gideon020 wrote:Apologies for the necro, but I've been having trouble with my copy that I downloaded off /idgames. It keeps coming up with [Script error, "Pirates!.wad:DECORATE" line 4672:
class 'dashsound' is not compatible with 'Inventory']

I'm using the latest GZDoom dev build. Anyone know where I can go to fix this error?


Im assuming that you are getting these errors trying to launch it? Have you tried using regular GZdoom? You know.... Not the developer version? I know I just did, and I didn't have any issues.
User avatar
JimpArgon
:) (:
Banned User
 
Joined: 04 Jul 2016
Location: Florida

Re: Pirate Doom! - House of Mojo 06/05/14

Postby Gideon020 » Tue Aug 02, 2016 11:20 pm

Sure, I'll give that a try. Thanks.
Gideon020
Fanboy
 
Joined: 28 Sep 2015

Re: Pirate Doom! - House of Mojo 06/05/14

Postby Ed the Bat » Wed Aug 03, 2016 12:44 am

As a hotfix, you can simply delete line 4672:
Code: Select allExpand view
SWOR A 0 A_TakeInventory("dashsound",1)
...from the DECORATE lump, and it should run.
User avatar
Ed the Bat
I'm tired. I want to go home.
 
Joined: 03 May 2012
Location: Maryland, US

Re: Pirate Doom! - House of Mojo 06/05/14

Postby SiFi270 » Wed Aug 03, 2016 3:15 am

Is this to do with how in current (not dev build) versions of GZDoom, certain sounds in this like picking up an armor bonus/ammo and firing the gatling gun are completely silent? Because I was meaning to ask about that for a while but wasn't so sure about bumping this just for that.
User avatar
SiFi270
 
Joined: 10 Feb 2015
Location: Does anyone put a serious answer here?

Re: Pirate Doom! - House of Mojo 06/05/14

Postby Ed the Bat » Wed Aug 03, 2016 3:17 am

This issue is because dev builds now disallow performing inventory-based functions (such as A_TakeInventory) on actors that are not a child class of Inventory. Previously, this didn't create errors, which is why the official build will still run Pirate Doom.
User avatar
Ed the Bat
I'm tired. I want to go home.
 
Joined: 03 May 2012
Location: Maryland, US

Re: Pirate Doom! - House of Mojo 06/05/14

Postby the95mexican » Mon Aug 08, 2016 10:26 pm

damn son!!! this mod need a new skin change you like this??
Attachments
piratas.png
User avatar
the95mexican
 
Joined: 02 Sep 2015
Location: mexico

Re: Pirate Doom! - House of Mojo 06/05/14

Postby NightFright » Mon Nov 14, 2016 6:53 am

Here is a slightly updated version of Pirate Doom which works again with recent GZDoom builds:

Pirate Doom with DECORATE update (PK7, 23 MB)

Changes:
[DECORATE] Commented out A_TakeInventory line to avoid startup error
[DECORATE] Renamed actor map to map1 to avoid conflict/warning
User avatar
NightFright
 
Joined: 02 May 2008
Location: Germany

Re: Pirate Doom! - House of Mojo 06/05/14

Postby SiFi270 » Mon Nov 14, 2016 1:10 pm

SiFi270 wrote:Is this to do with how in current (not dev build) versions of GZDoom, certain sounds in this like picking up an armor bonus/ammo and firing the gatling gun are completely silent? Because I was meaning to ask about that for a while but wasn't so sure about bumping this just for that.

I'm afraid I'm still having this problem.
User avatar
SiFi270
 
Joined: 10 Feb 2015
Location: Does anyone put a serious answer here?

Previous

Return to Abandoned/Dead Projects

Who is online

Users browsing this forum: No registered users and 2 guests