Page 245 of 247

Re: ÆoD (6.06.02 (03-14-16))

PostPosted: Sat Jan 07, 2017 8:13 am
by Somagu
Major Cooke wrote:Yeah, like that other mod that claimed AEoD would become a thing of the past. What was it called again? :P

Not only did that guy up and disappear, he also deleted his youtube channel. I know it wasn't Doomguy's Warzone, it was something else... I guess you could say, that mod became a thing of the past while AEoD is still very much relevant today.

Classic Rivalry, maybe?

Re: ÆoD (6.06.02 (03-14-16))

PostPosted: Sat Jan 07, 2017 9:39 am
by Captain J
I think it is, definitely. Man, that was hell of a drama about originality.

Re: ÆoD (6.06.02 (03-14-16))

PostPosted: Sun Jan 08, 2017 9:49 pm
by Ethril
I don't remember any claims about AEoD becoming a thing of the past, but the first thing that came to mind was Hardcore Doom Wars (COOL DOOM!), which was basically what randomizer mods probably look like to people who don't like randomizer mods.

Re: ÆoD (6.06.02 (03-14-16))

PostPosted: Mon Jan 09, 2017 8:54 am
by Major Cooke
Yeah, Classic Rivalry, that was it.

Good times! :P

Anyway, I've been thinking if I want to post the yet-to-be-finished beta here as a separate download link or not. I should warn you all, it's still very much beta-ish. Things may or may not work (for the most part they should) and I have a list of known issues prepared.

What I want to know is, would you all be willing to put up with it in exchange for being able to run GZDoom 2.3.x? I mean, you do get some new guns~! So that's a bonus.

Re: ÆoD (6.06.02 (03-14-16))

PostPosted: Mon Jan 09, 2017 3:38 pm
by Major Cooke
To make this easiest as possible for the sorting: Gameplay Mods.

Re: ÆoD (6.06.02 (03-14-16))

PostPosted: Wed Jan 11, 2017 1:14 pm
by fluffy
Major Cooke wrote:Yeah, Classic Rivalry, that was it.

Good times! :P

Anyway, I've been thinking if I want to post the yet-to-be-finished beta here as a separate download link or not. I should warn you all, it's still very much beta-ish. Things may or may not work (for the most part they should) and I have a list of known issues prepared.

What I want to know is, would you all be willing to put up with it in exchange for being able to run GZDoom 2.3.x? I mean, you do get some new guns~! So that's a bonus.


I would like to try out the new build of this mod, since i really enjoy it. Actually it might be better to release it so people can post bugs and prepare for the final build.

Re: ÆoD (6.06.02 (03-14-16))

PostPosted: Wed Jan 11, 2017 3:12 pm
by Major Cooke
I cannot condone it as a 'release'. It'll be simply 'beta' material since there is always the risk of something happening. As in, 'use at your own risk' like we've done for quite a long time.

Re: ÆoD (6.06.02 (03-14-16))

PostPosted: Thu Jan 12, 2017 3:32 am
by fluffy
Major Cooke wrote:I cannot condone it as a 'release'. It'll be simply 'beta' material since there is always the risk of something happening. As in, 'use at your own risk' like we've done for quite a long time.



Ok i hope it's playable at least :wink:


Tbh Aeod feels like a mod that can't get any better since with the amount of content there is, but things can still change like improvements with the guns, gore system and etc. So in truth i'm actually pretty curious to see what's new this time.

Re: ÆoD (6.06.02 (03-14-16))

PostPosted: Thu Jan 12, 2017 8:45 am
by Major Cooke
Oh it will get better, just you wait.

Welp, after waiting long enough for opinions...

For: 2 (including my own)
Against: 0

So I'll prepare a beta release and update the AEoD.pk3. That way, if there's bugs and issues, you won't be redownloading the huge files over and over again -- you simply redownload the data package.

Stay tuned.

Re: ÆoD (6.06.02 (03-14-16))

PostPosted: Thu Jan 12, 2017 4:46 pm
by TheAdmantArchvile
Got this error while trying to run AEoD.

Image

I keep getting errors like this in different mods. Is it just me or is it the new version of GZdoom?

Re: ÆoD (6.06.02 (03-14-16))

PostPosted: Thu Jan 12, 2017 5:25 pm
by wildweasel
It's the new version of GZDoom. I'm unsure what to suggest, though, aside from running an older version.

Re: ÆoD (6.06.02 (03-14-16))

PostPosted: Fri Jan 13, 2017 4:21 pm
by Major Cooke
2.2 or somewhere along 2.1 would be sufficient I believe. However, there will crop up a fuckton more errors if someone tries to fix that, so just be patient for a bit while I sort things out and rummage up some substantial 6.07 release.

Re: ÆoD (6.06.02 (03-14-16))

PostPosted: Sat Jan 14, 2017 11:09 pm
by enderandrew
wildweasel wrote:It's the new version of GZDoom. I'm unsure what to suggest, though, aside from running an older version.


On Line 3339, it is expecting a '(' character, and it sees something else. That generally means the previous line didn't end properly.

On line 3339, A_Jump is called, but there is nothing in the function. It looks like the decorate code may have always been bugged, but gzdoom wasn't catching this error before.

Re: ÆoD (6.06.02 (03-14-16))

PostPosted: Sun Jan 15, 2017 11:04 am
by Major Cooke
Yeah. Now that the zscript parser is in, it had broken some old behavior and, incidentally, shown us where we kinda forgot to complete some bits of code. :P

Re: ÆoD (6.06.02 (03-14-16))

PostPosted: Sun Jan 22, 2017 7:03 am
by vincentzo
Need some help here! It just doesn't work!

Tried using latest versions of GZdoom, ZDoom, latest svn builds, ...I always end up getting script errors and the mod doesn't start up!

And yeah I got both of the files AEoDdat.pk3 and AEod. And yes I did add -file stuff....!

This one seems to be the most common!

"AEoDDat.pk3:cvarinfo.txt" line 10:
cvar 'user_WeaponSlotLimits' already exists

lol wtf?