Page 3 of 19

Re: Doom Tournament [Pre-Release]

PostPosted: Tue Jun 05, 2018 4:01 pm
by LossForWords
aw, that's the fun part of the translocator. other than the telefragging combos, of course.

Re: Doom Tournament [Pre-Release]

PostPosted: Tue Jun 05, 2018 5:49 pm
by Marisa Kirisame
Another small update:

  • Corrected thrust angle of all trace-based damages.
This issue has been in here since the very start and I didn't even realize. All enemies were being pushed in a fixed direction when they were damaged by any hitscans due to a little mistake from my part.

Re: Doom Tournament [Pre-Release]

PostPosted: Wed Jun 06, 2018 1:14 am
by mutator
mutator wrote:I meant to say you are able to pick up ammo when your ammunition is full

Are you sure? I don't see this happening at all. Are you running it with any other mods?[/quote]
Yes I just run the mod alone with nothing else.. But you only pick up the ammunition that zombies drop when they die, you are not able to pick up ammo that spawn on map when your ammo is full but able to pick up the ones that zombies drop and I use latest devbuild

Re: Doom Tournament [Pre-Release]

PostPosted: Wed Jun 06, 2018 3:47 am
by Rannick1982
While using the recommended versions of QZDoom and GZDoom dev builds, and the most recent version of Doom Tournament (downloaded from Github), I seem to be having an issue where autoaim is permanently on. Is anyone else having this issue?

I have tried with vanilla Doom and BrutalDoom monsters with the same result.

Have a great day!

Re: Doom Tournament [Pre-Release]

PostPosted: Wed Jun 06, 2018 4:11 am
by Rachael
Try an even newer one, does the problem still happen? What version ARE you using, specifically? Don't just say "newest one" because that can change fast.

Re: Doom Tournament [Pre-Release]

PostPosted: Wed Jun 06, 2018 6:23 pm
by Marisa Kirisame
Tiny update: Bumped up the minimum required GZDoom version to 3.4.0.

(The autoaim thing is fixed in it btw)

Re: Doom Tournament [Pre-Release]

PostPosted: Wed Jun 06, 2018 8:03 pm
by Rannick1982
Rachael wrote:Try an even newer one, does the problem still happen? What version ARE you using, specifically? Don't just say "newest one" because that can change fast.


Thank you for the replay Rachel, for GZDoom, I was using build gzdoom-g3.4pre-529-g7009755c5, and for QZDoom, QZDoom-q2.1pre-1756-gacc7997c3-x64, the 64-bit builds of both.

Re: Doom Tournament [Pre-Release]

PostPosted: Wed Jun 06, 2018 8:04 pm
by Rannick1982
Marisa Kirisame wrote:Tiny update: Bumped up the minimum required GZDoom version to 3.4.0.

(The autoaim thing is fixed in it btw)


Thank you Marisa, I will rebuild it this evening!

Re: Doom Tournament [Pre-Release]

PostPosted: Fri Jun 08, 2018 9:05 am
by Marisa Kirisame
Small update while I brew up the rest of the 1.0 changes:

  • Adjusted projectile speeds across the board, now more consistent with UT99.
  • Guided redeemer missile adjusts its velocity like in UT, no longer making sharp turns.

Re: Doom Tournament [Pre-Release]

PostPosted: Fri Jun 08, 2018 4:02 pm
by snarkel
When I tried booting it up with GZDoom 3.3.1 I still get the error saying its the wrong version

Re: Doom Tournament [Pre-Release]

PostPosted: Fri Jun 08, 2018 4:13 pm
by Dynamo
snarkel wrote:When I tried booting it up with GZDoom 3.3.1 I still get the error saying its the wrong version

Yes, it's because as the error message shows, you are using GZDoom 3.3.1 when the mod requires that you use 3.4.0. Upgrade it and it'll work.

Re: Doom Tournament [Pre-Release]

PostPosted: Fri Jun 08, 2018 4:36 pm
by wildweasel
I was goofing around with this (using an awfully large load order...so almost anything could be at fault here) and got this VM abort after reloading a save:
Image

Here is my load order:
Image

Re: Doom Tournament [Pre-Release]

PostPosted: Sat Jun 09, 2018 1:28 am
by snarkel
oh gosh, now I feel stupid. I read that error message in the wrong way dangit, i'll be sure to try updating instead of downgrading lol ^^'

Re: Doom Tournament [Pre-Release]

PostPosted: Sat Jun 09, 2018 2:06 am
by fakemai
I'm gonna say it's not your fault, that message is really badly worded to a typical user. It should say "Mod xyzzy requires at least GZDoom version x.x.x, please update your GZDoom" or something to that effect. I realize it won't chase away every single instance of this question but anything to reduce ambiguity would be nice.

Re: Doom Tournament [Pre-Release]

PostPosted: Sat Jun 09, 2018 5:02 am
by Marisa Kirisame
@ww: any specifics on what was happening when you saved? Was there a Redeemer explosion in the world? Because I think I know what happened.

Edit: New update pushed

  • Changed up all the model offsets again due to complaints about inconsistency with UT.
  • Added view-space effects to Enforcer and Biorifle, others will follow soon.
  • Added smoke particles to spent casings.
  • Added green smoke particles to biorifle sludge explosions.
  • Touched up how rockets and grenades are fired.
  • Fixed a VM abort when the game is loaded while there's a Redeemer blast active.
  • Allow refire of pulsegun and minigun during cooldown/unwind.