Vanilla Essence 4.3: 320x200p support! More bugfixes.

Projects that alter game functions but do not include new maps belong here.
Forum rules
The Projects forums are ONLY for YOUR PROJECTS! If you are asking questions about a project, either find that project's thread, or start a thread in the General section instead.

Got a cool project idea but nothing else? Put it in the project ideas thread instead!

Projects for any Doom-based engine (especially 3DGE) are perfectly acceptable here too.

Please read the full rules for more details.

Re: Vanilla Essence 4.3: 320x200p support! More bugfixes.

Postby PhysixCat » Sat Sep 07, 2019 2:59 pm

Another thing I noticed:

VanillaEssence seems to set the cl_doautoaim CVAR to True when we tell it to use autoaim, but this isn't necessary. Just toggling the autoaim from 0 to 35 should correctly activate autoaim by itself. If the cl_doautoaim is used, it can result in unintended behavior (for example, even things in mods that are flagged as +NOTAUTOAIMED will be targetted by the autoaim instead of actual enemies, because cl_doautoaim ignores that flag)
User avatar
PhysixCat
 
Joined: 15 Jan 2019

Re: Vanilla Essence 4.3: 320x200p support! More bugfixes.

Postby Pixel Eater » Wed Sep 11, 2019 7:19 pm

Appreciate the info everyone...

I haven't had as much time to work on things or do much testing, so I'm going to post this version as a release candidate here instead of the OP.

The changes that I can remember:
It won't override changes you've made in the proper menu while it was active.
There's more customisation of the automap.
The rocket has it's dynamic light back.
The low-res pixelation has a cleaner render.
The CRY colourspace setting has an extra option.
The flashing disk/hourglass icon is built in now.
Interpolation options are fixed and the forced aiming removed.
New compatibility options "Doom w/Ammo dogaflop" & "Doom strict w/Leap frogging"
Attachments
Vanilla Essence 4.4rc1.pk3
(91.39 KiB) Downloaded 19 times
User avatar
Pixel Eater
I sense evil I fear it here today, Like a bad dream that never goes away -MBerry
 
 
 
Joined: 02 Aug 2017
Location: In between the Moon and you, between the buried and me.

Re: Vanilla Essence 4.3: 320x200p support! More bugfixes.

Postby Trimint123 » Thu Sep 12, 2019 8:42 am

Something I wanna point it out is that the Fullscreen HUD doesn't actually match with the resolution on wide-screen, as a result, makes the HUD had noticeable cut out.
This was visible on Hexen and Strife (without mod that fixed it, of course).
https://imgur.com/a/Va6L7fj
Trimint123
 
Joined: 05 Mar 2019
Discord: Trimint123#1987
Operating System: Windows Vista/7 64-bit
Graphics Processor: Not Listed

Re: Vanilla Essence 4.3: 320x200p support! More bugfixes.

Postby Pixel Eater » Thu Sep 12, 2019 4:29 pm

If you go to Options > Vanilla Essence > Interface and set the UI Scale slider to max (and retoggle vanilla) does that solve the problem?
User avatar
Pixel Eater
I sense evil I fear it here today, Like a bad dream that never goes away -MBerry
 
 
 
Joined: 02 Aug 2017
Location: In between the Moon and you, between the buried and me.

Re: Vanilla Essence 4.3: 320x200p support! More bugfixes.

Postby Trimint123 » Thu Sep 12, 2019 9:38 pm

Doesn't seems to work.
While messing around the option, I noticed that it works on certain wide-screen resolutions.
1280x720 works flawlessly, but my current monitor I have (1360x768 monitor on Full-Screen) had cut off.
I think it has to do with the user interface scale to prevent shimmering on the UI.
Trimint123
 
Joined: 05 Mar 2019
Discord: Trimint123#1987
Operating System: Windows Vista/7 64-bit
Graphics Processor: Not Listed

Re: Vanilla Essence 4.3: 320x200p support! More bugfixes.

Postby Pixel Eater » Thu Sep 12, 2019 10:48 pm

I see what you mean, I'm getting the same problem with certain resolutions (I never noticed because I usually stick to my native one). It does it without even loading vanilla essence so I think this is just how GZDoom works, because it uses integers to scale the UI.
User avatar
Pixel Eater
I sense evil I fear it here today, Like a bad dream that never goes away -MBerry
 
 
 
Joined: 02 Aug 2017
Location: In between the Moon and you, between the buried and me.

Re: Vanilla Essence 4.3: 320x200p support! More bugfixes.

Postby PhysixCat » Fri Sep 13, 2019 12:28 am

Hi PixelEater! Thank you so much for this release candidate you posted above.

Gave it a download and here are some initial observations:
- It correctly resets compat settings on exit now!
- Monster interpolation toggle now works correctly!
- Autoaim toggle stopped using cl_doautoaim! So mods (like UniversalGibs) can freely use +NOTAUTOAIMED without problems now

Now some questions I have:
- How come ve_b_doautoaim=true and ve_a_doautoaim=true both result in cl_doautoaim=false ? Are they dummy cvars that are gonna get dumped later?
- I'm afraid I don't really understand the new "ammo dogaflop" and "leap frogging" compat modes. I know you said earlier in the thread that your significant other told you "dogaflop" means the opposite of catapult, but I haven't been able to find a source for that, or what that even means gameplay wise :? . As for leap frogging, does that mean infinitely tall actors are disabled, or does that mean monsters can climb over each other?
- For the toggle VE sound, did you mean to change it from the TV static noise to the regular menu sound? Not that I have a preference in this, just checking if it was intentional
- In the configure low-res menu, why is the Pixel Aspect 1:1 the default, if it wasn't the PC default? Because it looks better? Just curious.
- In that same low-res config menu, I'm also not clear what the Smoothing and Advanced options do. I noticed ve_smooth is now ve_smoothlog. Could you please explain what these do?

For some small bugs I noticed:
- Under the Vanilla Essence -> Interface menu, the Show Monsters and Show Secrets toggles have a problem. They *DO* work as intended for the feature, but when they are enabled, if you toggle VE on/off, you'll see messages in the console that say:
Unknown command "true"

And finally, for some QoL suggestions (since I saw you made some on this rc)
- As the Anisotropic Filtering now is default set to Recommended 16x, I would also suggest setting Texture Filter Mode to "None (Nearest Mipmap)" as the Recommended setting, with the Vanilla obviously being just None.
- In the Low-Resolution menu, for the 400p option, I'd suggest adding a parentheses that says (Crispy Doom) or something like that next to it, so that people can easily pick that out if they don't remember the number off the top their head
- Would you consider adding your SCREEM palette to the Tonemapping section in Appearance? Sorry if it's a silly question, I don't even know if SCREEM qualifies as tonemapping.
User avatar
PhysixCat
 
Joined: 15 Jan 2019

Re: Vanilla Essence 4.3: 320x200p support! More bugfixes.

Postby Pixel Eater » Fri Sep 13, 2019 9:02 am

Heya PhysixCat. Thanks for your insights!

To answer your questions in order:
-Assuming you mean the cvarinfo entries, those ve_a_doautoaim etc lines were meant to be commented out as they don't serve a function anymore. The fact they are declared true is just to provide a default for first time use. The ve_b_ & ve_c_'s don't even need to be set either, the values are only there from me copying the ve_a_ block repeatedly.
-You got the leap frogging right, it's to do with infintely tall actors. Ammo dogaflop is where the items that monsters drop aren't flung upwards but will just rest on the floor.
-The static sound was a temporary solve until I better understood how the soundinfo stuff works. It used to be the menu sound but I linked to it in a way that caused an error in Hexen.
-Ack that is a mistake, it definitely should be 5:6!
-ve_smooth became ve_smoothx & ve_smoothy so we can control the smoothing of the axes independently. The lin/log slider sets the curve of the blend between pixels. Linear was the old style which is pretty blurry and log starts to reveal the squarish shape of the pixels.
-'Include PSprite' dictates whether the player sprite gets the low res and smoothing treatment. At 200p it can mean the bobbing is jerky like vanilla Doom but under the wrong conditions can look ugly. Swapping this around can fix some colour issues with palette tonemapping or CRY space when combined with smoothing.
-The quantize options can improve low res visuals by snapping the division of pixels to the nearest whole number (not even sure that I make any sense there, heh). It doesn't always look better either but it's a tool you can use. Also note that it can mean different pixel row values can look identical as they wind up at the same average "best fit" for your screen's resolution.

The Bug stuff:
The show monsters/secrets bug turned out to be a typo where I left out the "==" after some "test" commands in keyconf.txt.
Trying to find the cause (I wasn't getting warnings strangely) revealed that the same cvars weren't being affected by the menu reset command.

The Qol stuff:
-The reason Anisotropic filtering is recommended is because someone suggested it's actually closer to how vanilla looked, even though it didn't originally have that feature. It's something to do with column drawing if I recall correctly?
(It may be a similar situation with vertical sync as well but I'm not sure if that's something I've read or just imagined.)
As far as I know though, 'no filtering' is still the closest to vanilla and it's what I'd recommend for that.
-The crispy doom designator at 400p is a nice idea, I've added it into rc2.
-The shader used to create the palette might find it's way into vanilla essence eventually but it still needs work. The palette wouldn't be suitable because it only replaces the stock Doom palette. The shader however is universally applicable to any wad's palette and can be toggled too.
Attachments
Vanilla Essence 4.4rc2.pk3
(91.41 KiB) Downloaded 16 times
User avatar
Pixel Eater
I sense evil I fear it here today, Like a bad dream that never goes away -MBerry
 
 
 
Joined: 02 Aug 2017
Location: In between the Moon and you, between the buried and me.

Re: Vanilla Essence 4.3: 320x200p support! More bugfixes.

Postby Trimint123 » Fri Sep 13, 2019 9:10 am

Pixel Eater wrote:I see what you mean, I'm getting the same problem with certain resolutions (I never noticed because I usually stick to my native one). It does it without even loading vanilla essence so I think this is just how GZDoom works, because it uses integers to scale the UI.


Actually, set the Letterbox Ratio to 5:4 is the best option for wide-screen to prevent cut off UI since it's slightly larger than 4:3, so I think I may use that one for wide-screen only.
Trimint123
 
Joined: 05 Mar 2019
Discord: Trimint123#1987
Operating System: Windows Vista/7 64-bit
Graphics Processor: Not Listed

Re: Vanilla Essence 4.3: 320x200p support! More bugfixes.

Postby PhysixCat » Fri Sep 13, 2019 10:54 am

I see! Thank you for answering my questions, and for rc2.

As for the "leapfrogging" and "ammo dogaflop" options, would you consider maybe separating them into a different toggle below the compat mode? So that we can also have "Boom (strict) + leapfrogging + dogaflop" for example, and it doesn't end up crowding the compat selection with many leapfrog/dogaflop variants. I would also suggest maybe changing their name, or adding a description below the option, so that it's more readily apparent what they do

As for the bug fixes and features in rc2, everything else seems peachy from initial testing.

I do have a question - I've noticed it before in other releases, but I thought I might as well bring it up now.
I've noticed in certain maps that you'll get white pixels here and there with VE turned on. When VE is off, they are still there, but very hard to see obviously. This can be fixed by switching from 5:6 Pixel Aspect to 1:1, or by enabling QuantizeHeight/QuantizeWidth - either of those options will make them not appear when VE is turned on (sometimes, this isn't 100% effective though). Do you know what these are? Are they mapping errors?

(See near bottom right of crosshair, two white pixels)
https://i.imgur.com/ElUBEvk.png

PS: Sorry for being a forum noob, but how do you attach images straight from imgur? I know there's a link in the post editor to imgur, but I've only been able to make it work like a URL so far.
User avatar
PhysixCat
 
Joined: 15 Jan 2019

Previous

Return to Gameplay Mods

Who is online

Users browsing this forum: irukanjji, Shadez12 and 10 guests