[Community Sequel] [FINISHED] 40 Monsters Challenge

New maps, and other projects whose primary focus is new maps, belong here.

NOTE: This forum, and all forums below it, are NOT for questions or troubleshooting! Threads here are for active projects only! Please use the Editing subforums or General for questions.
Forum rules
The Projects forums are ONLY for YOUR PROJECTS! If you are asking questions about a project, either find that project's thread, or start a thread in the General section instead.

Got a cool project idea but nothing else? Put it in the project ideas thread instead!

Projects for any Doom-based engine (especially 3DGE) are perfectly acceptable here too.

Please read the full rules for more details.

Re: [Community Sequel] 40 Monsters Challenge

Postby Blue Shadow » Tue Sep 01, 2020 7:04 am

@CBM: how can I put this?... you're making way too many posts in this thread. You don't need to update the rest of the team on every bit of progress you make on your maps. And the screenshots, even though they're thumbnail-sized, the whole thing is countered by the fact that you post a lot of them.

So try to keep things under control, will you?
User avatar
Blue Shadow
 
Joined: 14 Nov 2010
Operating System: Windows 10/8.1/8/201x 64-bit
OS Test Version: No (Using Stable Public Version)
Graphics Processor: ATI/AMD (Modern GZDoom)

Re: [Community Sequel] 40 Monsters Challenge

Postby CBM » Tue Sep 01, 2020 7:30 am

Blue Shadow wrote:@CBM: how can I put this?... you're making way too many posts in this thread. You don't need to update the rest of the team on every bit of progress you make on your maps. And the screenshots, even though they're thumbnail-sized, the whole thing is countered by the fact that you post a lot of them.

So try to keep things under control, will you?

ok
User avatar
CBM
Imp Slayer
 
Joined: 09 Oct 2019
Location: The Shores of Hell
Operating System: Windows 10/8.1/8/201x 64-bit
OS Test Version: Yes (Using Development/Testing Version)
Graphics Processor: nVidia with Vulkan support

Re: [Community Sequel] 40 Monsters Challenge

Postby howeartistic » Tue Sep 01, 2020 8:26 am

@CBM: Man, just saw the progress on the temple, looks great! That is a ton of screenshots though, lmao!
We should make a hang thread for this project so we can share updates. Unless that already exists?

I've been trying to get myself into a map for the challenge. I've got 5 started, lol. I keep getting too into it and making a huge complex level. Anywho, the current one I'm really liking, would anyone wanna take a run through it? There's no monsters or items, just trying to get a nice flow through first. Stay safe, friendos! :D
User avatar
howeartistic
 
Joined: 16 Aug 2020

Re: [Community Sequel] 40 Monsters Challenge

Postby CBM » Tue Sep 01, 2020 9:56 am

howeartistic wrote:@CBM: Man, just saw the progress on the temple, looks great! That is a ton of screenshots though, lmao!
We should make a hang thread for this project so we can share updates. Unless that already exists?

I've been trying to get myself into a map for the challenge. I've got 5 started, lol. I keep getting too into it and making a huge complex level. Anywho, the current one I'm really liking, would anyone wanna take a run through it? There's no monsters or items, just trying to get a nice flow through first. Stay safe, friendos! :D


thanks

the whole portal thing turned out to be problematic when line portals and 3d floors are combined so I did a sector portal in the aztek pyramid temple instead

just need to add spawn code and some more details then I can give our fearless leader an alpha release of that map

just hope my cs/call of duty/urban doom map will be just as good. I figured it could be fun to hunt demons in an urban setting

there is no hang out thread
User avatar
CBM
Imp Slayer
 
Joined: 09 Oct 2019
Location: The Shores of Hell
Operating System: Windows 10/8.1/8/201x 64-bit
OS Test Version: Yes (Using Development/Testing Version)
Graphics Processor: nVidia with Vulkan support

Re: [Community Sequel] 40 Monsters Challenge

Postby CBM » Tue Sep 01, 2020 12:31 pm

first alpha for the new aztek pyramid temple map for slot 33 and
first alpha for the new monster city map for slot 34...

https://www.dropbox.com/s/8ppja91grgh0s ... 4.rar?dl=0
User avatar
CBM
Imp Slayer
 
Joined: 09 Oct 2019
Location: The Shores of Hell
Operating System: Windows 10/8.1/8/201x 64-bit
OS Test Version: Yes (Using Development/Testing Version)
Graphics Processor: nVidia with Vulkan support

Re: [Community Sequel] 40 Monsters Challenge

Postby howeartistic » Wed Sep 02, 2020 8:38 am

CBM wrote:first alpha for the new aztek pyramid temple map for slot 33 and
first alpha for the new monster city map for slot 34...


Hey dude! Played both, unfortunately I couldn't get past the temple in aztec. Teleport broke? Also, left side of the stairs were missing a texture. I like the idea of the city, but it destroyed my frames, lmao. Maybe more doors and teleport monsters in so they don't all rush you at once? I'm excited to see more of both! :D

My tech hell factory thing is like... 50% done? I've got zombiemen placeholders atm, but I'd love feedback if anyone wants to give it a shot.
User avatar
howeartistic
 
Joined: 16 Aug 2020

Re: [Community Sequel] 40 Monsters Challenge

Postby Accensus » Wed Sep 02, 2020 8:54 am

Post it here or PM it to me. I may not be able to take a look immediately so please wait. Got some IRL things to take care of in the next few days.
Accensus
 
Joined: 11 Feb 2016

Re: [Community Sequel] 40 Monsters Challenge

Postby CBM » Wed Sep 02, 2020 8:56 am

howeartistic wrote:
CBM wrote:first alpha for the new aztek pyramid temple map for slot 33 and
first alpha for the new monster city map for slot 34...


Hey dude! Played both, unfortunately I couldn't get past the temple in aztec. Teleport broke? Also, left side of the stairs were missing a texture. I like the idea of the city, but it destroyed my frames, lmao. Maybe more doors and teleport monsters in so they don't all rush you at once? I'm excited to see more of both! :D

My tech hell factory thing is like... 50% done? I've got zombiemen placeholders atm, but I'd love feedback if anyone wants to give it a shot.

thanks for the feedback, I will look at it, were you using gzdoom? because the portal works fine and I see no missing textures.. running map analysis to be sure though... also... runnning to fast makes you overshoot the entrance

Accensus wrote:Post it here or PM it to me. I may not be able to take a look immediately so please wait. Got some IRL things to take care of in the next few days.


wait for alpha 2 of my map 33 and 34

done.. alpha 2

https://www.dropbox.com/s/u9qay3z41q0mn ... 2.pk3?dl=0

changes:
aztek
* made lines behind entrance impassable so no overshoot can occur anymore
* checked whole map with map analyzer and fixed anything it found
monster city
* removed the multilevel 3D tower to improve FPS on potato rigs
User avatar
CBM
Imp Slayer
 
Joined: 09 Oct 2019
Location: The Shores of Hell
Operating System: Windows 10/8.1/8/201x 64-bit
OS Test Version: Yes (Using Development/Testing Version)
Graphics Processor: nVidia with Vulkan support

Re: [Community Sequel] 40 Monsters Challenge

Postby 9Rifleman » Fri Sep 04, 2020 5:31 am

So, I have finished fixing my maps, with the exception of 36, where I found a problem and I need your input on this, Accensus. No rush though.

Spoiler:
User avatar
9Rifleman
Ripeth and teareth
 
Joined: 15 Dec 2019
Operating System: Windows 10/8.1/8/201x 64-bit
OS Test Version: Yes (Using Development/Testing Version)
Graphics Processor: ATI/AMD with Vulkan Support

Re: [Community Sequel] 40 Monsters Challenge

Postby CBM » Fri Sep 04, 2020 7:42 am

9Rifleman wrote:So, I have finished fixing my maps, with the exception of 36, where I found a problem and I need your input on this, Accensus. No rush though.

Spoiler:


would you mind testing maps 33 and 34 for me?
User avatar
CBM
Imp Slayer
 
Joined: 09 Oct 2019
Location: The Shores of Hell
Operating System: Windows 10/8.1/8/201x 64-bit
OS Test Version: Yes (Using Development/Testing Version)
Graphics Processor: nVidia with Vulkan support

Re: [Community Sequel] 40 Monsters Challenge

Postby Accensus » Fri Sep 04, 2020 10:20 am

9Rifleman wrote:So, I have finished fixing my maps, with the exception of 36, where I found a problem and I need your input on this, Accensus. No rush though.

Spoiler:

One solution is to use https://zdoom.org/wiki/TeleportInSector. The other involves giving the players custom TIDs on map start, which I recall has numerous problems with compatibility so let's not do that.

As for the observing part, you can take a look at 20MCP's MAP42. Try opening it in local co-op and have one player go through the teleporter. The giant cinema screen will turn into a camera that follows the player doing the maze. It was the first makeshift solution I could think of at the time.
Accensus
 
Joined: 11 Feb 2016

Re: [Community Sequel] 40 Monsters Challenge

Postby howeartistic » Fri Sep 04, 2020 10:39 am

Hey y'all! So, here's my progress. I have to polish textures, tweak monsters and items, and finish the last room (it's just a placeholder for the moment, I like to leave it til last and crank er to 11).
I would love your thoughts on it. Oh, I guess the mutator is one colour, I may add damaging floors (floor is lava), but not sure.
I've been having a blast so far! :D Stay safe, my dudes!

I call it "Refined Tastes". :twisted:

https://drive.google.com/file/d/1NHo3OL ... sp=sharing
User avatar
howeartistic
 
Joined: 16 Aug 2020

Re: [Community Sequel] 40 Monsters Challenge

Postby CBM » Fri Sep 04, 2020 11:41 am

awaiting test of my alpha 2 version of maps 33 and 34
User avatar
CBM
Imp Slayer
 
Joined: 09 Oct 2019
Location: The Shores of Hell
Operating System: Windows 10/8.1/8/201x 64-bit
OS Test Version: Yes (Using Development/Testing Version)
Graphics Processor: nVidia with Vulkan support

Re: [Community Sequel] 40 Monsters Challenge

Postby 9Rifleman » Sat Sep 05, 2020 12:18 am

@CBM:
would you mind testing maps 33 and 34 for me?


I did try them. They seem to be on a good way. Some remarks below:

Spoiler:


@howe:

While I was at it, I tried yours too:

Spoiler:


@Accensus:

Spoiler:
User avatar
9Rifleman
Ripeth and teareth
 
Joined: 15 Dec 2019
Operating System: Windows 10/8.1/8/201x 64-bit
OS Test Version: Yes (Using Development/Testing Version)
Graphics Processor: ATI/AMD with Vulkan Support

Re: [Community Sequel] 40 Monsters Challenge

Postby Accensus » Sat Sep 05, 2020 2:48 am

9Rifleman wrote:I assigned the TID to players using Thing_ChangeTID through ENTER script(player tids 700-703), but if need be, I suppose I could figure out a script to assign TIDs and avoid this.

You basically did just that. :P
Honestly it's been so long since I last encountered an issue with player TIDs that I don't even remember what went wrong back then, so let's keep this solution until it breaks.
Accensus
 
Joined: 11 Feb 2016

PreviousNext

Return to Levels

Who is online

Users browsing this forum: dastrukar and 4 guests